summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-07-27 21:32:53 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-07-27 21:32:53 +0000
commit9082cee4f6a98480f5bc56e24dd2c79e2d36df13 (patch)
treeeb4960831fc2bcd2a23376f73c199f4b75a41395 /sci-visualization
parentVersion bump (diff)
downloadgentoo-2-9082cee4f6a98480f5bc56e24dd2c79e2d36df13.tar.gz
gentoo-2-9082cee4f6a98480f5bc56e24dd2c79e2d36df13.tar.bz2
gentoo-2-9082cee4f6a98480f5bc56e24dd2c79e2d36df13.zip
Version bump
(Portage version: 2.1.10.7/cvs/Linux x86_64)
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/epix/ChangeLog9
-rw-r--r--sci-visualization/epix/epix-1.2.8.ebuild66
2 files changed, 73 insertions, 2 deletions
diff --git a/sci-visualization/epix/ChangeLog b/sci-visualization/epix/ChangeLog
index 118bced69388..c1dd15a4a91f 100644
--- a/sci-visualization/epix/ChangeLog
+++ b/sci-visualization/epix/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-visualization/epix
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/epix/ChangeLog,v 1.34 2010/05/04 22:38:17 bicatali Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/epix/ChangeLog,v 1.35 2011/07/27 21:32:53 bicatali Exp $
+
+*epix-1.2.8 (27 Jul 2011)
+
+ 27 Jul 2011; Sébastien Fabbro <bicatali@gentoo.org> +epix-1.2.8.ebuild:
+ Version bump
*epix-1.2.7 (04 May 2010)
diff --git a/sci-visualization/epix/epix-1.2.8.ebuild b/sci-visualization/epix/epix-1.2.8.ebuild
new file mode 100644
index 000000000000..1b43f255a956
--- /dev/null
+++ b/sci-visualization/epix/epix-1.2.8.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/epix/epix-1.2.8.ebuild,v 1.1 2011/07/27 21:32:53 bicatali Exp $
+
+EAPI=4
+inherit elisp-common bash-completion autotools
+
+DESCRIPTION="2- and 3-D plotter for creating images (to be used in LaTeX)"
+HOMEPAGE="http://mathcs.holycross.edu/~ahwang/current/ePiX.html"
+SRC_URI="http://mathcs.holycross.edu/~ahwang/epix/${P}_withpdf.tar.bz2"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc emacs examples"
+
+DEPEND="virtual/latex-base
+ || ( ( dev-texlive/texlive-pstricks
+ dev-texlive/texlive-pictures
+ dev-texlive/texlive-latexextra
+ dev-tex/xcolor )
+ app-text/ptex )
+ emacs? ( virtual/emacs )"
+RDEPEND="${DEPEND}"
+SITEFILE=50${PN}-gentoo.el
+
+src_prepare() {
+ # disable automatic install of doc and examples
+ epatch "${FILESDIR}"/${PN}-1.2.7-doc-gentoo.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --docdir=/usr/share/doc/${PF} \
+ --disable-epix-el
+}
+
+src_install() {
+ default
+ if use emacs; then
+ # do compilation here as the make install target will
+ # create the .el file
+ elisp-compile *.el || die "elisp-compile failed!"
+ elisp-install ${PN} *.elc *.el || die "elisp-install failed!"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+ dobashcompletion bash_completions
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins doc/*gz
+ fi
+ if use examples; then
+ cd samples
+ insinto /usr/share/doc/${PF}/examples
+ doins *.xp *.flx *c *h README
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}