summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris PeBenito <pebenito@gentoo.org>2007-03-29 23:37:51 +0000
committerChris PeBenito <pebenito@gentoo.org>2007-03-29 23:37:51 +0000
commit281a4012ce9549ba931cd3cb723ed4cbe7d5a17f (patch)
tree7151eda0a3fde9237030f265f4ec3f2c8417b438 /sec-policy/selinux-base-policy
parentStable on x86. (diff)
downloadgentoo-2-281a4012ce9549ba931cd3cb723ed4cbe7d5a17f.tar.gz
gentoo-2-281a4012ce9549ba931cd3cb723ed4cbe7d5a17f.tar.bz2
gentoo-2-281a4012ce9549ba931cd3cb723ed4cbe7d5a17f.zip
New SELinux policy from SVN snapshot
(Portage version: 2.1.2.2)
Diffstat (limited to 'sec-policy/selinux-base-policy')
-rw-r--r--sec-policy/selinux-base-policy/ChangeLog8
-rw-r--r--sec-policy/selinux-base-policy/files/digest-selinux-base-policy-200703293
-rw-r--r--sec-policy/selinux-base-policy/selinux-base-policy-20070329.ebuild105
3 files changed, 115 insertions, 1 deletions
diff --git a/sec-policy/selinux-base-policy/ChangeLog b/sec-policy/selinux-base-policy/ChangeLog
index db1633cbf8db..01603bc0dcd9 100644
--- a/sec-policy/selinux-base-policy/ChangeLog
+++ b/sec-policy/selinux-base-policy/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sec-policy/selinux-base-policy
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sec-policy/selinux-base-policy/ChangeLog,v 1.55 2007/02/22 01:05:35 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/sec-policy/selinux-base-policy/ChangeLog,v 1.56 2007/03/29 23:37:50 pebenito Exp $
+
+*selinux-base-policy-20070329 (29 Mar 2007)
+
+ 29 Mar 2007; Chris PeBenito <pebenito@gentoo.org>
+ +selinux-base-policy-20070329.ebuild:
+ New SVN snapshot.
22 Feb 2007; Markus Ullmann <jokey@gentoo.org> ChangeLog:
Redigest for Manifest2
diff --git a/sec-policy/selinux-base-policy/files/digest-selinux-base-policy-20070329 b/sec-policy/selinux-base-policy/files/digest-selinux-base-policy-20070329
new file mode 100644
index 000000000000..f827edfb8f91
--- /dev/null
+++ b/sec-policy/selinux-base-policy/files/digest-selinux-base-policy-20070329
@@ -0,0 +1,3 @@
+MD5 4c103a26e8d4bce3ce0e6d4ce7651374 refpolicy-20070329.tar.bz2 313327
+RMD160 1d30ae525f3d7b429d100f9b7d1bd43395ba0612 refpolicy-20070329.tar.bz2 313327
+SHA256 e0c82834a62b584578250230651a49c00a13e6be8689611326f6fac06e2d88fa refpolicy-20070329.tar.bz2 313327
diff --git a/sec-policy/selinux-base-policy/selinux-base-policy-20070329.ebuild b/sec-policy/selinux-base-policy/selinux-base-policy-20070329.ebuild
new file mode 100644
index 000000000000..2e212327d399
--- /dev/null
+++ b/sec-policy/selinux-base-policy/selinux-base-policy-20070329.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sec-policy/selinux-base-policy/selinux-base-policy-20070329.ebuild,v 1.1 2007/03/29 23:37:50 pebenito Exp $
+
+IUSE=""
+
+inherit eutils
+
+DESCRIPTION="Gentoo base policy for SELinux"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/selinux/"
+SRC_URI="http://oss.tresys.com/files/refpolicy/refpolicy-${PV}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+
+#KEYWORDS="~x86 ~ppc ~sparc ~amd64 ~mips ~alpha"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~sparc ~x86"
+
+RDEPEND=">=sys-apps/policycoreutils-1.30.30"
+DEPEND="${RDEPEND}
+ sys-devel/m4
+ >=sys-apps/checkpolicy-1.30.12"
+
+S=${WORKDIR}/
+
+src_unpack() {
+ [ -z "${POLICY_TYPES}" ] && local POLICY_TYPES="strict targeted"
+
+ unpack ${A}
+
+ for i in ${POLICY_TYPES}; do
+ mkdir -p ${S}/${i}/policy
+ cp ${FILESDIR}/modules.conf.${i} ${S}/${i}/policy/modules.conf
+ done
+}
+
+src_compile() {
+ local OPTS="MONOLITHIC=n DISTRO=gentoo QUIET=y"
+ [ -z "${POLICY_TYPES}" ] && local POLICY_TYPES="strict targeted"
+
+ cd ${S}/refpolicy
+
+ make ${OPTS} generate || die "Failed to create generated module files"
+
+ make ${OPTS} xml || die "XML generation failed."
+
+ for i in ${POLICY_TYPES}; do
+# make ${OPTS} TYPE=${i} NAME=${i} LOCAL_ROOT=${S}/${i} conf \
+# || die "${i} modules.conf update failed"
+
+ make ${OPTS} TYPE=${i} NAME=${i} LOCAL_ROOT=${S}/${i} base \
+ || die "${i} compile failed"
+ done
+}
+
+src_install() {
+ local OPTS="MONOLITHIC=n DISTRO=gentoo QUIET=y DESTDIR=${D}"
+ [ -z "${POLICY_TYPES}" ] && local POLICY_TYPES="strict targeted"
+
+ cd ${S}/refpolicy
+
+ for i in ${POLICY_TYPES}; do
+ make ${OPTS} TYPE=${i} NAME=${i} LOCAL_ROOT=${S}/${i} install \
+ || die "${i} install failed."
+
+ make ${OPTS} TYPE=${i} NAME=${i} install-headers \
+ || die "${i} headers install failed."
+
+ echo "run_init_t" > ${D}/etc/selinux/${i}/contexts/run_init_type
+
+ echo "textrel_shlib_t" >> ${D}/etc/selinux/${i}/contexts/customizable_types
+
+ # libsemanage won't make this on its own
+ keepdir /etc/selinux/${i}/policy
+ done
+
+ dodoc doc/Makefile.example doc/example.{te,fc,if}
+
+ insinto /etc/selinux
+ doins ${FILESDIR}/config
+}
+
+pkg_postinst() {
+ [ -z "${POLICY_TYPES}" ] && local POLICY_TYPES="strict targeted"
+
+ if has "loadpolicy" $FEATURES ; then
+ for i in ${POLICY_TYPES}; do
+ einfo "Inserting base module into ${i} module store."
+
+ cd /usr/share/selinux/${i}
+ semodule -s ${i} -b base.pp
+ done
+ else
+ echo
+ echo
+ eerror "Policy has not been loaded. It is strongly suggested"
+ eerror "that the policy be loaded before continuing!!"
+ echo
+ einfo "Automatic policy loading can be enabled by adding"
+ einfo "\"loadpolicy\" to the FEATURES in make.conf."
+ echo
+ echo
+ ebeep 4
+ epause 4
+ fi
+}