summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2014-04-25 22:57:20 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2014-04-25 22:57:20 +0000
commit639d797e57eb7854c959c737600524f7fc9396ac (patch)
treee60b51527cec6c3e1be325e85d4873ef81076e89 /sys-apps/accountsservice
parentFix static lib requirements for USE=static-user #487918 by jannis. (diff)
downloadgentoo-2-639d797e57eb7854c959c737600524f7fc9396ac.tar.gz
gentoo-2-639d797e57eb7854c959c737600524f7fc9396ac.tar.bz2
gentoo-2-639d797e57eb7854c959c737600524f7fc9396ac.zip
Version bump.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'sys-apps/accountsservice')
-rw-r--r--sys-apps/accountsservice/ChangeLog8
-rw-r--r--sys-apps/accountsservice/accountsservice-0.6.37.ebuild57
2 files changed, 64 insertions, 1 deletions
diff --git a/sys-apps/accountsservice/ChangeLog b/sys-apps/accountsservice/ChangeLog
index 9cb44213f65a..dc18ad974c11 100644
--- a/sys-apps/accountsservice/ChangeLog
+++ b/sys-apps/accountsservice/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/accountsservice
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/accountsservice/ChangeLog,v 1.40 2014/04/18 19:51:08 swift Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/accountsservice/ChangeLog,v 1.41 2014/04/25 22:57:20 eva Exp $
+
+*accountsservice-0.6.37 (25 Apr 2014)
+
+ 25 Apr 2014; Gilles Dartiguelongue <eva@gentoo.org>
+ +accountsservice-0.6.37.ebuild:
+ Version bump.
18 Apr 2014; Sven Vermeulen <swift@gentoo.org>
accountsservice-0.6.29-r1.ebuild, accountsservice-0.6.34.ebuild,
diff --git a/sys-apps/accountsservice/accountsservice-0.6.37.ebuild b/sys-apps/accountsservice/accountsservice-0.6.37.ebuild
new file mode 100644
index 000000000000..e19283cdac50
--- /dev/null
+++ b/sys-apps/accountsservice/accountsservice-0.6.37.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/accountsservice/accountsservice-0.6.37.ebuild,v 1.1 2014/04/25 22:57:20 eva Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit eutils gnome2 systemd
+
+DESCRIPTION="D-Bus interfaces for querying and manipulating user account information"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/AccountsService/"
+SRC_URI="http://www.freedesktop.org/software/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="doc +introspection selinux systemd"
+
+RDEPEND="
+ >=dev-libs/glib-2.37.3:2
+ sys-auth/polkit
+ introspection? ( >=dev-libs/gobject-introspection-0.9.12 )
+ selinux? ( sec-policy/selinux-accountsd )
+ systemd? ( >=sys-apps/systemd-186:0= )
+ !systemd? ( sys-auth/consolekit )
+"
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ dev-util/gdbus-codegen
+ >=dev-util/gtk-doc-am-1.15
+ >=dev-util/intltool-0.40
+ sys-devel/gettext
+ virtual/pkgconfig
+ doc? (
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/xmlto )
+"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-0.6.35-gentoo-system-users.patch"
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ --disable-more-warnings \
+ --localstatedir="${EPREFIX}"/var \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --enable-admin-group="wheel" \
+ $(use_enable doc docbook-docs) \
+ $(use_enable introspection) \
+ $(use_enable systemd) \
+ $(systemd_with_unitdir)
+}