summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-10-10 00:26:05 +0000
committerMike Frysinger <vapier@gentoo.org>2004-10-10 00:26:05 +0000
commit6c1693d6ea2fab3cb337510ce472abb4f3720327 (patch)
tree453591d49af437860198e08de10185bf9ea400c5 /sys-apps/acl
parentAdded ~sparc keyword. (Manifest recommit) (diff)
downloadgentoo-2-6c1693d6ea2fab3cb337510ce472abb4f3720327.tar.gz
gentoo-2-6c1693d6ea2fab3cb337510ce472abb4f3720327.tar.bz2
gentoo-2-6c1693d6ea2fab3cb337510ce472abb4f3720327.zip
ver bump
Diffstat (limited to 'sys-apps/acl')
-rw-r--r--sys-apps/acl/ChangeLog7
-rw-r--r--sys-apps/acl/acl-2.2.27.ebuild57
-rw-r--r--sys-apps/acl/files/digest-acl-2.2.271
3 files changed, 64 insertions, 1 deletions
diff --git a/sys-apps/acl/ChangeLog b/sys-apps/acl/ChangeLog
index 852c8fba90cb..1fe27e9dfbf1 100644
--- a/sys-apps/acl/ChangeLog
+++ b/sys-apps/acl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/acl
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/acl/ChangeLog,v 1.33 2004/08/31 10:38:12 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/acl/ChangeLog,v 1.34 2004/10/10 00:26:05 vapier Exp $
+
+*acl-2.2.27 (09 Oct 2004)
+
+ 09 Oct 2004; Mike Frysinger <vapier@gentoo.org> +acl-2.2.27.ebuild:
+ Version bump.
*acl-2.2.13-r3 (31 Aug 2004)
diff --git a/sys-apps/acl/acl-2.2.27.ebuild b/sys-apps/acl/acl-2.2.27.ebuild
new file mode 100644
index 000000000000..b6a007e78fb0
--- /dev/null
+++ b/sys-apps/acl/acl-2.2.27.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/acl/acl-2.2.27.ebuild,v 1.1 2004/10/10 00:26:05 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="Access control list utilities, libraries and headers"
+HOMEPAGE="http://oss.sgi.com/projects/xfs"
+SRC_URI="ftp://oss.sgi.com/projects/xfs/download/cmd_tars/${P}.src.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~arm ~hppa ~amd64 ~ia64 ~ppc64 ~s390"
+IUSE="nls debug"
+
+RDEPEND=">=sys-apps/attr-2.4
+ nls? ( sys-devel/gettext )"
+DEPEND="${RDEPEND}
+ sys-devel/autoconf"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i \
+ -e '/^PKG_[[:upper:]]*_DIR/s:= := $(DESTDIR):' \
+ -e "/^PKG_DOC_DIR/s:=.*:= /usr/share/doc/${PF}:" \
+ include/builddefs.in \
+ || die "failed to update builddefs"
+}
+
+src_compile() {
+ if use debug ; then
+ export DEBUG=-DDEBUG
+ else
+ export DEBUG=-DNDEBUG
+ fi
+ export OPTIMIZER="${CFLAGS}"
+
+ # Some archs need the PLATFORM var unset
+ if hasq ${ARCH} mips ppc sparc ppc64 s390; then
+ unset PLATFORM
+ fi
+
+ econf \
+ --mandir=/usr/share/man \
+ --prefix=/usr \
+ --libexecdir=/usr/$(get_libdir) \
+ --libdir=/$(get_libdir) \
+ --bindir=/bin \
+ $(use_enable nls gettext) \
+ || die
+ emake || die
+}
+
+src_install() {
+ make DIST_ROOT=${D} install install-dev install-lib || die
+}
diff --git a/sys-apps/acl/files/digest-acl-2.2.27 b/sys-apps/acl/files/digest-acl-2.2.27
new file mode 100644
index 000000000000..47e6eeaddb9e
--- /dev/null
+++ b/sys-apps/acl/files/digest-acl-2.2.27
@@ -0,0 +1 @@
+MD5 bccc63369b5c446e5e2e999bb0a83e31 acl-2.2.27.src.tar.gz 144408