summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-12-04 12:10:35 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-12-04 12:10:35 +0000
commit75daa4198e124dc53eed3c7608ccda04ff539a40 (patch)
tree5e9372aa145647a9cb1790b4df081d2a380f6d3a /sys-apps/busybox/busybox-9999.ebuild
parentremove old (diff)
downloadgentoo-2-75daa4198e124dc53eed3c7608ccda04ff539a40.tar.gz
gentoo-2-75daa4198e124dc53eed3c7608ccda04ff539a40.tar.bz2
gentoo-2-75daa4198e124dc53eed3c7608ccda04ff539a40.zip
Integrate support for busybox-{sysklogd,ntpd,watchdog}, bug #444718
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'sys-apps/busybox/busybox-9999.ebuild')
-rw-r--r--sys-apps/busybox/busybox-9999.ebuild26
1 files changed, 24 insertions, 2 deletions
diff --git a/sys-apps/busybox/busybox-9999.ebuild b/sys-apps/busybox/busybox-9999.ebuild
index 25648d81ff82..c2bf8324f65b 100644
--- a/sys-apps/busybox/busybox-9999.ebuild
+++ b/sys-apps/busybox/busybox-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-9999.ebuild,v 1.7 2012/11/02 18:59:14 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-9999.ebuild,v 1.8 2012/12/04 12:10:35 blueness Exp $
EAPI="4"
inherit eutils flag-o-matic savedconfig toolchain-funcs multilib
@@ -81,6 +81,10 @@ busybox_config_option() {
einfo $(grep "CONFIG_$2[= ]" .config || echo Could not find CONFIG_$2 ...)
}
+busybox_config_enabled() {
+ grep "^CONFIG_$1=y" -q .config
+}
+
src_prepare() {
unset KBUILD_OUTPUT #88088
append-flags -fno-strict-aliasing #310413
@@ -88,7 +92,7 @@ src_prepare() {
# patches go here!
epatch "${FILESDIR}"/${PN}-1.19.0-bb.patch
- epatch "${FILESDIR}"/${P}-*.patch
+ #epatch "${FILESDIR}"/${P}-*.patch
cp "${FILESDIR}"/ginit.c init/ || die
# flag cleanup
@@ -233,6 +237,24 @@ src_install() {
dosym busybox /bin/vi
fi
+ # add busybox daemon's, bug #444718
+ if busybox_config_enabled FEATURE_NTPD_SERVER; then
+ newconfd "${FILESDIR}/ntpd.confd" "busybox-ntpd"
+ newinitd "${FILESDIR}/ntpd.initd" "busybox-ntpd"
+ fi
+ if busybox_config_enabled SYSLOGD; then
+ newconfd "${FILESDIR}/syslogd.confd" "busybox-syslogd"
+ newinitd "${FILESDIR}/syslogd.initd" "busybox-syslogd"
+ fi
+ if busybox_config_enabled KLOGD; then
+ newconfd "${FILESDIR}/klogd.confd" "busybox-klogd"
+ newinitd "${FILESDIR}/klogd.initd" "busybox-klogd"
+ fi
+ if busybox_config_enabled WATCHDOG; then
+ newconfd "${FILESDIR}/watchdog.confd" "busybox-watchdog"
+ newinitd "${FILESDIR}/watchdog.initd" "busybox-watchdog"
+ fi
+
# bundle up the symlink files for use later
emake DESTDIR="${ED}" install
rm _install/bin/busybox