summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-05-04 01:31:58 +0000
committerMike Frysinger <vapier@gentoo.org>2012-05-04 01:31:58 +0000
commitc5662af4793f892ff1498a439f8565dcfcc73139 (patch)
treea96e6905f01ad2b498ae754150e0a5ad0a325206 /sys-apps/busybox/busybox-9999.ebuild
parentrevbump, nvtt and glut flags added, wrt #411565 and #375841 (diff)
downloadgentoo-2-c5662af4793f892ff1498a439f8565dcfcc73139.tar.gz
gentoo-2-c5662af4793f892ff1498a439f8565dcfcc73139.tar.bz2
gentoo-2-c5662af4793f892ff1498a439f8565dcfcc73139.zip
Add USE=math to control libm usage in awk.
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/busybox/busybox-9999.ebuild')
-rw-r--r--sys-apps/busybox/busybox-9999.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/sys-apps/busybox/busybox-9999.ebuild b/sys-apps/busybox/busybox-9999.ebuild
index 47ad0b37eb57..a01ee9d68a55 100644
--- a/sys-apps/busybox/busybox-9999.ebuild
+++ b/sys-apps/busybox/busybox-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-9999.ebuild,v 1.1 2012/04/30 01:59:09 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-9999.ebuild,v 1.2 2012/05/04 01:31:58 vapier Exp $
EAPI="4"
inherit eutils flag-o-matic savedconfig toolchain-funcs
@@ -57,7 +57,7 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="ipv6 make-symlinks mdev -pam selinux sep-usr static"
+IUSE="ipv6 make-symlinks math mdev -pam selinux sep-usr static"
RESTRICT="test"
RDEPEND="selinux? ( sys-libs/libselinux )
@@ -154,6 +154,7 @@ src_configure() {
&& busybox_config_option n PAM \
|| busybox_config_option pam PAM
busybox_config_option static STATIC
+ busybox_config_option math FEATURE_AWK_LIBM
# all the debug options are compiler related, so punt them
busybox_config_option n DEBUG