summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-03-28 06:09:28 +0000
committerMike Frysinger <vapier@gentoo.org>2006-03-28 06:09:28 +0000
commitc6f59e323c7a2e295092336a3aa3b40827f053e1 (patch)
tree12926d6c5fbd87834edf84882b83d58dd1e9a044 /sys-apps/busybox
parentremove some more manpages since shadow provides them now #127737 by Florian F... (diff)
downloadgentoo-2-c6f59e323c7a2e295092336a3aa3b40827f053e1.tar.gz
gentoo-2-c6f59e323c7a2e295092336a3aa3b40827f053e1.tar.bz2
gentoo-2-c6f59e323c7a2e295092336a3aa3b40827f053e1.zip
Fix from upstream for big endian hosts.
(Portage version: 2.1_pre7-r2)
Diffstat (limited to 'sys-apps/busybox')
-rw-r--r--sys-apps/busybox/ChangeLog6
-rw-r--r--sys-apps/busybox/busybox-1.1.1.ebuild3
-rw-r--r--sys-apps/busybox/files/1.1.1/insmod.patch27
3 files changed, 34 insertions, 2 deletions
diff --git a/sys-apps/busybox/ChangeLog b/sys-apps/busybox/ChangeLog
index 7bdde22e4ca5..a2ed3d529e7d 100644
--- a/sys-apps/busybox/ChangeLog
+++ b/sys-apps/busybox/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/busybox
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/ChangeLog,v 1.85 2006/03/28 02:47:19 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/ChangeLog,v 1.86 2006/03/28 06:09:28 vapier Exp $
+
+ 28 Mar 2006; Mike Frysinger <vapier@gentoo.org> +files/1.1.1/insmod.patch,
+ busybox-1.1.1.ebuild:
+ Fix from upstream for big endian hosts.
28 Mar 2006; Mike Frysinger <vapier@gentoo.org> busybox-1.1.0.ebuild,
busybox-1.1.1.ebuild:
diff --git a/sys-apps/busybox/busybox-1.1.1.ebuild b/sys-apps/busybox/busybox-1.1.1.ebuild
index ce970422dcd7..ab6a203644d7 100644
--- a/sys-apps/busybox/busybox-1.1.1.ebuild
+++ b/sys-apps/busybox/busybox-1.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.1.1.ebuild,v 1.2 2006/03/28 02:47:19 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.1.1.ebuild,v 1.3 2006/03/28 06:09:28 vapier Exp $
inherit eutils
@@ -58,6 +58,7 @@ src_unpack() {
# patches go here!
epatch "${FILESDIR}"/1.1.1/bb.patch
+ epatch "${FILESDIR}"/1.1.1/insmod.patch
# check for a busybox config before making one of our own.
# if one exist lets return and use it.
diff --git a/sys-apps/busybox/files/1.1.1/insmod.patch b/sys-apps/busybox/files/1.1.1/insmod.patch
new file mode 100644
index 000000000000..f3078d7853dc
--- /dev/null
+++ b/sys-apps/busybox/files/1.1.1/insmod.patch
@@ -0,0 +1,27 @@
+Index: modutils/insmod.c
+===================================================================
+--- modutils/insmod.c (revision 14652)
++++ modutils/insmod.c (revision 14653)
+@@ -516,12 +516,6 @@ int delete_module(const char *);
+ #include <elf.h>
+ #include <endian.h>
+
+-#if BB_LITTLE_ENDIAN
+-# define ELFDATAM ELFDATA2LSB
+-#else
+-# define ELFDATAM ELFDATA2MSB
+-#endif
+-
+ #ifndef ElfW
+ # if ELFCLASSM == ELFCLASS32
+ # define ElfW(x) Elf32_ ## x
+@@ -3331,7 +3325,8 @@ static struct obj_file *obj_load(FILE *
+ return NULL;
+ }
+ if (f->header.e_ident[EI_CLASS] != ELFCLASSM
+- || f->header.e_ident[EI_DATA] != ELFDATAM
++ || f->header.e_ident[EI_DATA] != (BB_BIG_ENDIAN
++ ? ELFDATA2MSB : ELFDATA2LSB)
+ || f->header.e_ident[EI_VERSION] != EV_CURRENT
+ || !MATCH_MACHINE(f->header.e_machine)) {
+ bb_error_msg("ELF file not for this architecture");