summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2011-03-02 00:36:22 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2011-03-02 00:36:22 +0000
commitf6c41c96f82f60735e848d1342f4ec13bd6204e5 (patch)
tree4bd1cf5d92640bc6eb87eea7da6bd68743961b41 /sys-apps/ccs-tools
parentsparc stable (bug 355911) (diff)
downloadgentoo-2-f6c41c96f82f60735e848d1342f4ec13bd6204e5.tar.gz
gentoo-2-f6c41c96f82f60735e848d1342f4ec13bd6204e5.tar.bz2
gentoo-2-f6c41c96f82f60735e848d1342f4ec13bd6204e5.zip
Version bumped, bug #355799. respect LDFLAGS, bug #332603.
(Portage version: 2.1.9.40/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/ccs-tools')
-rw-r--r--sys-apps/ccs-tools/ChangeLog11
-rw-r--r--sys-apps/ccs-tools/ccs-tools-1.8.0_p20110214.ebuild72
-rw-r--r--sys-apps/ccs-tools/files/ccs-tools-1.8.0_p20110214-parallel.patch13
3 files changed, 94 insertions, 2 deletions
diff --git a/sys-apps/ccs-tools/ChangeLog b/sys-apps/ccs-tools/ChangeLog
index 80d668479e96..f42b8822c6c7 100644
--- a/sys-apps/ccs-tools/ChangeLog
+++ b/sys-apps/ccs-tools/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/ccs-tools
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/ccs-tools/ChangeLog,v 1.7 2010/04/04 15:56:43 matsuu Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/ccs-tools/ChangeLog,v 1.8 2011/03/02 00:36:22 matsuu Exp $
+
+*ccs-tools-1.8.0_p20110214 (02 Mar 2011)
+
+ 02 Mar 2011; MATSUU Takuto <matsuu@gentoo.org>
+ +ccs-tools-1.8.0_p20110214.ebuild,
+ +files/ccs-tools-1.8.0_p20110214-parallel.patch:
+ Version bumped, bug #355799. respect LDFLAGS, bug #332603.
*ccs-tools-1.7.2_p20100401 (04 Apr 2010)
diff --git a/sys-apps/ccs-tools/ccs-tools-1.8.0_p20110214.ebuild b/sys-apps/ccs-tools/ccs-tools-1.8.0_p20110214.ebuild
new file mode 100644
index 000000000000..8ba28518f236
--- /dev/null
+++ b/sys-apps/ccs-tools/ccs-tools-1.8.0_p20110214.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/ccs-tools/ccs-tools-1.8.0_p20110214.ebuild,v 1.1 2011/03/02 00:36:22 matsuu Exp $
+
+EAPI=3
+inherit eutils multilib toolchain-funcs
+
+MY_P="${P/_p/-}"
+DESCRIPTION="TOMOYO Linux tools"
+HOMEPAGE="http://tomoyo.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/tomoyo/49693/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT="test"
+
+DEPEND="sys-libs/ncurses
+ sys-libs/readline"
+RDEPEND="${DEPEND}
+ sys-apps/which"
+
+S="${WORKDIR}/ccstools"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-parallel.patch"
+ sed -i \
+ -e "s:gcc:$(tc-getCC):" \
+ -e "s:-O2:${CFLAGS}:" \
+ -e 's/\$(CFLAGS)/& $(LDFLAGS)/' \
+ -e "s:/usr/lib:/usr/$(get_libdir):g" \
+ -e "s:= /:= ${EPREFIX}/:g" \
+ Include.make || die
+}
+
+src_test() {
+ cd "${S}/kernel_test"
+ emake || die
+ ./testall.sh || die
+}
+
+src_install() {
+ emake INSTALLDIR="${D}" install || die
+
+# insinto /etc/ccs
+# doins ccstools.conf || die
+
+ dodoc README.ccs
+}
+
+pkg_postinst() {
+ elog "Execute the following command to setup the initial policy configuration:"
+ elog
+ elog "emerge --config =${CATEGORY}/${PF}"
+ elog
+ elog "For more information, please visit the following."
+ elog
+ elog "For >=kernel-2.6.36:"
+ elog "http://tomoyo.sourceforge.jp/2.3/"
+ elog
+ elog "For >=kernel-2.6.30:"
+ elog "http://tomoyo.sourceforge.jp/2.2/"
+ elog
+ elog "For <kernel-2.6.30 + ccs-patch:"
+ elog "http://tomoyo.sourceforge.jp/1.8/"
+}
+
+pkg_config() {
+ /usr/$(get_libdir)/ccs/init_policy.sh
+}
diff --git a/sys-apps/ccs-tools/files/ccs-tools-1.8.0_p20110214-parallel.patch b/sys-apps/ccs-tools/files/ccs-tools-1.8.0_p20110214-parallel.patch
new file mode 100644
index 000000000000..95093b9be846
--- /dev/null
+++ b/sys-apps/ccs-tools/files/ccs-tools-1.8.0_p20110214-parallel.patch
@@ -0,0 +1,13 @@
+Index: usr_sbin/Makefile
+===================================================================
+--- usr_sbin/Makefile (revision 4670)
++++ usr_sbin/Makefile (revision 4671)
+@@ -7,6 +7,8 @@
+
+ all: libccstools.so $(BUILD_FILES)
+
++$(BUILD_FILES): libccstools.so
++
+ /usr/include/curses.h:
+ @echo "/usr/include/curses.h is missing."
+ @echo "Run 'yum install ncurses-devel' or 'apt-get install libncurses-dev'"