summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-10-14 14:47:14 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-10-14 14:47:14 +0000
commitb8ae07167e1a2200553a4a360538da8d6dabd3e8 (patch)
tree29cb8bd923f898c1875a0be8b99b86d4525b689f /sys-apps/chpax
parentBump to 0.10.5, take maintainership since it seems I'm stuck with it. (diff)
downloadgentoo-2-b8ae07167e1a2200553a4a360538da8d6dabd3e8.tar.gz
gentoo-2-b8ae07167e1a2200553a4a360538da8d6dabd3e8.tar.bz2
gentoo-2-b8ae07167e1a2200553a4a360538da8d6dabd3e8.zip
Fix CFLAGS handling so they get injected during src_compile rather than set in stone during src_unpack; properly respect LDFLAGS (they go before the object files, not after).
(Portage version: 2.2_rc12/cvs/Linux 2.6.27-gentoo x86_64)
Diffstat (limited to 'sys-apps/chpax')
-rw-r--r--sys-apps/chpax/ChangeLog9
-rw-r--r--sys-apps/chpax/chpax-0.7.ebuild12
2 files changed, 14 insertions, 7 deletions
diff --git a/sys-apps/chpax/ChangeLog b/sys-apps/chpax/ChangeLog
index 4ca1190157c1..4338bcdebe54 100644
--- a/sys-apps/chpax/ChangeLog
+++ b/sys-apps/chpax/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/chpax
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/chpax/ChangeLog,v 1.34 2006/12/19 22:38:19 solar Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/chpax/ChangeLog,v 1.35 2008/10/14 14:47:14 flameeyes Exp $
+
+ 14 Oct 2008; Diego Pettenò <flameeyes@gentoo.org> chpax-0.7.ebuild:
+ Fix CFLAGS handling so they get injected during src_compile rather than
+ set in stone during src_unpack; properly respect LDFLAGS (they go before
+ the object files, not after).
19 Dec 2006; <solar@gentoo.org> chpax-0.7.ebuild:
- make note about chpax being obsolete and suggest paxctl
diff --git a/sys-apps/chpax/chpax-0.7.ebuild b/sys-apps/chpax/chpax-0.7.ebuild
index d5927cadd4fd..9847d97992de 100644
--- a/sys-apps/chpax/chpax-0.7.ebuild
+++ b/sys-apps/chpax/chpax-0.7.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/chpax/chpax-0.7.ebuild,v 1.12 2006/12/19 22:38:19 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/chpax/chpax-0.7.ebuild,v 1.13 2008/10/14 14:47:14 flameeyes Exp $
inherit flag-o-matic toolchain-funcs
@@ -18,13 +18,15 @@ DEPEND="${RDEPEND}"
src_unpack() {
unpack ${A}
- cd ${S}
- sed -i -e "s|-Wall|${CFLAGS}|" Makefile
+ sed -i \
+ -e '/^CFLAGS/s:=:+=:' \
+ -e '/TARGET/s:CFLAGS:LDFLAGS:' \
+ "${S}"/Makefile || die "sed in Makefile failed"
}
src_compile() {
# use static && append-ldflags -static ; # breaks with current ssp.
- emake CC="$(tc-getCC)" TARGET="chpax ${LDFLAGS:0}" || die "Parallel Make Failed"
+ emake CC="$(tc-getCC)" || die "Parallel Make Failed"
}
src_install() {