summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-05-16 16:10:56 +0000
committerMike Frysinger <vapier@gentoo.org>2009-05-16 16:10:56 +0000
commit075f3cd97403cb8ac4c9e54ada7c6d1fd6ec8fff (patch)
treec8b222e694345c568e3d60e46d18e3f2cb4ff9d8 /sys-apps/coreutils
parentAdded ~x86. (diff)
downloadgentoo-2-075f3cd97403cb8ac4c9e54ada7c6d1fd6ec8fff.tar.gz
gentoo-2-075f3cd97403cb8ac4c9e54ada7c6d1fd6ec8fff.tar.bz2
gentoo-2-075f3cd97403cb8ac4c9e54ada7c6d1fd6ec8fff.zip
Allow /dev/loop when running mount #269758 by Nick Fortino.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/coreutils')
-rw-r--r--sys-apps/coreutils/ChangeLog6
-rw-r--r--sys-apps/coreutils/coreutils-7.1.ebuild5
-rw-r--r--sys-apps/coreutils/coreutils-7.2.ebuild5
-rw-r--r--sys-apps/coreutils/coreutils-7.4.ebuild5
4 files changed, 14 insertions, 7 deletions
diff --git a/sys-apps/coreutils/ChangeLog b/sys-apps/coreutils/ChangeLog
index 2c1e228ae9b6..5aaf0f76f708 100644
--- a/sys-apps/coreutils/ChangeLog
+++ b/sys-apps/coreutils/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/coreutils
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/ChangeLog,v 1.254 2009/05/07 19:46:35 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/ChangeLog,v 1.255 2009/05/16 16:10:56 vapier Exp $
+
+ 16 May 2009; Mike Frysinger <vapier@gentoo.org> coreutils-7.1.ebuild,
+ coreutils-7.2.ebuild, coreutils-7.4.ebuild:
+ Allow /dev/loop when running mount #269758 by Nick Fortino.
*coreutils-7.4 (07 May 2009)
diff --git a/sys-apps/coreutils/coreutils-7.1.ebuild b/sys-apps/coreutils/coreutils-7.1.ebuild
index 8c9aaa93fccd..67964eb2f5d7 100644
--- a/sys-apps/coreutils/coreutils-7.1.ebuild
+++ b/sys-apps/coreutils/coreutils-7.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-7.1.ebuild,v 1.17 2009/04/27 04:58:59 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-7.1.ebuild,v 1.18 2009/05/16 16:10:56 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -81,6 +81,7 @@ src_test() {
# coreutils tests like to do `mount` and such with temp dirs
# so make sure /etc/mtab is writable #265725
+ # make sure /dev/loop* can be mounted #269758
mkdir -p "${T}"/mount-wrappers
mkwrap() {
local w ww
@@ -88,7 +89,7 @@ src_test() {
ww="${T}/mount-wrappers/${w}"
cat <<-EOF > "${ww}"
#!/bin/sh
- exec env SANDBOX_WRITE="\${SANDBOX_WRITE}:/etc/mtab" $(type -P $w) "\$@"
+ exec env SANDBOX_WRITE="\${SANDBOX_WRITE}:/etc/mtab:/dev/loop" $(type -P $w) "\$@"
EOF
chmod a+rx "${ww}"
done
diff --git a/sys-apps/coreutils/coreutils-7.2.ebuild b/sys-apps/coreutils/coreutils-7.2.ebuild
index 0a25ba783a90..64a7e20c646c 100644
--- a/sys-apps/coreutils/coreutils-7.2.ebuild
+++ b/sys-apps/coreutils/coreutils-7.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-7.2.ebuild,v 1.4 2009/04/27 04:58:59 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-7.2.ebuild,v 1.5 2009/05/16 16:10:56 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -81,6 +81,7 @@ src_test() {
# coreutils tests like to do `mount` and such with temp dirs
# so make sure /etc/mtab is writable #265725
+ # make sure /dev/loop* can be mounted #269758
mkdir -p "${T}"/mount-wrappers
mkwrap() {
local w ww
@@ -88,7 +89,7 @@ src_test() {
ww="${T}/mount-wrappers/${w}"
cat <<-EOF > "${ww}"
#!/bin/sh
- exec env SANDBOX_WRITE="\${SANDBOX_WRITE}:/etc/mtab" $(type -P $w) "\$@"
+ exec env SANDBOX_WRITE="\${SANDBOX_WRITE}:/etc/mtab:/dev/loop" $(type -P $w) "\$@"
EOF
chmod a+rx "${ww}"
done
diff --git a/sys-apps/coreutils/coreutils-7.4.ebuild b/sys-apps/coreutils/coreutils-7.4.ebuild
index f51b9beaeece..6982d98a8e0d 100644
--- a/sys-apps/coreutils/coreutils-7.4.ebuild
+++ b/sys-apps/coreutils/coreutils-7.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-7.4.ebuild,v 1.1 2009/05/07 19:46:35 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-7.4.ebuild,v 1.2 2009/05/16 16:10:56 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -81,6 +81,7 @@ src_test() {
# coreutils tests like to do `mount` and such with temp dirs
# so make sure /etc/mtab is writable #265725
+ # make sure /dev/loop* can be mounted #269758
mkdir -p "${T}"/mount-wrappers
mkwrap() {
local w ww
@@ -88,7 +89,7 @@ src_test() {
ww="${T}/mount-wrappers/${w}"
cat <<-EOF > "${ww}"
#!/bin/sh
- exec env SANDBOX_WRITE="\${SANDBOX_WRITE}:/etc/mtab" $(type -P $w) "\$@"
+ exec env SANDBOX_WRITE="\${SANDBOX_WRITE}:/etc/mtab:/dev/loop" $(type -P $w) "\$@"
EOF
chmod a+rx "${ww}"
done