summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2008-02-27 20:48:06 +0000
committerDoug Goldstein <cardoe@gentoo.org>2008-02-27 20:48:06 +0000
commit362d33d86fccdac3cd99ee16f1cf555717df957a (patch)
tree452f48d1b8f0257f751b64ae6f266d3a66a667e0 /sys-apps/dbus
parentSparc stable --- Bug #208917 --- around over 5 months and all tests pass. (diff)
downloadgentoo-2-362d33d86fccdac3cd99ee16f1cf555717df957a.tar.gz
gentoo-2-362d33d86fccdac3cd99ee16f1cf555717df957a.tar.bz2
gentoo-2-362d33d86fccdac3cd99ee16f1cf555717df957a.zip
fix for CVE-2008-0595. potentially fixes bug #211076
(Portage version: 2.1.4.4)
Diffstat (limited to 'sys-apps/dbus')
-rw-r--r--sys-apps/dbus/ChangeLog7
-rw-r--r--sys-apps/dbus/dbus-1.1.20.ebuild115
2 files changed, 121 insertions, 1 deletions
diff --git a/sys-apps/dbus/ChangeLog b/sys-apps/dbus/ChangeLog
index 96f6dcca8b00..2f7bfef8e71d 100644
--- a/sys-apps/dbus/ChangeLog
+++ b/sys-apps/dbus/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/dbus
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/ChangeLog,v 1.209 2008/02/12 13:01:15 steev Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/ChangeLog,v 1.210 2008/02/27 20:48:06 cardoe Exp $
+
+*dbus-1.1.20 (27 Feb 2008)
+
+ 27 Feb 2008; Doug Klima <cardoe@gentoo.org> +dbus-1.1.20.ebuild:
+ fix for CVE-2008-0595. potentially fixes bug #211076
12 Feb 2008; Steev Klimaszewski <steev@gentoo.org> dbus-1.1.4.ebuild:
Disable libaudit when not using SELinux. Should close bug #209571.
diff --git a/sys-apps/dbus/dbus-1.1.20.ebuild b/sys-apps/dbus/dbus-1.1.20.ebuild
new file mode 100644
index 000000000000..da91ffe3f110
--- /dev/null
+++ b/sys-apps/dbus/dbus-1.1.20.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/dbus-1.1.20.ebuild,v 1.1 2008/02/27 20:48:06 cardoe Exp $
+
+inherit eutils multilib autotools flag-o-matic
+
+DESCRIPTION="A message bus system, a simple way for applications to talk to each other"
+HOMEPAGE="http://dbus.freedesktop.org/"
+SRC_URI="http://dbus.freedesktop.org/releases/dbus/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 AFL-2.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="debug doc selinux X"
+
+RDEPEND="X? ( x11-libs/libXt x11-libs/libX11 )
+ selinux? ( sys-libs/libselinux
+ sec-policy/selinux-dbus )
+ >=dev-libs/expat-1.95.8
+ !<sys-apps/dbus-0.91"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( app-doc/doxygen
+ app-text/xmlto )"
+
+src_compile() {
+ # so we can get backtraces from apps
+ append-flags -rdynamic
+
+ local myconf=""
+
+ hasq test ${FEATURES} && myconf="${myconf} --enable-tests=yes"
+ # libaudit is *only* used in DBus wrt SELinux support, so disable it, if
+ # not on an SELinux profile.
+ econf \
+ $(use_with X x) \
+ $(use_enable kernel_linux inotify) \
+ $(use_enable kernel_FreeBSD kqueue) \
+ $(use_enable selinux) \
+ $(use_enable selinux libaudit) \
+ $(use_enable debug verbose-mode) \
+ $(use_enable debug asserts) \
+ --with-xml=expat \
+ --with-system-pid-file=/var/run/dbus.pid \
+ --with-system-socket=/var/run/dbus/system_bus_socket \
+ --with-session-socket-dir=/tmp \
+ --with-dbus-user=messagebus \
+ --localstatedir=/var \
+ $(use_enable doc doxygen-docs) \
+ --disable-xml-docs \
+ ${myconf} \
+ || die "econf failed"
+
+ # after the compile, it uses a selinuxfs interface to
+ # check if the SELinux policy has the right support
+ use selinux && addwrite /selinux/access
+
+ emake || die "make failed"
+}
+
+src_test() {
+ DBUS_VERBOSE=1 make check || die "make check failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ # initscript
+ newinitd "${FILESDIR}"/dbus.init-1.0 dbus
+
+ # dbus X session script (#77504)
+ # turns out to only work for GDM. has been merged into other desktop
+ # (kdm and such scripts)
+ exeinto /etc/X11/xinit/xinitrc.d/
+ doexe "${FILESDIR}"/30-dbus
+
+ # needs to exist for the system socket
+ keepdir /var/run/dbus
+ # needs to exist for machine id
+ keepdir /var/lib/dbus
+ # needs to exist for dbus sessions to launch
+
+ keepdir /usr/lib/dbus-1.0/services
+ keepdir /usr/share/dbus-1/services
+ keepdir /etc/dbus-1/system.d/
+ keepdir /etc/dbus-1/session.d/
+
+ dodoc AUTHORS ChangeLog HACKING NEWS README doc/TODO
+ if use doc; then
+ dohtml doc/*html
+ fi
+}
+
+pkg_preinst() {
+ enewgroup messagebus || die "Problem adding messagebus group"
+ enewuser messagebus -1 "-1" -1 messagebus || die "Problem adding messagebus user"
+}
+
+pkg_postinst() {
+ elog "To start the D-Bus system-wide messagebus by default"
+ elog "you should add it to the default runlevel :"
+ elog "\`rc-update add dbus default\`"
+ elog
+ elog "Some applications require a session bus in addition to the system"
+ elog "bus. Please see \`man dbus-launch\` for more information."
+ elog
+ ewarn
+ ewarn "You MUST run 'revdep-rebuild' after emerging this package"
+ elog "If you notice any issues, please rebuild sys-apps/hal"
+ ewarn
+ ewarn "If you are currently running X with the hal useflag enabled"
+ ewarn "restarting the dbus service WILL restart X as well"
+ ebeep 5
+ ewarn
+}