summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2001-08-19 21:05:27 +0000
committerDaniel Robbins <drobbins@gentoo.org>2001-08-19 21:05:27 +0000
commitd46c9387d04dfba61f4853df51007469b017de57 (patch)
tree8b4ae9cd97fc8d49c1c3a255dc0d49ad5e1f2010 /sys-apps/dcron
parentfixed (diff)
downloadgentoo-2-d46c9387d04dfba61f4853df51007469b017de57.tar.gz
gentoo-2-d46c9387d04dfba61f4853df51007469b017de57.tar.bz2
gentoo-2-d46c9387d04dfba61f4853df51007469b017de57.zip
new dcron
Diffstat (limited to 'sys-apps/dcron')
-rw-r--r--sys-apps/dcron/dcron-2.7-r5.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sys-apps/dcron/dcron-2.7-r5.ebuild b/sys-apps/dcron/dcron-2.7-r5.ebuild
new file mode 100644
index 000000000000..0324b410d093
--- /dev/null
+++ b/sys-apps/dcron/dcron-2.7-r5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: System Team <system@gentoo.org>
+# Author: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dcron/dcron-2.7-r5.ebuild,v 1.1 2001/08/19 21:05:27 drobbins Exp $
+
+S=${WORKDIR}/dcron
+DESCRIPTION="A cute little cron from Matt Dillon."
+SRC_URI="http://apollo.backplane.com/FreeSrc/dcron27.tgz"
+
+HOMEPAGE="http://apollo.backplane.com"
+
+DEPEND="virtual/glibc"
+#debianutils is needed for start-stop-daemon (init.d script)
+RDEPEND="$DEPEND sys-apps/debianutils"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ patch -p0 < ${FILESDIR}/${P}-Makefile-gentoo.diff
+}
+
+src_compile() {
+ try make
+}
+
+src_install() {
+ try make DESTDIR=${D} install
+
+ #important fix!
+ dodir /usr/sbin
+ mv ${D}/usr/bin/crond ${D}/usr/sbin
+ #to use cron, you must be part of the "cron" group
+
+ diropts -m0750
+ dodir /var/spool/cron/crontabs /var/cron/lastrun
+ dodoc CHANGELOG README
+ insinto /etc
+ doins ${FILESDIR}/crontab
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/dcron-newinit dcron
+}
+