summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-10-08 13:24:11 +0000
committerMike Frysinger <vapier@gentoo.org>2004-10-08 13:24:11 +0000
commit29f40ef77b0542e38cc2043a88db8229e4ccf517 (patch)
treeebc889ef319c29354b7eb4b6aa56b2cd7831e029 /sys-apps/dmapi
parentnew release. (Manifest recommit) (diff)
downloadgentoo-2-29f40ef77b0542e38cc2043a88db8229e4ccf517.tar.gz
gentoo-2-29f40ef77b0542e38cc2043a88db8229e4ccf517.tar.bz2
gentoo-2-29f40ef77b0542e38cc2043a88db8229e4ccf517.zip
ver bump uNF
Diffstat (limited to 'sys-apps/dmapi')
-rw-r--r--sys-apps/dmapi/ChangeLog7
-rw-r--r--sys-apps/dmapi/dmapi-2.2.1.ebuild44
-rw-r--r--sys-apps/dmapi/files/digest-dmapi-2.2.11
3 files changed, 51 insertions, 1 deletions
diff --git a/sys-apps/dmapi/ChangeLog b/sys-apps/dmapi/ChangeLog
index 18f13eddbe47..f17a85424d4e 100644
--- a/sys-apps/dmapi/ChangeLog
+++ b/sys-apps/dmapi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/dmapi
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dmapi/ChangeLog,v 1.22 2004/09/03 21:03:23 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dmapi/ChangeLog,v 1.23 2004/10/08 13:24:11 vapier Exp $
+
+*dmapi-2.2.1 (08 Oct 2004)
+
+ 08 Oct 2004; Mike Frysinger <vapier@gentoo.org> :
+ Version bump.
*dmapi-2.2.0 (03 Sep 2004)
diff --git a/sys-apps/dmapi/dmapi-2.2.1.ebuild b/sys-apps/dmapi/dmapi-2.2.1.ebuild
new file mode 100644
index 000000000000..1f36799c1eea
--- /dev/null
+++ b/sys-apps/dmapi/dmapi-2.2.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dmapi/dmapi-2.2.1.ebuild,v 1.1 2004/10/08 13:24:11 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="XFS data management API library"
+HOMEPAGE="http://oss.sgi.com/projects/xfs/"
+SRC_URI="ftp://oss.sgi.com/projects/xfs/download/cmd_tars/${P}.src.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~sparc ~x86"
+IUSE="debug static"
+
+DEPEND="sys-fs/xfsprogs"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i \
+ -e 's:^PKG_\(.*\)_DIR[[:space:]]*= \(.*\)$:PKG_\1_DIR = $(DESTDIR)\2:' \
+ include/builddefs.in || die
+}
+
+src_compile() {
+ use debug \
+ && export DEBUG=-DDEBUG \
+ || export DEBUG=-DNDEBUG
+ export OPTIMIZER="${CFLAGS}"
+
+ # Some archs need the PLATFORM var unset
+ unset PLATFORM
+
+ econf \
+ --libdir=/$(get_libdir) \
+ --libexecdir=/usr/$(get_libdir) \
+ || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install install-dev || die
+}
diff --git a/sys-apps/dmapi/files/digest-dmapi-2.2.1 b/sys-apps/dmapi/files/digest-dmapi-2.2.1
new file mode 100644
index 000000000000..d7773db9e09e
--- /dev/null
+++ b/sys-apps/dmapi/files/digest-dmapi-2.2.1
@@ -0,0 +1 @@
+MD5 f214fb062f872ecbe6946bff95c1127a dmapi-2.2.1.src.tar.gz 78018