summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-12-06 05:44:29 +0000
committerMike Frysinger <vapier@gentoo.org>2004-12-06 05:44:29 +0000
commitb9f797f03f266da60fa67add1bf889f4e1147931 (patch)
treec3d3d907bda1f89ede9822fd5ab11dc92b36b91a /sys-apps/ed
parentcross-compile fixes (Manifest recommit) (diff)
downloadgentoo-2-b9f797f03f266da60fa67add1bf889f4e1147931.tar.gz
gentoo-2-b9f797f03f266da60fa67add1bf889f4e1147931.tar.bz2
gentoo-2-b9f797f03f266da60fa67add1bf889f4e1147931.zip
cross-compile fixes
Diffstat (limited to 'sys-apps/ed')
-rw-r--r--sys-apps/ed/ChangeLog5
-rw-r--r--sys-apps/ed/ed-0.2-r4.ebuild11
2 files changed, 11 insertions, 5 deletions
diff --git a/sys-apps/ed/ChangeLog b/sys-apps/ed/ChangeLog
index 80ed1a216392..2bcde8dca5d1 100644
--- a/sys-apps/ed/ChangeLog
+++ b/sys-apps/ed/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-apps/ed
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/ed/ChangeLog,v 1.18 2004/10/10 03:06:51 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/ed/ChangeLog,v 1.19 2004/12/06 05:44:29 vapier Exp $
+
+ 06 Dec 2004; Mike Frysinger <vapier@gentoo.org> ed-0.2-r4.ebuild:
+ cross-compile fixes
09 Oct 2004; Tom Gall <tgall@gentoo.org> ed-0.2-r4.ebuild:
stable on ppc64, bug #66400
diff --git a/sys-apps/ed/ed-0.2-r4.ebuild b/sys-apps/ed/ed-0.2-r4.ebuild
index 4e367a86585b..03a99b0daa2b 100644
--- a/sys-apps/ed/ed-0.2-r4.ebuild
+++ b/sys-apps/ed/ed-0.2-r4.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/ed/ed-0.2-r4.ebuild,v 1.10 2004/11/12 15:53:39 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/ed/ed-0.2-r4.ebuild,v 1.11 2004/12/06 05:44:29 vapier Exp $
-inherit eutils
+inherit eutils toolchain-funcs
DESCRIPTION="Your basic line editor"
HOMEPAGE="http://www.gnu.org/software/ed/"
@@ -21,16 +21,19 @@ src_unpack() {
cd ${S}
epatch ${FILESDIR}/${PV}-info-dir.patch
epatch ${FILESDIR}/${PV}-mkstemp.patch
+ WANT_AUTOCONF=2.1 autoconf || die "autoconf failed"
}
src_compile() {
+ export CC="$(tc-getCC)" RANLIB="$(tc-getRANLIB)"
# very old configure script ... econf wont work
local myconf="--prefix=/ --host=${CHOST}"
- [ ! -z "${CBUILD}" ] && myconf="${myconf} --build=${CBUILD}"
+ [[ -n ${CBUILD} ]] && myconf="${myconf} --build=${CBUILD}"
+ [[ -n ${CTARGET} ]] && myconf="${myconf} --target=${CTARGET}"
myconf="${myconf} ${EXTRA_ECONF}"
echo "./configure ${myconf}"
./configure ${myconf} || die
- emake || die
+ emake AR="$(tc-getAR)" || die
}
src_install() {