summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Imhof <tantive@gentoo.org>2003-04-07 08:05:54 +0000
committerMichael Imhof <tantive@gentoo.org>2003-04-07 08:05:54 +0000
commit5465ac9999be7a5e4ad094c1ef921afc9f9ac5ed (patch)
tree55d8ab96bef4e26c56bf1024ca281cff4df961eb /sys-apps/evms
parentget rid of a possibility of copyright infringement (diff)
downloadgentoo-2-5465ac9999be7a5e4ad094c1ef921afc9f9ac5ed.tar.gz
gentoo-2-5465ac9999be7a5e4ad094c1ef921afc9f9ac5ed.tar.bz2
gentoo-2-5465ac9999be7a5e4ad094c1ef921afc9f9ac5ed.zip
Version bumped as old version was broken. Added new init-script for 2.0.0. Should close 18835
Diffstat (limited to 'sys-apps/evms')
-rw-r--r--sys-apps/evms/ChangeLog8
-rw-r--r--sys-apps/evms/evms-2.0.0-r1.ebuild (renamed from sys-apps/evms/evms-2.0.0.ebuild)26
-rw-r--r--sys-apps/evms/files/digest-evms-2.0.0-r1 (renamed from sys-apps/evms/files/digest-evms-2.0.0)0
-rw-r--r--sys-apps/evms/files/evms2-init16
4 files changed, 33 insertions, 17 deletions
diff --git a/sys-apps/evms/ChangeLog b/sys-apps/evms/ChangeLog
index 5a9d1090ea36..e8981dad3e5a 100644
--- a/sys-apps/evms/ChangeLog
+++ b/sys-apps/evms/ChangeLog
@@ -1,7 +1,13 @@
# ChangeLog for sys-apps/evms
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/evms/ChangeLog,v 1.16 2003/04/05 20:36:42 tantive Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/evms/ChangeLog,v 1.17 2003/04/07 08:05:54 tantive Exp $
+*evms-2.0.0-r1 (08 Apr 2003)
+
+ 08 Apr 2003; Michael Imhof <tantive@gentoo.org>:
+ Version bumped to -r1 as -r0 was borked. Removed -r0.
+ Added new init-script for 2.0.0
+ Should close #18835.
*evms-2.0.0 (06 Apr 2003)
diff --git a/sys-apps/evms/evms-2.0.0.ebuild b/sys-apps/evms/evms-2.0.0-r1.ebuild
index a1b74bd16a70..46b6127b0abe 100644
--- a/sys-apps/evms/evms-2.0.0.ebuild
+++ b/sys-apps/evms/evms-2.0.0-r1.ebuild
@@ -1,12 +1,11 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/evms/evms-2.0.0.ebuild,v 1.1 2003/04/05 20:36:42 tantive Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/evms/evms-2.0.0-r1.ebuild,v 1.1 2003/04/07 08:05:54 tantive Exp $
IUSE="ncurses gtk"
inherit eutils
-S="${WORKDIR}/${P}"
DESCRIPTION="Utilities for the IBM Enterprise Volume Management System"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
HOMEPAGE="http://www.sourceforge.net/projects/evms"
@@ -21,33 +20,29 @@ DEPEND="virtual/glibc
gtk? ( =x11-libs/gtk+-1* )
ncurses? ( sys-libs/ncurses )"
-
src_compile() {
- local interfaces="CommandLine,utilities,LvmUtils"
- use ncurses && interfaces="ncurses,${interfaces}"
- use gtk && interfaces="evmsgui,${interfaces}"
+ local excluded_interfaces=""
+ use ncurses || excluded_interfaces="--disable-text-mode"
+ use gtk || excluded_interfaces="${excluded_interfaces} --disable-gui"
- cd engine
./configure \
--prefix=/usr \
--libdir=/lib \
--sbindir=/sbin \
- --with-plugins=all \
--mandir=/usr/share/man \
--includedir=/usr/include \
- --with-interfaces=${interfaces} \
- --host=${CHOST} || die "bad ./configure"
- #1.2.0 doesn't support parallel make
- make || die "compile problem"
+ ${excluded_interfaces} || die "Failed configure"
+ emake || die "Failed emake"
}
src_install() {
- make -C engine DESTDIR=${D} install || die
- dodoc CHANGES COPYING EVMS*.txt PLUGIN.IDS
+ make DESTDIR=${D} install || die "Make install died"
+ dodoc ChangeLog COPYING TERMINOLOGY PLUGIN.IDS
# move static libraries to /usr/lib
dodir /usr/lib
mv -f ${D}/lib/*.a ${D}/usr/lib
+
# Create linker scripts for dynamic libs in /lib, else gcc
# links to the static ones in /usr/lib first. Bug #4411.
for x in ${D}/usr/lib/*.a
@@ -75,6 +70,5 @@ src_install() {
fi
exeinto /etc/init.d
- newexe ${FILESDIR}/evms-init evms
+ newexe ${FILESDIR}/evms2-init evms
}
-
diff --git a/sys-apps/evms/files/digest-evms-2.0.0 b/sys-apps/evms/files/digest-evms-2.0.0-r1
index 2b093ac4504f..2b093ac4504f 100644
--- a/sys-apps/evms/files/digest-evms-2.0.0
+++ b/sys-apps/evms/files/digest-evms-2.0.0-r1
diff --git a/sys-apps/evms/files/evms2-init b/sys-apps/evms/files/evms2-init
new file mode 100644
index 000000000000..d40c9e1134d7
--- /dev/null
+++ b/sys-apps/evms/files/evms2-init
@@ -0,0 +1,16 @@
+#!/sbin/runscript
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/evms/files/evms2-init,v 1.1 2003/04/07 08:05:54 tantive Exp $
+
+start() {
+ ebegin "Starting evms"
+ evms_activate
+ eend 0
+}
+
+stop() {
+ ebegin "Stopping evms"
+ evms_deactivate
+ eend 0
+}