summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2002-07-23 18:03:52 +0000
committerDaniel Robbins <drobbins@gentoo.org>2002-07-23 18:03:52 +0000
commit56f4807825f670c6304ba1c928c1f99c8d024a0e (patch)
tree3882c2869d1c9db61d16470f8ae6731be168180b /sys-apps/evms
parentAdd pam dependancy line. Closes bug #5148. Added KEYWORDS. (diff)
downloadgentoo-2-56f4807825f670c6304ba1c928c1f99c8d024a0e.tar.gz
gentoo-2-56f4807825f670c6304ba1c928c1f99c8d024a0e.tar.bz2
gentoo-2-56f4807825f670c6304ba1c928c1f99c8d024a0e.zip
New prerelease version of the EVMS tools that works with the mjc kernels,
has support for ext2/3/swap/ReiserFS/JFS filesystems via modules.
Diffstat (limited to 'sys-apps/evms')
-rw-r--r--sys-apps/evms/evms-1.1.0_pre4.ebuild99
-rw-r--r--sys-apps/evms/files/digest-evms-1.1.0_pre41
-rw-r--r--sys-apps/evms/files/evms-1.1.0-pre4-gcc31.diff24
-rw-r--r--sys-apps/evms/files/evms-1.1.0-pre4-reiserfs-3.6.diff59
4 files changed, 183 insertions, 0 deletions
diff --git a/sys-apps/evms/evms-1.1.0_pre4.ebuild b/sys-apps/evms/evms-1.1.0_pre4.ebuild
new file mode 100644
index 000000000000..4d7b86fcfcb7
--- /dev/null
+++ b/sys-apps/evms/evms-1.1.0_pre4.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/evms/evms-1.1.0_pre4.ebuild,v 1.1 2002/07/23 18:03:52 drobbins Exp $
+
+# You need to have an evms-patched kernel source tree in /usr/src/linux
+# to build this. Either take care of that yourself or do these steps :
+#
+# o get a vanilla 2.4.18 kernel and unpack it in /usr/src/linux
+# o ebuild evms-1.0.1.ebuild clean unpack
+# o cd /usr/src/linux
+# o patch -p1 < /tmp/portage/evms-1.0.1/work/evms-1.0.1/kernel/evms-1.0.1-linux-2.4.patch
+# o patch -p1 < /tmp/portage/evms-1.0.1/work/evms-1.0.1/kernel/evms-linux-2.4.18-common-files.patch
+# o patch -p1 < /tmp/portage/evms-1.0.1/work/evms-1.0.1/kernel/linux-2.4.18-VFS-lock.patch
+#
+# The third patch isn't totally required. Now configure your kernel
+# and select the evms features that you want. If you plan on using
+# an evms volume on your /boot partition then you'll need to use the
+# included patch against lilo-22.2 in the same directory as above.
+# Please see their homepage for further information and details.
+
+DESCRIPTION="Utilities for the IBM Enterprise Volume Management System"
+HOMEPAGE="http://www.sourceforge.net/projects/evms"
+KEYWORDS="x86 -ppc"
+
+NEWP=evms-1.1.0-pre4
+LIBV=1.1.0
+S=${WORKDIR}/${NEWP}
+SRC_URI="ftp://ftp.sourceforge.net/pub/sourceforge/${PN}/${NEWP}.tar.gz"
+
+#EVMS uses libuuid from e2fsprogs
+DEPEND="virtual/glibc gtk? ( =x11-libs/gtk+-1* ) ncurses? ( sys-libs/ncurses ) sys-apps/e2fsprogs"
+LICENSE="GPL-2"
+SLOT="0"
+
+pkg_setup() {
+ if [ ! -f /usr/src/linux/include/linux/evms/evms.h ]
+ then
+ eerror "You dont appear to have an evms-patched kernel source"
+ eerror "tree in /usr/src/linux. Please fix that and try again."
+ return 1
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ #this next patch fixes some missing libuuid symbols:
+ patch -p1 < ${FILESDIR}/${NEWP}-gcc31.diff || die
+ #this next patch allows EVMS to recognize the new ReiserFS 3.6 versioning scheme
+ patch -p1 < ${FILESDIR}/${NEWP}-reiserfs-3.6.diff || die
+}
+
+src_compile() {
+ local interfaces="CommandLine,LvmUtils,utilities"
+ use ncurses && interfaces="ncurses,${interfaces}"
+ use gtk && interfaces="evmsgui,${interfaces}"
+
+ cd engine
+ ./configure \
+ --prefix=/usr \
+ --libdir=/lib \
+ --sbindir=/sbin \
+ --with-plugins=all \
+ --mandir=/usr/share/man \
+ --includedir=/usr/include \
+ --with-kernel=/usr/src/linux \
+ --with-interfaces=${interfaces} \
+ --host=${CHOST} || die "bad ./configure"
+
+ emake || die "compile problem"
+}
+
+src_install() {
+ make -C engine DESTDIR=${D} install || die
+ dodoc CHANGES COPYING EVMS*.txt PLUGIN.IDS
+
+ # no need for static libraries in /lib
+ dodir /usr/lib
+ mv ${D}/lib/*.a ${D}/usr/lib
+
+ # make the non-existant symlinks. why doesn't their
+ # makefile do this? :/
+ cd ${D}/lib
+ rm -f libdlist.so libevms.so
+ ln -sf libevms-${LIBV}.so libevms.so.1
+ ln -sf libevms.so.1 libevms.so
+ ln -sf libdlist-1.0.so libdlist.so.1
+ ln -sf libdlist.so.1 libdlist.so
+
+ # the gtk+ frontend should live in /usr/sbin though..
+ if [ -n "`use gtk`" ]
+ then
+ dodir /usr/sbin
+ mv ${D}/sbin/evmsgui ${D}/usr/sbin
+ fi
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/evms-init evms
+}
diff --git a/sys-apps/evms/files/digest-evms-1.1.0_pre4 b/sys-apps/evms/files/digest-evms-1.1.0_pre4
new file mode 100644
index 000000000000..2b5fe62b3a3d
--- /dev/null
+++ b/sys-apps/evms/files/digest-evms-1.1.0_pre4
@@ -0,0 +1 @@
+MD5 d570e79fe545d64d47092b1a43b71dac evms-1.1.0-pre4.tar.gz 1505606
diff --git a/sys-apps/evms/files/evms-1.1.0-pre4-gcc31.diff b/sys-apps/evms/files/evms-1.1.0-pre4-gcc31.diff
new file mode 100644
index 000000000000..c35a771c286e
--- /dev/null
+++ b/sys-apps/evms/files/evms-1.1.0-pre4-gcc31.diff
@@ -0,0 +1,24 @@
+diff -urN evms-1.1.0-pre4/engine/Plugins/gptsegmgr/Makefile evms-1.1.0-pre4.fixed/engine/Plugins/gptsegmgr/Makefile
+--- evms-1.1.0-pre4/engine/Plugins/gptsegmgr/Makefile Tue Apr 30 11:36:48 2002
++++ evms-1.1.0-pre4.fixed/engine/Plugins/gptsegmgr/Makefile Tue Jul 23 11:29:45 2002
+@@ -28,7 +28,7 @@
+ rm -f $(DESTDIR)$(PLUGINS_DIR)/$(TARGET)
+
+ $(TARGET): $(OBJS)
+- $(CC) $(SO_CFLAGS) -luuid -Wl,-soname,$(SONAME) -o $(TARGET) $(OBJS)
++ $(CC) $(SO_CFLAGS) -Wl,-soname,$(SONAME) -o $(TARGET) $(OBJS) -luuid
+
+ clean:
+ rm -f .depend *.o *.so $(TARGET)
+diff -urN evms-1.1.0-pre4/engine/Plugins/jfsfsim/Makefile evms-1.1.0-pre4.fixed/engine/Plugins/jfsfsim/Makefile
+--- evms-1.1.0-pre4/engine/Plugins/jfsfsim/Makefile Fri May 17 14:05:04 2002
++++ evms-1.1.0-pre4.fixed/engine/Plugins/jfsfsim/Makefile Tue Jul 23 11:30:02 2002
+@@ -28,7 +28,7 @@
+ rm -f $(DESTDIR)$(PLUGINS_DIR)/$(TARGET)
+
+ $(TARGET): $(OBJS)
+- $(CC) $(SO_CFLAGS) -luuid -Wl,-soname,$(SONAME) -o $(TARGET) $(OBJS)
++ $(CC) $(SO_CFLAGS) -Wl,-soname,$(SONAME) -o $(TARGET) $(OBJS) -luuid
+
+ clean:
+ rm -f .depend *.o *.so $(TARGET)
diff --git a/sys-apps/evms/files/evms-1.1.0-pre4-reiserfs-3.6.diff b/sys-apps/evms/files/evms-1.1.0-pre4-reiserfs-3.6.diff
new file mode 100644
index 000000000000..e01307aaaa5f
--- /dev/null
+++ b/sys-apps/evms/files/evms-1.1.0-pre4-reiserfs-3.6.diff
@@ -0,0 +1,59 @@
+diff -urN evms-1.1.0-pre4/engine/Plugins/reiserfsim/reiserfs.c evms-1.1.0-pre4.fixed/engine/Plugins/reiserfsim/reiserfs.c
+--- evms-1.1.0-pre4/engine/Plugins/reiserfsim/reiserfs.c Wed Jun 19 16:54:20 2002
++++ evms-1.1.0-pre4.fixed/engine/Plugins/reiserfsim/reiserfs.c Tue Jul 23 11:49:16 2002
+@@ -563,14 +563,18 @@
+ if ((ver = strstr(buffer, "3.x.0"))) {
+ reiser_version = 0;
+ end = strstr(ver,"\n");
+- strncpy(reiser_version_text,ver,min((int)end - (int)ver,31));
++ strncpy(reiser_version_text,ver,min(end - ver,31));
+ rc = 0;
+ } else if ((ver =strstr(buffer, "3.x.1"))) {
+ end = strstr(ver,"\n");
+ strncpy(reiser_version_text,ver,min(end - ver,31));
+-// strncpy(reiser_version_text,ver,31);
+ reiser_version = 1;
+ rc = 0;
++ } else if ((ver = strstr(buffer, "3.6."))) {
++ end = strstr(ver,"\n");
++ strncpy(reiser_version_text,ver,min(end - ver,31));
++ reiser_version = 2;
++ rc = 0;
+ }
+ }
+ }
+@@ -818,9 +822,9 @@
+ LOGENTRY();
+
+ /* don't expand if mounted */
+- if (EngFncs->is_mounted(volume->name, NULL)) {
+- return EBUSY;
+- }
++// if (EngFncs->is_mounted(volume->name, NULL)) {
++// return EBUSY;
++// }
+
+ rc = pipe(fds1);
+ if (rc) {
+@@ -1671,9 +1675,9 @@
+ int rc = 0;
+
+ LOGENTRY();
+- if (EngFncs->is_mounted(volume->name, NULL)) {
+- rc = EBUSY; // If mounted, can't expand
+- } else {
++// if (EngFncs->is_mounted(volume->name, NULL)) {
++// rc = EBUSY; // If mounted, can't expand
++// } else {
+ fs_get_fs_limits( volume, // reset limits.
+ &volume->min_fs_size,
+ &volume->max_vol_size,
+@@ -1681,7 +1685,7 @@
+ if (volume->fs_size + *delta > volume->max_fs_size) {
+ *delta = volume->max_fs_size - volume->fs_size;
+ }
+- }
++// }
+ LOGEXITRC();
+ return rc;
+