summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-07-03 09:52:42 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-07-03 09:52:42 +0000
commit3f0c60baf3a973feec3f6cad09bc80d9d4b7a1d4 (patch)
treeb4cd8aeb55a3f6e69f8f60b8f798892d491b2f0f /sys-apps/fakeroot
parentremove requirement for depend.php from php-pear-lib-r1.eclass (diff)
downloadgentoo-2-3f0c60baf3a973feec3f6cad09bc80d9d4b7a1d4.tar.gz
gentoo-2-3f0c60baf3a973feec3f6cad09bc80d9d4b7a1d4.tar.bz2
gentoo-2-3f0c60baf3a973feec3f6cad09bc80d9d4b7a1d4.zip
Fix building with USE="-acl" wrt #424419 by Maksim Melnikau
(Portage version: 2.2.0_alpha114/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/fakeroot')
-rw-r--r--sys-apps/fakeroot/ChangeLog6
-rw-r--r--sys-apps/fakeroot/fakeroot-1.18.4.ebuild6
-rw-r--r--sys-apps/fakeroot/files/fakeroot-1.18.4-no-acl_h.patch35
3 files changed, 45 insertions, 2 deletions
diff --git a/sys-apps/fakeroot/ChangeLog b/sys-apps/fakeroot/ChangeLog
index 0fb9a4bbf28d..461c80f4c0d6 100644
--- a/sys-apps/fakeroot/ChangeLog
+++ b/sys-apps/fakeroot/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/fakeroot
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/fakeroot/ChangeLog,v 1.86 2012/06/07 09:10:50 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/fakeroot/ChangeLog,v 1.87 2012/07/03 09:52:42 ssuominen Exp $
+
+ 03 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> fakeroot-1.18.4.ebuild,
+ +files/fakeroot-1.18.4-no-acl_h.patch:
+ Fix building with USE="-acl" wrt #424419 by Maksim Melnikau
*fakeroot-1.18.4 (07 Jun 2012)
diff --git a/sys-apps/fakeroot/fakeroot-1.18.4.ebuild b/sys-apps/fakeroot/fakeroot-1.18.4.ebuild
index 61718791cedd..428b239622e3 100644
--- a/sys-apps/fakeroot/fakeroot-1.18.4.ebuild
+++ b/sys-apps/fakeroot/fakeroot-1.18.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/fakeroot/fakeroot-1.18.4.ebuild,v 1.1 2012/06/07 09:10:50 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/fakeroot/fakeroot-1.18.4.ebuild,v 1.2 2012/07/03 09:52:42 ssuominen Exp $
EAPI=4
inherit eutils
@@ -21,6 +21,10 @@ DEPEND="${RDEPEND}
DOCS="AUTHORS BUGS DEBUG README doc/README.saving"
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.18.4-no-acl_h.patch
+}
+
src_configure() {
export ac_cv_header_sys_acl_h=$(usex acl)
diff --git a/sys-apps/fakeroot/files/fakeroot-1.18.4-no-acl_h.patch b/sys-apps/fakeroot/files/fakeroot-1.18.4-no-acl_h.patch
new file mode 100644
index 000000000000..dbd9dd7758e9
--- /dev/null
+++ b/sys-apps/fakeroot/files/fakeroot-1.18.4-no-acl_h.patch
@@ -0,0 +1,35 @@
+http://bugs.gentoo.org/424419
+
+--- libfakeroot.c
++++ libfakeroot.c
+@@ -1551,6 +1551,7 @@
+ return fakeroot_disabled;
+ }
+
++#ifdef HAVE_SYS_ACL_H
+ #ifdef HAVE_ACL_T
+ int acl_set_fd(int fd, acl_t acl) {
+ errno = ENOTSUP;
+@@ -1561,6 +1562,7 @@
+ errno = ENOTSUP;
+ return -1;
+ }
++#endif /* HAVE_ACL_T */
+ #endif /* HAVE_SYS_ACL_H */
+
+ #ifdef HAVE_FTS_READ
+--- wrapfunc.inp
++++ wrapfunc.inp
+@@ -167,10 +167,12 @@
+ #endif /* HAVE_UNLINKAT */
+ #endif /* HAVE_FSTATAT */
+
++#ifdef HAVE_SYS_ACL_H
+ #ifdef HAVE_ACL_T
+ acl_set_fd;int;(int fd, acl_t acl);(fd, acl)
+ acl_set_file;int;(const char *path_p, acl_type_t type, acl_t acl);(path_p, type, acl)
+ #endif /* HAVE_ACL_T */
++#endif /* HAVE_SYS_ACL_H */
+
+ #ifdef HAVE_FTS_READ
+ fts_read;FTSENT *;(FTS *ftsp);(ftsp)