summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-02-04 18:25:47 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-02-04 18:25:47 +0000
commit18942984dc41ffcbbcf655008bfd8cdcbd952b32 (patch)
tree0e6d0a216a1e4be3ff5e2718a791c6d282496283 /sys-apps/file
parentold (diff)
downloadgentoo-2-18942984dc41ffcbbcf655008bfd8cdcbd952b32.tar.gz
gentoo-2-18942984dc41ffcbbcf655008bfd8cdcbd952b32.tar.bz2
gentoo-2-18942984dc41ffcbbcf655008bfd8cdcbd952b32.zip
Set PYTHON_DEPEND. Set SUPPORT_PYTHON_ABIS. Unset DISTUTILS_DISABLE_PYTHON_DEPENDENCY. Restrict installation for Python 3.
(Portage version: 15318-svn/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/file')
-rw-r--r--sys-apps/file/ChangeLog7
-rw-r--r--sys-apps/file/file-5.03.ebuild12
-rw-r--r--sys-apps/file/file-5.04.ebuild10
3 files changed, 19 insertions, 10 deletions
diff --git a/sys-apps/file/ChangeLog b/sys-apps/file/ChangeLog
index f973b865ed7b..128b7eba46e6 100644
--- a/sys-apps/file/ChangeLog
+++ b/sys-apps/file/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/file
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/ChangeLog,v 1.178 2010/01/25 02:54:39 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/ChangeLog,v 1.179 2010/02/04 18:25:47 arfrever Exp $
+
+ 04 Feb 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ file-5.03.ebuild, file-5.04.ebuild:
+ Set PYTHON_DEPEND. Set SUPPORT_PYTHON_ABIS. Unset DISTUTILS_DISABLE_PYTHON_DEPENDENCY.
+ Restrict installation for Python 3.
*file-5.04 (25 Jan 2010)
diff --git a/sys-apps/file/file-5.03.ebuild b/sys-apps/file/file-5.03.ebuild
index 3683701abafc..a1a4ca13aee9 100644
--- a/sys-apps/file/file-5.03.ebuild
+++ b/sys-apps/file/file-5.03.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-5.03.ebuild,v 1.9 2009/10/05 18:19:20 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-5.03.ebuild,v 1.10 2010/02/04 18:25:47 arfrever Exp $
-DISTUTILS_DISABLE_PYTHON_DEPENDENCY="1"
+PYTHON_DEPEND="python? 2"
+SUPPORT_PYTHON_ABIS="1"
inherit eutils distutils libtool flag-o-matic
@@ -16,8 +17,9 @@ SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
IUSE="python"
-DEPEND="python? ( virtual/python )"
-RDEPEND="${DEPEND}"
+DEPEND=""
+RDEPEND=""
+RESTRICT_PYTHON_ABIS="3.*"
src_unpack() {
unpack ${P}.tar.gz
diff --git a/sys-apps/file/file-5.04.ebuild b/sys-apps/file/file-5.04.ebuild
index e23905cee13f..6b75afc874f3 100644
--- a/sys-apps/file/file-5.04.ebuild
+++ b/sys-apps/file/file-5.04.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-5.04.ebuild,v 1.1 2010/01/25 02:54:39 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-5.04.ebuild,v 1.2 2010/02/04 18:25:47 arfrever Exp $
-DISTUTILS_DISABLE_PYTHON_DEPENDENCY="1"
+PYTHON_DEPEND="python? 2"
+SUPPORT_PYTHON_ABIS="1"
inherit eutils distutils libtool flag-o-matic
@@ -16,8 +17,9 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
IUSE="python"
-DEPEND="python? ( virtual/python )"
-RDEPEND="${DEPEND}"
+DEPEND=""
+RDEPEND=""
+RESTRICT_PYTHON_ABIS="3.*"
src_unpack() {
unpack ${P}.tar.gz