summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-08-18 22:27:24 +0000
committerMike Frysinger <vapier@gentoo.org>2005-08-18 22:27:24 +0000
commitb000493993b67deec516eccd478a5a54050f7c9f (patch)
treeae6cf8131cfc1aea2510f1982c1fe2d5943e9fdb /sys-apps/file
parentold&broken (diff)
downloadgentoo-2-b000493993b67deec516eccd478a5a54050f7c9f.tar.gz
gentoo-2-b000493993b67deec516eccd478a5a54050f7c9f.tar.bz2
gentoo-2-b000493993b67deec516eccd478a5a54050f7c9f.zip
Version bump to fix #101298 by PIERRE Benoît / #101639 by Preston Crow / #102520 by Daniel Drake.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'sys-apps/file')
-rw-r--r--sys-apps/file/ChangeLog22
-rw-r--r--sys-apps/file/file-4.15.ebuild54
-rw-r--r--sys-apps/file/files/digest-file-4.151
3 files changed, 60 insertions, 17 deletions
diff --git a/sys-apps/file/ChangeLog b/sys-apps/file/ChangeLog
index 56fb80263d59..98eaa624ea25 100644
--- a/sys-apps/file/ChangeLog
+++ b/sys-apps/file/ChangeLog
@@ -1,29 +1,17 @@
# ChangeLog for sys-apps/file
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/ChangeLog,v 1.86 2005/08/18 04:10:46 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/ChangeLog,v 1.87 2005/08/18 22:27:24 vapier Exp $
- 18 Aug 2005; Mike Frysinger <vapier@gentoo.org> file-4.14.ebuild:
- Mask until #101298 / #101639 / #102520 get sorted out.
+*file-4.15 (18 Aug 2005)
- 09 Aug 2005; Aaron Walker <ka0ttic@gentoo.org> file-4.13.ebuild:
- Stable on mips.
+ 18 Aug 2005; Mike Frysinger <vapier@gentoo.org> +file-4.15.ebuild:
+ Version bump to fix up #101298 by PIERRE Benoît / #101639 by Preston
+ Crow / #102520 by Daniel Drake.
24 Jul 2005; Martin Schlemmer <azarah@gentoo.org>
+files/file-4.14-gcc2.patch, file-4.14.ebuild:
Fix building with gcc2.
- 20 Jul 2005; Markus Rothe <corsair@gentoo.org> file-4.13.ebuild:
- Stable on ppc64
-
- 19 Jul 2005; Bryan Østergaard <kloeri@gentoo.org> file-4.13.ebuild:
- Stable on alpha.
-
- 18 Jul 2005; Gustavo Zacarias <gustavoz@gentoo.org> file-4.13.ebuild:
- Stable on sparc
-
- 18 Jul 2005; Joseph Jezak <josejx@gentoo.org> file-4.13.ebuild:
- Marked ppc stable.
-
*file-4.14 (17 Jul 2005)
17 Jul 2005; Mike Frysinger <vapier@gentoo.org> +file-4.14.ebuild:
diff --git a/sys-apps/file/file-4.15.ebuild b/sys-apps/file/file-4.15.ebuild
new file mode 100644
index 000000000000..af354180b64a
--- /dev/null
+++ b/sys-apps/file/file-4.15.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-4.15.ebuild,v 1.1 2005/08/18 22:27:24 vapier Exp $
+
+inherit distutils libtool
+
+DESCRIPTION="identify a file's format by scanning binary data for patterns"
+HOMEPAGE="ftp://ftp.astron.com/pub/file/"
+SRC_URI="ftp://ftp.gw.com/mirrors/pub/unix/file/${P}.tar.gz
+ ftp://ftp.astron.com/pub/file/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="python build"
+
+DEPEND="!build? ( python? ( virtual/python ) )"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd "${S}"
+
+ uclibctoolize
+
+ # make sure python links against the current libmagic #54401
+ sed -i "/library_dirs/s:'\.\./src':'../src/.libs':" python/setup.py
+
+ # dont let python README kill main README #60043
+ mv python/README{,.python}
+}
+
+src_compile() {
+ econf --datadir=/usr/share/misc || die
+ emake || die "emake failed"
+
+ use python && cd python && distutils_src_compile
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ if ! use build ; then
+ dodoc ChangeLog MAINT README
+ use python && cd python && distutils_src_install
+ fi
+}
+
+pkg_postinst() {
+ use python && distutils_pkg_postinst
+}
+
+pkg_postrm() {
+ use python && distutils_pkg_postrm
+}
diff --git a/sys-apps/file/files/digest-file-4.15 b/sys-apps/file/files/digest-file-4.15
new file mode 100644
index 000000000000..e534cb0de2d5
--- /dev/null
+++ b/sys-apps/file/files/digest-file-4.15
@@ -0,0 +1 @@
+MD5 09a6603dadbe06e577e98a2547201fab file-4.15.tar.gz 546522