summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-05-14 10:36:32 +0000
committerMike Frysinger <vapier@gentoo.org>2011-05-14 10:36:32 +0000
commitb23d22692e593e91c340986fa413029a0471c94f (patch)
treec866ac85206618bf2397fb9b6a98dac41096a008 /sys-apps/grep/grep-2.8.ebuild
parentppc/ppc64 stable wrt #366369 (diff)
downloadgentoo-2-b23d22692e593e91c340986fa413029a0471c94f.tar.gz
gentoo-2-b23d22692e593e91c340986fa413029a0471c94f.tar.bz2
gentoo-2-b23d22692e593e91c340986fa413029a0471c94f.zip
Version bump.
(Portage version: 2.2.0_alpha32/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/grep/grep-2.8.ebuild')
-rw-r--r--sys-apps/grep/grep-2.8.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-apps/grep/grep-2.8.ebuild b/sys-apps/grep/grep-2.8.ebuild
new file mode 100644
index 000000000000..08e920a3256a
--- /dev/null
+++ b/sys-apps/grep/grep-2.8.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/grep-2.8.ebuild,v 1.1 2011/05/14 10:36:32 vapier Exp $
+
+EAPI="3"
+
+DESCRIPTION="GNU regular expression matcher"
+HOMEPAGE="http://www.gnu.org/software/grep/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz
+ mirror://gentoo/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+IUSE="nls pcre"
+
+RDEPEND="nls? ( virtual/libintl )
+ pcre? ( >=dev-libs/libpcre-7.8-r1 )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_configure() {
+ econf \
+ --bindir=/bin \
+ $(use_enable nls) \
+ $(use_enable pcre perl-regexp) \
+ $(use elibc_FreeBSD || echo --without-included-regex)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+}