summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2003-02-08 21:18:38 +0000
committerMartin Schlemmer <azarah@gentoo.org>2003-02-08 21:18:38 +0000
commit1fb72c636102a76fe420e7d967a513fed0ee98b8 (patch)
treed252b7bf6f79f7263d419497ab4b1af350a770e4 /sys-apps/groff
parentAdded hppa to keywords. (diff)
downloadgentoo-2-1fb72c636102a76fe420e7d967a513fed0ee98b8.tar.gz
gentoo-2-1fb72c636102a76fe420e7d967a513fed0ee98b8.tar.bz2
gentoo-2-1fb72c636102a76fe420e7d967a513fed0ee98b8.zip
bugfix
Diffstat (limited to 'sys-apps/groff')
-rw-r--r--sys-apps/groff/ChangeLog7
-rw-r--r--sys-apps/groff/files/digest-groff-1.18.1-r11
-rw-r--r--sys-apps/groff/files/groff-1.18.1-no-color-segfault.patch33
-rw-r--r--sys-apps/groff/groff-1.18.1-r1.ebuild88
4 files changed, 128 insertions, 1 deletions
diff --git a/sys-apps/groff/ChangeLog b/sys-apps/groff/ChangeLog
index a362d5d0961c..b877b948dcb9 100644
--- a/sys-apps/groff/ChangeLog
+++ b/sys-apps/groff/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/groff
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/groff/ChangeLog,v 1.13 2003/02/07 20:40:26 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/groff/ChangeLog,v 1.14 2003/02/08 21:18:38 azarah Exp $
+
+*groff-1.18.1-r1 (08 Feb 2003)
+
+ 08 Feb 2003; Martin Schlemmer <azarah@gentoo.org> groff-1.18.1-r1.ebuild :
+ Do not segfault if no color is defined in input, bug #14329.
07 Feb 2003; Guy Martin <gmsoft@gentoo.org> groff-1.18.1.ebuild :
Added hppa to keywords.
diff --git a/sys-apps/groff/files/digest-groff-1.18.1-r1 b/sys-apps/groff/files/digest-groff-1.18.1-r1
new file mode 100644
index 000000000000..94400bd5b25d
--- /dev/null
+++ b/sys-apps/groff/files/digest-groff-1.18.1-r1
@@ -0,0 +1 @@
+MD5 4c7a1b478d230696f14743772f31639f groff-1.18.1.tar.gz 2250463
diff --git a/sys-apps/groff/files/groff-1.18.1-no-color-segfault.patch b/sys-apps/groff/files/groff-1.18.1-no-color-segfault.patch
new file mode 100644
index 000000000000..fee3e6ad55d5
--- /dev/null
+++ b/sys-apps/groff/files/groff-1.18.1-no-color-segfault.patch
@@ -0,0 +1,33 @@
+--- groff-1.18.1/src/roff/troff/node.cc.orig 2003-01-08 20:29:35.000000000 +0200
++++ groff-1.18.1/src/roff/troff/node.cc 2003-01-08 22:37:46.000000000 +0200
+@@ -992,8 +992,10 @@
+ if (c == '\0') {
+ flush_tbuf();
+ do_motion();
+- glyph_color(gcol);
+- fill_color(fcol);
++ if (gcol)
++ glyph_color(gcol);
++ if (fcol)
++ fill_color(fcol);
+ check_charinfo(tf, ci);
+ if (ci->numbered()) {
+ put('N');
+@@ -1162,7 +1164,7 @@
+
+ void troff_output_file::fill_color(color *col)
+ {
+- if ((current_fill_color == col) || !color_flag)
++ if ((current_fill_color == col) || !color_flag || !col)
+ return;
+ flush_tbuf();
+ put("DF");
+@@ -1210,7 +1212,7 @@
+
+ void troff_output_file::glyph_color(color *col)
+ {
+- if ((current_glyph_color == col) || !color_flag)
++ if ((current_glyph_color == col) || !color_flag || !col)
+ return;
+ flush_tbuf();
+ put("m");
diff --git a/sys-apps/groff/groff-1.18.1-r1.ebuild b/sys-apps/groff/groff-1.18.1-r1.ebuild
new file mode 100644
index 000000000000..f563dcc1c6fa
--- /dev/null
+++ b/sys-apps/groff/groff-1.18.1-r1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/groff/groff-1.18.1-r1.ebuild,v 1.1 2003/02/08 21:18:38 azarah Exp $
+
+IUSE=""
+
+inherit eutils
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Text formatter used for man pages"
+SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/groff/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/groff/groff.html"
+
+KEYWORDS="x86 ~ppc ~sparc alpha ~mips hppa"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="virtual/glibc"
+
+PDEPEND=">=sys-apps/man-1.5k-r1"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # Fix the info pages to have .info extensions,
+ # else they do not get gzipped.
+ epatch ${FILESDIR}/groff-1.18-infoext.patch
+
+ # Do not generate example files that require us to
+ # depend on netpbm.
+ epatch ${FILESDIR}/groff-1.18-no-netpbm-depend.patch
+
+ # Do not segfault if no color is defined in input, bug #14329
+ # <azarah@gentoo.org> (08 Feb 2003)
+ epatch ${FILESDIR}/${P}-no-color-segfault.patch
+}
+
+src_compile() {
+ # Fix problems with not finding g++
+ [ -z "${CC}" ] && export CC="gcc"
+ [ -z "${CXX}" ] && export CXX="g++"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=\${inforoot} || die
+
+ # emake doesn't work
+ make || die
+
+ # Only build X stuff if we have X installed, but do
+ # not depend on it, else we get circular deps.
+ if [ -n "`use X`" ] && [ -x /usr/X11R6/bin/xmkmf ]
+ then
+ cd ${S}/src/xditview
+ xmkmf || die
+ make depend all || die
+ fi
+}
+
+src_install() {
+ dodir /usr /usr/share/doc/${PF}/{examples,html}
+ make prefix=${D}/usr \
+ manroot=${D}/usr/share/man \
+ inforoot=${D}/usr/share/info \
+ docdir=${D}/usr/share/doc/${PF} \
+ install || die
+
+ if [ -n "`use X`" ] && [ -x /usr/X11R6/bin/xmkmf ]
+ then
+ cd ${S}/src/xditview
+ make DESTDIR=${D} \
+ BINDIR=/usr/bin \
+ MANPATH=/usr/share/man \
+ install \
+ install.man || die
+ fi
+
+ #the following links are required for xman
+ dosym eqn /usr/bin/geqn
+ dosym tbl /usr/bin/gtbl
+ dosym soelim /usr/bin/zsoelim
+
+ cd ${S}
+ dodoc BUG-REPORT COPYING ChangeLog FDL MORE.STUFF NEWS \
+ PROBLEMS PROJECTS README REVISION TODO VERSION
+}
+