summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Guertin <gerk@gentoo.org>2002-06-21 20:44:48 +0000
committerMark Guertin <gerk@gentoo.org>2002-06-21 20:44:48 +0000
commit2a4dcbfb4ff09de29d4d59cc2ab8f86fa2f5f609 (patch)
tree6280561cb2c1724cd363915aea63926f61e17dba /sys-apps/gtkpbbuttons
parentupdated arch detect setup (diff)
downloadgentoo-2-2a4dcbfb4ff09de29d4d59cc2ab8f86fa2f5f609.tar.gz
gentoo-2-2a4dcbfb4ff09de29d4d59cc2ab8f86fa2f5f609.tar.bz2
gentoo-2-2a4dcbfb4ff09de29d4d59cc2ab8f86fa2f5f609.zip
updated arch detect setup
Diffstat (limited to 'sys-apps/gtkpbbuttons')
-rw-r--r--sys-apps/gtkpbbuttons/gtkpbbuttons-0.4.6b.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/sys-apps/gtkpbbuttons/gtkpbbuttons-0.4.6b.ebuild b/sys-apps/gtkpbbuttons/gtkpbbuttons-0.4.6b.ebuild
index 295e55a1a537..cdc88e5e84fb 100644
--- a/sys-apps/gtkpbbuttons/gtkpbbuttons-0.4.6b.ebuild
+++ b/sys-apps/gtkpbbuttons/gtkpbbuttons-0.4.6b.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author David Chamberlain <daybird@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gtkpbbuttons/gtkpbbuttons-0.4.6b.ebuild,v 1.2 2002/05/09 15:36:34 daybird Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gtkpbbuttons/gtkpbbuttons-0.4.6b.ebuild,v 1.3 2002/06/21 20:42:58 gerk Exp $
S=${WORKDIR}/${P}
DESCRIPTION="gtkpbbuttons is a PPC-only program to monitor special Powerbook/iBook keys in Linux"
@@ -12,6 +12,11 @@ DEPEND="x11-libs/gtk+ media-libs/audiofile sys-apps/pbbuttonsd"
src_compile() {
+ if [ ${ARCH} = "x86" ] ; then
+ einfo "PPC Only build, sorry"
+ exit 1
+ fi
+
./configure --prefix=/usr || die "sorry, ppc-only package"
make || die "sorry, gtkpbbuttons compile failed"
}