summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2014-02-24 22:45:57 +0000
committerAnthony G. Basile <blueness@gentoo.org>2014-02-24 22:45:57 +0000
commit16c6cae8f519bdfddcbeb8e9ccf10a4784075a10 (patch)
treeeb964badfba76f2c98c26914e7e719a7edd35e9a /sys-apps/haveged/haveged-1.9.1.ebuild
parentWe no longer need libxslt and docbook for non-LIVE builds. (diff)
downloadgentoo-2-16c6cae8f519bdfddcbeb8e9ccf10a4784075a10.tar.gz
gentoo-2-16c6cae8f519bdfddcbeb8e9ccf10a4784075a10.tar.bz2
gentoo-2-16c6cae8f519bdfddcbeb8e9ccf10a4784075a10.zip
Version bump
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'sys-apps/haveged/haveged-1.9.1.ebuild')
-rw-r--r--sys-apps/haveged/haveged-1.9.1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sys-apps/haveged/haveged-1.9.1.ebuild b/sys-apps/haveged/haveged-1.9.1.ebuild
new file mode 100644
index 000000000000..2ca94c056617
--- /dev/null
+++ b/sys-apps/haveged/haveged-1.9.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/haveged/haveged-1.9.1.ebuild,v 1.1 2014/02/24 22:45:57 blueness Exp $
+
+EAPI=5
+
+inherit autotools-utils systemd
+
+DESCRIPTION="A simple entropy daemon using the HAVEGE algorithm"
+HOMEPAGE="http://www.issihosts.com/haveged/"
+SRC_URI="http://www.issihosts.com/haveged/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="!<sys-apps/openrc-0.11.8"
+
+# threads are broken right now, but eventually
+# we should add $(use_enable threads)
+src_configure() {
+ local myeconfargs=(
+ --bindir=/usr/sbin
+ --enable-nistest
+ --disable-static
+ --disable-threads
+ )
+
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ # Install gentoo ones instead
+ newinitd "${FILESDIR}"/haveged-init.d.3 haveged
+ newconfd "${FILESDIR}"/haveged-conf.d haveged
+
+ systemd_newunit "${FILESDIR}"/service.gentoo ${PN}.service
+ insinto /etc
+ doins "${FILESDIR}"/haveged.conf
+}