summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-12-29 22:05:02 +0000
committerMike Frysinger <vapier@gentoo.org>2010-12-29 22:05:02 +0000
commit348bde686606817b808c98917de758f3feeba239 (patch)
treedea64aa43150442aa920d9d9361a118960b1bf9a /sys-apps/help2man
parentarm stable, bug #344827 (diff)
downloadgentoo-2-348bde686606817b808c98917de758f3feeba239.tar.gz
gentoo-2-348bde686606817b808c98917de758f3feeba239.tar.bz2
gentoo-2-348bde686606817b808c98917de758f3feeba239.zip
Version bump #350062 by Panagiotis Christopoulos.
(Portage version: 2.2.0_alpha10/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/help2man')
-rw-r--r--sys-apps/help2man/ChangeLog8
-rw-r--r--sys-apps/help2man/files/help2man-1.38.4-linguas.patch53
-rw-r--r--sys-apps/help2man/help2man-1.38.4.ebuild41
3 files changed, 101 insertions, 1 deletions
diff --git a/sys-apps/help2man/ChangeLog b/sys-apps/help2man/ChangeLog
index d921bac040b0..31f6c8248305 100644
--- a/sys-apps/help2man/ChangeLog
+++ b/sys-apps/help2man/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/help2man
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/help2man/ChangeLog,v 1.49 2010/07/11 18:00:55 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/help2man/ChangeLog,v 1.50 2010/12/29 22:05:02 vapier Exp $
+
+*help2man-1.38.4 (29 Dec 2010)
+
+ 29 Dec 2010; Mike Frysinger <vapier@gentoo.org> +help2man-1.38.4.ebuild,
+ +files/help2man-1.38.4-linguas.patch:
+ Version bump #350062 by Panagiotis Christopoulos.
11 Jul 2010; Raúl Porcel <armin76@gentoo.org> help2man-1.37.1.ebuild:
alpha/arm/ia64/m68k/s390/sh/sparc stable wrt #325089
diff --git a/sys-apps/help2man/files/help2man-1.38.4-linguas.patch b/sys-apps/help2man/files/help2man-1.38.4-linguas.patch
new file mode 100644
index 000000000000..080166c5060c
--- /dev/null
+++ b/sys-apps/help2man/files/help2man-1.38.4-linguas.patch
@@ -0,0 +1,53 @@
+respect user LINGUAS
+
++++ b/Makefile.in
+@@ -16,7 +16,12 @@
+ export VPATH = .:$(srcdir)
+
+ DESTDIR =
+-LINGUAS = $(basename $(notdir $(wildcard $(srcdir)/po/*.po)))
++ALL_LINGUAS = $(basename $(notdir $(wildcard $(srcdir)/po/*.po)))
++ifeq ($(LINGUAS),)
++INSTALL_LINGUAS = $(ALL_LINGUAS)
++else
++INSTALL_LINGUAS = $(filter $(LINGUAS),$(ALL_LINGUAS))
++endif
+
+ CC = @CC@
+ PERL = @PERL@
+@@ -56,7 +62,7 @@
+ $(INSTALL_PROGRAM) $(preload).so $(DESTDIR)$(pkglibdir)
+
+ install_l10n: install_dirs msg_l10n man_l10n
+- for lang in $(LINGUAS); \
++ for lang in $(INSTALL_LINGUAS); \
+ do \
+ $(MKINSTALLDIRS) $(DESTDIR)$(localedir)/$$lang/LC_MESSAGES; \
+ $(INSTALL_DATA) $(call vpath_file,po/$$lang.gmo) \
+@@ -124,7 +130,7 @@
+ $(MAKE) $(target).h2m
+ ./$(target) --include=$(target).h2m --output=$@ ./$(target)
+
+-msg_l10n: $(addprefix po/,$(addsuffix .gmo,$(LINGUAS)))
++msg_l10n: $(addprefix po/,$(addsuffix .gmo,$(ALL_LINGUAS)))
+ po/%.gmo: $(srcdir)/po/%.po
+ test -d po || mkdir po
+ $(MSGFMT) -o $@ $?
+@@ -134,7 +140,7 @@
+ $(MKINSTALLDIRS) localetmp/$$lang/LC_MESSAGES && \
+ $(INSTALL_DATA) po/$$lang.gmo localetmp/$$lang/LC_MESSAGES/$(target).mo
+
+-man_l10n: $(addprefix $(target).,$(addsuffix .1,$(LINGUAS)))
++man_l10n: $(addprefix $(target).,$(addsuffix .1,$(ALL_LINGUAS)))
+ $(target).%.1: $(srcdir)/$(target).PL $(srcdir)/$(target).h2m.PL \
+ $(srcdir)/po/%.po
+ lang=$(patsubst $(target).%.1,%,$@); \
+@@ -164,7 +170,7 @@
+ ./config.status
+
+ update-po: $(srcdir)/po/$(target).pot
+- for lang in $(LINGUAS); \
++ for lang in $(ALL_LINGUAS); \
+ do \
+ echo -n "Updating $$lang "; \
+ msgmerge -U $(srcdir)/po/$$lang.po $(srcdir)/po/$(target).pot; \
diff --git a/sys-apps/help2man/help2man-1.38.4.ebuild b/sys-apps/help2man/help2man-1.38.4.ebuild
new file mode 100644
index 000000000000..a2c5a5231b42
--- /dev/null
+++ b/sys-apps/help2man/help2man-1.38.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/help2man/help2man-1.38.4.ebuild,v 1.1 2010/12/29 22:05:02 vapier Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="GNU utility to convert program --help output to a man page"
+HOMEPAGE="http://www.gnu.org/software/help2man"
+SRC_URI="mirror://gnu/help2man/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="nls elibc_glibc"
+
+RDEPEND="dev-lang/perl"
+DEPEND="${RDEPEND}
+ elibc_glibc? ( nls? (
+ dev-perl/Locale-gettext
+ >=sys-devel/gettext-0.12.1-r1
+ ) )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.36.4-respect-LDFLAGS.patch
+ epatch "${FILESDIR}"/${PN}-1.38.4-linguas.patch
+}
+
+src_configure() {
+ local myconf
+ use elibc_glibc \
+ && myconf="${myconf} $(use_enable nls)" \
+ || myconf="${myconf} --disable-nls"
+ econf ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc ChangeLog NEWS README THANKS
+}