summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2013-01-19 15:03:26 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2013-01-19 15:03:26 +0000
commit9310a89ec2767feb39c3769e116cf3c8dc85914d (patch)
treea966dcb10c5bf459d3b9b02d7fbf8a68b725640e /sys-apps/hwids/hwids-20130119.ebuild
parentUpdate PDEPEND of virtual/udev to 197. (diff)
downloadgentoo-2-9310a89ec2767feb39c3769e116cf3c8dc85914d.tar.gz
gentoo-2-9310a89ec2767feb39c3769e116cf3c8dc85914d.tar.bz2
gentoo-2-9310a89ec2767feb39c3769e116cf3c8dc85914d.zip
Version bump.
(Portage version: 2.2.0_alpha154/cvs/Linux x86_64, signed Manifest commit with key 1CD13C8AD4301342)
Diffstat (limited to 'sys-apps/hwids/hwids-20130119.ebuild')
-rw-r--r--sys-apps/hwids/hwids-20130119.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sys-apps/hwids/hwids-20130119.ebuild b/sys-apps/hwids/hwids-20130119.ebuild
new file mode 100644
index 000000000000..721c1eb1285e
--- /dev/null
+++ b/sys-apps/hwids/hwids-20130119.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/hwids-20130119.ebuild,v 1.1 2013/01/19 15:03:26 flameeyes Exp $
+
+EAPI=5
+inherit udev eutils
+
+DESCRIPTION="Hardware (PCI, USB, OUI, IAB) IDs databases"
+HOMEPAGE="https://github.com/gentoo/hwids"
+SRC_URI="https://github.com/gentoo/hwids/archive/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 BSD ) public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~amd64-linux ~x86-linux"
+IUSE="+udev"
+
+DEPEND="udev? ( dev-lang/perl !=sys-fs/udev-196 )"
+RDEPEND="!<sys-apps/pciutils-3.1.9-r2
+ !<sys-apps/usbutils-005-r1"
+
+S=${WORKDIR}/hwids-${P}
+
+src_compile() {
+ emake UDEV=$(usex udev)
+}
+
+src_install() {
+ emake UDEV=$(usex udev) install \
+ DOCDIR="${EPREFIX}/usr/share/doc/${PF}" \
+ MISCDIR="${EPREFIX}/usr/share/misc" \
+ HWDBDIR="${EPREFIX}$(udev_get_udevdir)/hwdb.d" \
+ DESTDIR="${D}"
+}
+
+pkg_postinst() {
+ # until udev introduces a way to compile the database at a given
+ # location, rather than just /, we can't do much on offset root.
+ if [[ ${ROOT} != "" ]] && [[ ${ROOT} != "/" ]]; then
+ return 0
+ fi
+
+ if use udev && [[ $(udevadm --help 2>&1) == *hwdb* ]]; then
+ udevadm hwdb --update
+ fi
+}