summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-07-02 16:26:37 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-07-02 16:26:37 +0000
commit1a89cb030ebb611fafdd385ae4070296596eabb3 (patch)
tree1c85acc4cdc5902e4c42f83cc3d9178d771a7946 /sys-apps/hwloc
parentBump for #373509 (diff)
downloadgentoo-2-1a89cb030ebb611fafdd385ae4070296596eabb3.tar.gz
gentoo-2-1a89cb030ebb611fafdd385ae4070296596eabb3.tar.bz2
gentoo-2-1a89cb030ebb611fafdd385ae4070296596eabb3.zip
[sys-apps/hwloc] Enable prefix support for ~amd64-linux =D
(Portage version: 2.2.0_alpha43/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/hwloc')
-rw-r--r--sys-apps/hwloc/ChangeLog7
-rw-r--r--sys-apps/hwloc/hwloc-1.1.1-r1.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/sys-apps/hwloc/ChangeLog b/sys-apps/hwloc/ChangeLog
index e2b8cd4b3620..bedd32104966 100644
--- a/sys-apps/hwloc/ChangeLog
+++ b/sys-apps/hwloc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/hwloc
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwloc/ChangeLog,v 1.7 2011/01/26 19:43:12 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwloc/ChangeLog,v 1.8 2011/07/02 16:26:37 alexxy Exp $
+
+*hwloc-1.1.1-r1 (02 Jul 2011)
+
+ 02 Jul 2011; Alexey Shvetsov <alexxy@gentoo.org> +hwloc-1.1.1-r1.ebuild:
+ Enable prefix support for ~amd64-linux =D
*hwloc-1.1.1 (26 Jan 2011)
diff --git a/sys-apps/hwloc/hwloc-1.1.1-r1.ebuild b/sys-apps/hwloc/hwloc-1.1.1-r1.ebuild
new file mode 100644
index 000000000000..b4cce467f797
--- /dev/null
+++ b/sys-apps/hwloc/hwloc-1.1.1-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwloc/hwloc-1.1.1-r1.ebuild,v 1.1 2011/07/02 16:26:37 alexxy Exp $
+
+EAPI="4"
+
+DESCRIPTION="displays the hardware topology in convenient formats"
+HOMEPAGE="http://www.open-mpi.org/projects/hwloc/"
+SRC_URI="http://www.open-mpi.org/software/hwloc/v1.1/downloads/${P}.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux"
+IUSE="cairo svg static-libs xml X"
+SLOT="0"
+LICENSE="BSD"
+
+RDEPEND="sys-libs/ncurses
+ cairo? ( x11-libs/cairo[X?,svg?] )
+ xml? ( dev-libs/libxml2 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${P}" \
+ $(use_enable cairo) \
+ $(use_enable static-libs static) \
+ $(use_enable xml) \
+ $(use_with X x) \
+ --disable-silent-rules
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS NEWS README VERSION || die
+}
+
+src_test() {
+ # autotools-utils broke tests, the first of which being
+ # PASS: 256ppc-8n8s4t-nosys.output
+ emake check || die
+}