summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2012-03-05 17:49:19 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2012-03-05 17:49:19 +0000
commita01ce6c2a5085019e4650610e90c2e12ca52cb3f (patch)
tree2bf6f6f187b292d084ef9f339bf386566da68ae6 /sys-apps/hwloc
parentVersion bump. Add patches to fix handling of library writability and package ... (diff)
downloadgentoo-2-a01ce6c2a5085019e4650610e90c2e12ca52cb3f.tar.gz
gentoo-2-a01ce6c2a5085019e4650610e90c2e12ca52cb3f.tar.bz2
gentoo-2-a01ce6c2a5085019e4650610e90c2e12ca52cb3f.zip
Version bump
(Portage version: 2.2.0_alpha89/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/hwloc')
-rw-r--r--sys-apps/hwloc/ChangeLog9
-rw-r--r--sys-apps/hwloc/hwloc-1.3.2.ebuild47
-rw-r--r--sys-apps/hwloc/hwloc-1.4.1.ebuild47
3 files changed, 102 insertions, 1 deletions
diff --git a/sys-apps/hwloc/ChangeLog b/sys-apps/hwloc/ChangeLog
index 05d3cc991311..de26a1cd8f1f 100644
--- a/sys-apps/hwloc/ChangeLog
+++ b/sys-apps/hwloc/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/hwloc
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwloc/ChangeLog,v 1.21 2012/02/10 09:11:07 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwloc/ChangeLog,v 1.22 2012/03/05 17:49:19 xarthisius Exp $
+
+*hwloc-1.3.2 (05 Mar 2012)
+*hwloc-1.4.1 (05 Mar 2012)
+
+ 05 Mar 2012; Kacper Kowalik <xarthisius@gentoo.org> +hwloc-1.3.2.ebuild,
+ +hwloc-1.4.1.ebuild:
+ Version bump
10 Feb 2012; Kacper Kowalik <xarthisius@gentoo.org> hwloc-1.4.ebuild:
Add actual use_enable for numa
diff --git a/sys-apps/hwloc/hwloc-1.3.2.ebuild b/sys-apps/hwloc/hwloc-1.3.2.ebuild
new file mode 100644
index 000000000000..ae8b431bf6d7
--- /dev/null
+++ b/sys-apps/hwloc/hwloc-1.3.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwloc/hwloc-1.3.2.ebuild,v 1.1 2012/03/05 17:49:19 xarthisius Exp $
+
+EAPI=4
+
+inherit multilib versionator
+
+MY_PV=v$(get_version_component_range 1-2)
+
+DESCRIPTION="displays the hardware topology in convenient formats"
+HOMEPAGE="http://www.open-mpi.org/projects/hwloc/"
+SRC_URI="http://www.open-mpi.org/software/${PN}/${MY_PV}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux"
+IUSE="cairo debug +numa +pci svg static-libs xml X"
+
+RDEPEND="sys-libs/ncurses
+ cairo? ( x11-libs/cairo[X?,svg?] )
+ pci? ( sys-apps/pciutils )
+ xml? ( dev-libs/libxml2 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ numa? ( sys-process/numactl )"
+
+DOCS=( AUTHORS NEWS README VERSION )
+
+src_configure() {
+ export HWLOC_PKG_CONFIG=$(tc-getPKG_CONFIG) #393467
+ econf \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ $(use_enable cairo) \
+ $(use_enable debug) \
+ $(use_enable pci) \
+ $(use_enable numa libnuma) \
+ $(use_enable static-libs static) \
+ $(use_enable xml libxml2) \
+ $(use_with X x) \
+ --disable-silent-rules
+}
+
+src_install() {
+ default
+ use static-libs || rm "${D}"/usr/$(get_libdir)/lib${PN}.la
+}
diff --git a/sys-apps/hwloc/hwloc-1.4.1.ebuild b/sys-apps/hwloc/hwloc-1.4.1.ebuild
new file mode 100644
index 000000000000..e662ddab59cc
--- /dev/null
+++ b/sys-apps/hwloc/hwloc-1.4.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwloc/hwloc-1.4.1.ebuild,v 1.1 2012/03/05 17:49:19 xarthisius Exp $
+
+EAPI=4
+
+inherit multilib versionator
+
+MY_PV=v$(get_version_component_range 1-2)
+
+DESCRIPTION="displays the hardware topology in convenient formats"
+HOMEPAGE="http://www.open-mpi.org/projects/hwloc/"
+SRC_URI="http://www.open-mpi.org/software/${PN}/${MY_PV}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux"
+IUSE="cairo debug +numa +pci svg static-libs xml X"
+
+RDEPEND="sys-libs/ncurses
+ cairo? ( x11-libs/cairo[X?,svg?] )
+ pci? ( sys-apps/pciutils )
+ xml? ( dev-libs/libxml2 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ numa? ( sys-process/numactl )"
+
+DOCS=( AUTHORS NEWS README VERSION )
+
+src_configure() {
+ export HWLOC_PKG_CONFIG=$(tc-getPKG_CONFIG) #393467
+ econf \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ $(use_enable cairo) \
+ $(use_enable debug) \
+ $(use_enable pci) \
+ $(use_enable numa libnuma) \
+ $(use_enable static-libs static) \
+ $(use_enable xml libxml2) \
+ $(use_with X x) \
+ --disable-silent-rules
+}
+
+src_install() {
+ default
+ use static-libs || rm "${D}"/usr/$(get_libdir)/lib${PN}.la
+}