summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-01-05 00:41:06 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-01-05 00:41:06 +0000
commite553a7ca790bba2c19d0d56c2798720abf243f43 (patch)
treea803626a74257bc772e0344bf3075461082a8632 /sys-apps/input-utils/input-utils-0.0.1_pre20051128-r1.ebuild
parentUnmask wxpython-2.8. (diff)
downloadgentoo-2-e553a7ca790bba2c19d0d56c2798720abf243f43.tar.gz
gentoo-2-e553a7ca790bba2c19d0d56c2798720abf243f43.tar.bz2
gentoo-2-e553a7ca790bba2c19d0d56c2798720abf243f43.zip
Minor bump for the newer debian patch. Cleans up manpage and uses system header instead of bundled header. Also clean up ebuilds to modern standards.
(Portage version: 2.1.4_rc11)
Diffstat (limited to 'sys-apps/input-utils/input-utils-0.0.1_pre20051128-r1.ebuild')
-rw-r--r--sys-apps/input-utils/input-utils-0.0.1_pre20051128-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sys-apps/input-utils/input-utils-0.0.1_pre20051128-r1.ebuild b/sys-apps/input-utils/input-utils-0.0.1_pre20051128-r1.ebuild
new file mode 100644
index 000000000000..da5e788bef44
--- /dev/null
+++ b/sys-apps/input-utils/input-utils-0.0.1_pre20051128-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/input-utils/input-utils-0.0.1_pre20051128-r1.ebuild,v 1.1 2008/01/05 00:41:06 robbat2 Exp $
+
+inherit eutils
+
+MY_P="input-${PV/0.0.1_pre/}-143821"
+DEBIAN_PR=4
+DEBIAN_P="${PN}_${PV/1_pre/}-${DEBIAN_PR}.diff.gz"
+
+DESCRIPTION="Small collection of linux input layer utils"
+HOMEPAGE="http://dl.bytesex.org/cvs-snapshots/"
+SRC_URI="http://dl.bytesex.org/cvs-snapshots/${MY_P}.tar.gz
+ mirror://debian/pool/main/i/input-utils/${DEBIAN_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/input"
+
+src_unpack() {
+ unpack ${MY_P}.tar.gz
+ EPATCH_OPTS="-d ${S} -p1 " epatch "${DISTDIR}"/${DEBIAN_P}
+ for p in $(<"${S}"/debian/patches/series) ; do
+ EPATCH_OPTS="-d ${S} -p1 " epatch "${S}"/debian/patches/${p}
+ done
+ sed -i -e '/INSTALL_BINARY/s,-s,,g' "${S}"/mk/Variables.mk \
+ || die "Failed to sed"
+}
+
+src_install() {
+ make install bindir="${D}"/usr/bin mandir="${D}"/usr/share/man || die "make install failed"
+ dodoc lircd.conf
+ dodoc README
+}