summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-02-07 15:55:15 +0000
committerAchim Gottinger <achim@gentoo.org>2001-02-07 15:55:15 +0000
commit36d7d63fc8e533a54bc3008fe078d25b06cc0d55 (patch)
treebbf6a3f305a5e307e2b8b191680365bd8b5a23b2 /sys-apps/ipchains
parent*** empty log message *** (diff)
downloadgentoo-2-36d7d63fc8e533a54bc3008fe078d25b06cc0d55.tar.gz
gentoo-2-36d7d63fc8e533a54bc3008fe078d25b06cc0d55.tar.bz2
gentoo-2-36d7d63fc8e533a54bc3008fe078d25b06cc0d55.zip
Maintainence and FHS 2.1 fixes for RC4
Diffstat (limited to 'sys-apps/ipchains')
-rw-r--r--sys-apps/ipchains/ipchains-1.3.10-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sys-apps/ipchains/ipchains-1.3.10-r1.ebuild b/sys-apps/ipchains/ipchains-1.3.10-r1.ebuild
new file mode 100644
index 000000000000..916a2313b31e
--- /dev/null
+++ b/sys-apps/ipchains/ipchains-1.3.10-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/ipchains/ipchains-1.3.10-r1.ebuild,v 1.1 2001/02/07 15:51:27 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="2.2 kernel equivalent of ipfwadm"
+SRC_URI="http://netfilter.kernelnotes.org/ipchains/${A}"
+HOMEPAGE="http://netfilter.filewatcher.org/ipchains/"
+
+DEPEND="virtual/glibc"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ mv Makefile Makefile.orig
+ sed -e "s/= -g -O/= ${CFLAGS}/" Makefile.orig > Makefile
+ cd ${S}/libipfwc
+ mv Makefile Makefile.orig
+ sed -e "s/= -g -O/= ${CFLAGS}/" Makefile.orig > Makefile
+}
+
+src_compile() {
+
+ try make clean
+ try make ${MAKEOPTS} all
+
+}
+
+src_install() {
+
+ into /
+ dosbin ipchains
+ doman ipfw.4 ipchains.8
+ dodoc COPYING README
+ docinto ps
+ dodoc ipchains-quickref.ps
+
+}
+
+