summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2015-05-19 12:46:33 +0000
committerTony Vroon <chainsaw@gentoo.org>2015-05-19 12:46:33 +0000
commit24079c4002426f149ea140ffaa00580b44ff5421 (patch)
tree44fe781c1addeeea0079d2bc47e50727048450a2 /sys-apps/irqbalance
parentversion bump (diff)
downloadgentoo-2-24079c4002426f149ea140ffaa00580b44ff5421.tar.gz
gentoo-2-24079c4002426f149ea140ffaa00580b44ff5421.tar.bz2
gentoo-2-24079c4002426f149ea140ffaa00580b44ff5421.zip
Version bump, as requested by "andcycle". Now parses isolcpus on the kernel command line automatically. Improved signal handling. Closes bug #547698.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0xB5058F9A)
Diffstat (limited to 'sys-apps/irqbalance')
-rw-r--r--sys-apps/irqbalance/ChangeLog10
-rw-r--r--sys-apps/irqbalance/irqbalance-1.0.9.ebuild49
2 files changed, 57 insertions, 2 deletions
diff --git a/sys-apps/irqbalance/ChangeLog b/sys-apps/irqbalance/ChangeLog
index e9a03d0de678..f0289c249a1b 100644
--- a/sys-apps/irqbalance/ChangeLog
+++ b/sys-apps/irqbalance/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/irqbalance
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/irqbalance/ChangeLog,v 1.61 2015/04/07 14:45:50 jlec Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/irqbalance/ChangeLog,v 1.62 2015/05/19 12:46:33 chainsaw Exp $
+
+*irqbalance-1.0.9 (19 May 2015)
+
+ 19 May 2015; Tony Vroon <chainsaw@gentoo.org> +irqbalance-1.0.9.ebuild:
+ Version bump, as requested by "andcycle". Now parses isolcpus on the kernel
+ command line automatically. Improved signal handling. Closes bug #547698.
*irqbalance-1.0.7-r1 (08 Nov 2014)
diff --git a/sys-apps/irqbalance/irqbalance-1.0.9.ebuild b/sys-apps/irqbalance/irqbalance-1.0.9.ebuild
new file mode 100644
index 000000000000..cb517735c06c
--- /dev/null
+++ b/sys-apps/irqbalance/irqbalance-1.0.9.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/irqbalance/irqbalance-1.0.9.ebuild,v 1.1 2015/05/19 12:46:33 chainsaw Exp $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils systemd linux-info
+
+DESCRIPTION="Distribute hardware interrupts across processors on a multiprocessor system"
+HOMEPAGE="https://github.com/Irqbalance/irqbalance"
+SRC_URI="https://github.com/Irqbalance/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="caps +numa selinux"
+
+CDEPEND="dev-libs/glib:2
+ caps? ( sys-libs/libcap-ng )
+ numa? ( sys-process/numactl )
+"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+"
+RDEPEND="${CDEPEND}
+ selinux? ( sec-policy/selinux-irqbalance )
+"
+
+pkg_setup() {
+ CONFIG_CHECK="~PCI_MSI"
+ linux-info_pkg_setup
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with caps libcap-ng)
+ $(use_enable numa)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ newinitd "${FILESDIR}"/irqbalance.init.3 irqbalance
+ newconfd "${FILESDIR}"/irqbalance.confd-1 irqbalance
+ systemd_dounit "${FILESDIR}"/irqbalance.service
+}