summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2014-04-23 16:51:22 +0000
committerLars Wendler <polynomial-c@gentoo.org>2014-04-23 16:51:22 +0000
commit6aa32808b69b9c7aa77e6702c004f9e17cc74989 (patch)
tree4687b8a47302652f991043ff29cdf3ebb58b587b /sys-apps/kbd
parentMarked ~hppa (bug #508528). (diff)
downloadgentoo-2-6aa32808b69b9c7aa77e6702c004f9e17cc74989.tar.gz
gentoo-2-6aa32808b69b9c7aa77e6702c004f9e17cc74989.tar.bz2
gentoo-2-6aa32808b69b9c7aa77e6702c004f9e17cc74989.zip
Fixed loadkeys not working on big_endian machines (bug #508436). Added live ebuild. Removed old
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'sys-apps/kbd')
-rw-r--r--sys-apps/kbd/ChangeLog10
-rw-r--r--sys-apps/kbd/kbd-1.15.3.ebuild46
-rw-r--r--sys-apps/kbd/kbd-2.0.1-r1.ebuild64
-rw-r--r--sys-apps/kbd/kbd-9999.ebuild62
4 files changed, 135 insertions, 47 deletions
diff --git a/sys-apps/kbd/ChangeLog b/sys-apps/kbd/ChangeLog
index 0d38a79a0ada..e4f19361cb52 100644
--- a/sys-apps/kbd/ChangeLog
+++ b/sys-apps/kbd/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-apps/kbd
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/kbd/ChangeLog,v 1.127 2014/01/26 12:19:59 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/kbd/ChangeLog,v 1.128 2014/04/23 16:51:22 polynomial-c Exp $
+
+*kbd-9999 (23 Apr 2014)
+*kbd-2.0.1-r1 (23 Apr 2014)
+
+ 23 Apr 2014; Lars Wendler <polynomial-c@gentoo.org> -kbd-1.15.3.ebuild,
+ +kbd-2.0.1-r1.ebuild, +kbd-9999.ebuild:
+ Fixed loadkeys not working on big_endian machines (bug #508436). Added live
+ ebuild. Removed old.
26 Jan 2014; Agostino Sarubbo <ago@gentoo.org> kbd-1.15.5-r1.ebuild:
Stable for sparc, wrt bug #496434
diff --git a/sys-apps/kbd/kbd-1.15.3.ebuild b/sys-apps/kbd/kbd-1.15.3.ebuild
deleted file mode 100644
index fe0a1d914401..000000000000
--- a/sys-apps/kbd/kbd-1.15.3.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/kbd/kbd-1.15.3.ebuild,v 1.7 2011/10/11 16:44:58 jer Exp $
-
-DESCRIPTION="Keyboard and console utilities"
-HOMEPAGE="http://freshmeat.net/projects/kbd/"
-SRC_URI="ftp://ftp.altlinux.org/pub/people/legion/kbd/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
-IUSE="nls"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # broken file ... upstream git punted it
- rm po/es.po
-
- # Rename conflicting keymaps to have unique names, bug #293228
- cd "${S}"/data/keymaps/i386
- mv dvorak/no.map dvorak/no-dvorak.map
- mv fgGIod/trf.map fgGIod/trf-fgGIod.map
- mv olpc/es.map olpc/es-olpc.map
- mv olpc/pt.map olpc/pt-olpc.map
- mv qwerty/cz.map qwerty/cz-qwerty.map
-
- # bundled timestamps are broken
- find "${S}" -type f -exec touch -r "${S}"/configure {} +
-}
-
-src_compile() {
- econf $(use_enable nls) || die
- emake || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc AUTHORS ChangeLog INSTALL NEWS README
- dohtml doc/*.html
-}
diff --git a/sys-apps/kbd/kbd-2.0.1-r1.ebuild b/sys-apps/kbd/kbd-2.0.1-r1.ebuild
new file mode 100644
index 000000000000..7fd61d4d5b85
--- /dev/null
+++ b/sys-apps/kbd/kbd-2.0.1-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/kbd/kbd-2.0.1-r1.ebuild,v 1.1 2014/04/23 16:51:22 polynomial-c Exp $
+
+EAPI=5
+
+SCM=""
+if [[ ${PV} == "9999" ]] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="http://git.kernel.org/cgit/linux/kernel/git/legion/${PN}.git"
+ EGIT_BRANCH="master"
+else
+ SRC_URI="ftp://ftp.kernel.org/pub/linux/utils/kbd/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+inherit autotools eutils ${SCM}
+
+DESCRIPTION="Keyboard and console utilities"
+HOMEPAGE="http://kbd-project.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="nls pam test"
+
+RDEPEND="pam? ( virtual/pam )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( dev-libs/check )"
+
+src_unpack() {
+ if [[ ${PV} == "9999" ]] ; then
+ git-r3_src_unpack
+ else
+ default
+ fi
+
+ # Rename conflicting keymaps to have unique names, bug #293228
+ cd "${S}"/data/keymaps/i386 || die
+ mv dvorak/no.map dvorak/no-dvorak.map || die
+ mv fgGIod/trf.map fgGIod/trf-fgGIod.map || die
+ mv olpc/es.map olpc/es-olpc.map || die
+ mv olpc/pt.map olpc/pt-olpc.map || die
+ mv qwerty/cz.map qwerty/cz-qwerty.map || die
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.0.0-tests.patch
+ epatch "${FILESDIR}"/${P}-stdarg.patch #497200
+ epatch "${FILESDIR}"/${P}-big_endian.patch #508436
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable pam vlock) \
+ $(use_enable test tests)
+}
+
+src_install() {
+ default
+ dohtml docs/doc/*.html
+}
diff --git a/sys-apps/kbd/kbd-9999.ebuild b/sys-apps/kbd/kbd-9999.ebuild
new file mode 100644
index 000000000000..fcba36ff30e7
--- /dev/null
+++ b/sys-apps/kbd/kbd-9999.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/kbd/kbd-9999.ebuild,v 1.1 2014/04/23 16:51:22 polynomial-c Exp $
+
+EAPI=5
+
+SCM=""
+if [[ ${PV} == "9999" ]] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="http://git.kernel.org/cgit/linux/kernel/git/legion/kbd.git"
+ EGIT_BRANCH="master"
+else
+ SRC_URI="ftp://ftp.kernel.org/pub/linux/utils/kbd/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+inherit autotools eutils ${SCM}
+
+DESCRIPTION="Keyboard and console utilities"
+HOMEPAGE="http://kbd-project.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="nls pam test"
+
+RDEPEND="pam? ( virtual/pam )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( dev-libs/check )"
+
+src_unpack() {
+ if [[ ${PV} == "9999" ]] ; then
+ git-r3_src_unpack
+ else
+ default
+ fi
+
+ # Rename conflicting keymaps to have unique names, bug #293228
+ cd "${S}"/data/keymaps/i386 || die
+ mv dvorak/no.map dvorak/no-dvorak.map || die
+ mv fgGIod/trf.map fgGIod/trf-fgGIod.map || die
+ mv olpc/es.map olpc/es-olpc.map || die
+ mv olpc/pt.map olpc/pt-olpc.map || die
+ mv qwerty/cz.map qwerty/cz-qwerty.map || die
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.0.0-tests.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable pam vlock) \
+ $(use_enable test tests)
+}
+
+src_install() {
+ default
+ dohtml docs/doc/*.html
+}