summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-03-16 03:32:21 +0000
committerMike Frysinger <vapier@gentoo.org>2006-03-16 03:32:21 +0000
commita2dbb97ebe13166fa952f53256bd945f4a81a142 (patch)
tree1bb69640f502046932515f024c7c7903b427cb35 /sys-apps/kbd
parentold (diff)
downloadgentoo-2-a2dbb97ebe13166fa952f53256bd945f4a81a142.tar.gz
gentoo-2-a2dbb97ebe13166fa952f53256bd945f4a81a142.tar.bz2
gentoo-2-a2dbb97ebe13166fa952f53256bd945f4a81a142.zip
Drop the italian euro keymap patch #75970.
(Portage version: 2.1_pre6-r3)
Diffstat (limited to 'sys-apps/kbd')
-rw-r--r--sys-apps/kbd/ChangeLog7
-rw-r--r--sys-apps/kbd/files/digest-kbd-1.12-r62
-rw-r--r--sys-apps/kbd/kbd-1.12-r6.ebuild102
3 files changed, 110 insertions, 1 deletions
diff --git a/sys-apps/kbd/ChangeLog b/sys-apps/kbd/ChangeLog
index 030bb78e074c..44496da352db 100644
--- a/sys-apps/kbd/ChangeLog
+++ b/sys-apps/kbd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/kbd
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/kbd/ChangeLog,v 1.42 2006/02/08 15:23:28 kanaka Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/kbd/ChangeLog,v 1.43 2006/03/16 03:32:21 vapier Exp $
+
+*kbd-1.12-r6 (16 Mar 2006)
+
+ 16 Mar 2006; Mike Frysinger <vapier@gentoo.org> +kbd-1.12-r6.ebuild:
+ Drop the italian euro keymap patch #75970.
08 Feb 2006; Joel Martin <kanaka@gentoo.org> kbd-1.12-r5.ebuild:
Don't run test programs when cross-compiling. Export CC for cross-compiling.
diff --git a/sys-apps/kbd/files/digest-kbd-1.12-r6 b/sys-apps/kbd/files/digest-kbd-1.12-r6
new file mode 100644
index 000000000000..97dbb48e0136
--- /dev/null
+++ b/sys-apps/kbd/files/digest-kbd-1.12-r6
@@ -0,0 +1,2 @@
+MD5 7892c7010512a9bc6697a295c921da25 kbd-1.12.tar.gz 884827
+MD5 c3bc810b784880c9bb5a6fe80d95a696 svorakln.tar.gz 3030
diff --git a/sys-apps/kbd/kbd-1.12-r6.ebuild b/sys-apps/kbd/kbd-1.12-r6.ebuild
new file mode 100644
index 000000000000..116dce1e6e2c
--- /dev/null
+++ b/sys-apps/kbd/kbd-1.12-r6.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/kbd/kbd-1.12-r6.ebuild,v 1.1 2006/03/16 03:32:21 vapier Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Keyboard and console utilities"
+HOMEPAGE="http://freshmeat.net/projects/kbd/"
+SRC_URI="ftp://ftp.cwi.nl/pub/aeb/kbd/${P}.tar.gz
+ ftp://ftp.win.tue.nl/pub/home/aeb/linux-local/utils/kbd/${P}.tar.gz
+ nls? ( http://www.users.one.se/liket/svorak/svorakln.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86"
+IUSE="nls"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ local a
+ # Workaround problem on JFS filesystems, see bug 42859
+ for a in ${A} ; do
+ echo ">>> Unpacking ${a} to ${WORKDIR}"
+ gzip -dc "${DISTDIR}"/${a} | tar xf -
+ assert
+ done
+
+ cd "${S}"
+ sed -i \
+ -e "/^CFLAGS/ s:-O2:${CFLAGS}:g" \
+ -e "/^LDFLAGS/ s:-s:${LDFLAGS}:" \
+ -e "s:install -s:install:" \
+ src/Makefile.in \
+ openvt/Makefile
+
+ if tc-is-cross-compiler; then
+ tc-export CC
+ # Cross-compiling: don't run test programs
+ sed -i -e "s:&& ./conftest::" configure || \
+ die "Could not do sed configure for cross-compile"
+ fi
+
+ # Other patches from RH
+ epatch "${FILESDIR}"/${PN}-1.08-terminal.patch
+
+ # Fixes a problem where loadkeys matches dvorak the dir, and not the
+ # .map inside
+ epatch "${FILESDIR}"/${P}-find-map-fix.patch
+
+ # Sparc have not yet fixed struct kbd_rate to use 'period' and not 'rate'
+ epatch "${FILESDIR}"/${P}-kbd_repeat-v2.patch
+
+ # misc fixes from debian
+ epatch "${FILESDIR}"/${P}-debian.patch
+
+ # Provide a QWERTZ and QWERTY cz map #19010
+ cp data/keymaps/i386/{qwerty,qwertz}/cz.map || die "cz qwerty"
+ epatch "${FILESDIR}"/${P}-cz-qwerty-map.patch
+
+ # Fix jp map to recognize Ctrl-[ as Escape #71870
+ epatch "${FILESDIR}"/${P}-jp-escape.patch
+
+ # Patches from Fedora
+ epatch "${FILESDIR}"/${P}-Meta_utf8.patch
+ ## Fix runtime with gcc4 (setfont: Input file: trailing garbage)
+ epatch "${FILESDIR}"/${P}-alias.patch
+ epatch "${FILESDIR}"/${P}-setfont-man.patch
+}
+
+src_compile() {
+ local myconf=
+ # Non-standard configure script; --disable-nls to
+ # disable NLS, nothing to enable it.
+ use nls || myconf="--disable-nls"
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --datadir=/usr/share \
+ ${myconf} || die
+
+ emake CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ mv "${D}"/usr/bin/setfont "${D}"/bin/
+ dosym /bin/setfont /usr/bin/setfont
+
+ dodoc CHANGES CREDITS README
+ dodir /usr/share/doc/${PF}/html
+ cp -dR doc/* "${D}"/usr/share/doc/${PF}/html/
+
+ if use nls ; then
+ cd ${WORKDIR}/mnt/e/SvorakLN
+ insinto /usr/share/keymaps/i386/dvorak/
+ doins .svorakmap svorak.map.gz
+ dodoc Svorak.txt
+ fi
+}