summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-06-07 02:48:07 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-06-07 02:48:07 +0000
commitee3b5105c8e68fff8bcbafd3a70517e73f533443 (patch)
tree3e8dd6728dcac6457f991a2fc72d271ff521569e /sys-apps/keyutils/keyutils-1.2-r1.ebuild
parentVersion bump per bug #203457. (diff)
downloadgentoo-2-ee3b5105c8e68fff8bcbafd3a70517e73f533443.tar.gz
gentoo-2-ee3b5105c8e68fff8bcbafd3a70517e73f533443.tar.bz2
gentoo-2-ee3b5105c8e68fff8bcbafd3a70517e73f533443.zip
Resolve bug #198352 where the binaries were built before the new lib sometimes, leading to bad linking.
(Portage version: 2.1.5.4)
Diffstat (limited to 'sys-apps/keyutils/keyutils-1.2-r1.ebuild')
-rw-r--r--sys-apps/keyutils/keyutils-1.2-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-apps/keyutils/keyutils-1.2-r1.ebuild b/sys-apps/keyutils/keyutils-1.2-r1.ebuild
new file mode 100644
index 000000000000..536a751bee46
--- /dev/null
+++ b/sys-apps/keyutils/keyutils-1.2-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/keyutils/keyutils-1.2-r1.ebuild,v 1.1 2008/06/07 02:48:07 robbat2 Exp $
+
+inherit multilib eutils
+
+DESCRIPTION="Linux Key Management Utilities"
+HOMEPAGE="http://www.kernel.org/"
+SRC_URI="http://people.redhat.com/~dhowells/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=sys-kernel/linux-headers-2.6.11"
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}"/${PN}-1.2-makefile-fixup.patch
+ cd "${S}"
+ sed -i \
+ -e '/CFLAGS/s|:= -g -O2|+=|' \
+ Makefile || die
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ LIBDIR="/$(get_libdir)" \
+ USRLIBDIR="/usr/$(get_libdir)" \
+ install || die
+ dodoc README
+}