summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2014-01-04 23:30:45 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2014-01-04 23:30:45 +0000
commitb42cb57cc1fc7b7a914be086d3657235e794cb9d (patch)
tree5b631e7a22b548af6b51e755a43440de1e6cc1d4 /sys-apps/keyutils
parentUnmask dev-vcs/git mediawiki support on amd64 while other arches are still ke... (diff)
downloadgentoo-2-b42cb57cc1fc7b7a914be086d3657235e794cb9d.tar.gz
gentoo-2-b42cb57cc1fc7b7a914be086d3657235e794cb9d.tar.bz2
gentoo-2-b42cb57cc1fc7b7a914be086d3657235e794cb9d.zip
Version bump, also fix bug #484452 (AR) and bug #421531 (checking kernel config).
(Portage version: 2.2.7/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'sys-apps/keyutils')
-rw-r--r--sys-apps/keyutils/ChangeLog12
-rw-r--r--sys-apps/keyutils/keyutils-1.5.5.ebuild17
-rw-r--r--sys-apps/keyutils/keyutils-1.5.8.ebuild69
3 files changed, 91 insertions, 7 deletions
diff --git a/sys-apps/keyutils/ChangeLog b/sys-apps/keyutils/ChangeLog
index 17265066ff1d..205d6c396668 100644
--- a/sys-apps/keyutils/ChangeLog
+++ b/sys-apps/keyutils/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/keyutils
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/keyutils/ChangeLog,v 1.35 2012/07/01 18:21:34 armin76 Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/keyutils/ChangeLog,v 1.36 2014/01/04 23:30:45 robbat2 Exp $
+
+*keyutils-1.5.8 (04 Jan 2014)
+
+ 04 Jan 2014; Robin H. Johnson <robbat2@gentoo.org> +keyutils-1.5.8.ebuild,
+ keyutils-1.5.5.ebuild:
+ Version bump, also fix bug #484452 (AR) and bug #421531 (checking kernel
+ config).
01 Jul 2012; Raúl Porcel <armin76@gentoo.org> keyutils-1.5.5.ebuild:
alpha/ia64/m68k/s390/sh/sparc stable wrt #417445
@@ -134,4 +141,3 @@
15 Dec 2005; Robin H. Johnson <robbat2@gentoo.org> +metadata.xml,
+keyutils-1.0.ebuild:
Initial commit. Ebuild by Robin H. Johnson <robbat2@gentoo.org>.
-
diff --git a/sys-apps/keyutils/keyutils-1.5.5.ebuild b/sys-apps/keyutils/keyutils-1.5.5.ebuild
index ed02fffd0e58..00469b2c3682 100644
--- a/sys-apps/keyutils/keyutils-1.5.5.ebuild
+++ b/sys-apps/keyutils/keyutils-1.5.5.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/keyutils/keyutils-1.5.5.ebuild,v 1.9 2012/07/01 18:21:34 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/keyutils/keyutils-1.5.5.ebuild,v 1.10 2014/01/04 23:30:45 robbat2 Exp $
EAPI="3"
-inherit multilib eutils toolchain-funcs
+inherit multilib eutils toolchain-funcs linux-info
DESCRIPTION="Linux Key Management Utilities"
HOMEPAGE="http://people.redhat.com/dhowells/keyutils/"
@@ -13,10 +13,18 @@ SRC_URI="http://people.redhat.com/dhowells/${PN}/${P}.tar.bz2"
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux"
-IUSE=""
+IUSE="test"
DEPEND="!prefix? ( >=sys-kernel/linux-headers-2.6.11 )"
+pkg_setup() {
+ CONFIG_CHECK="~KEYS"
+ use test && CONFIG_CHECK="${CONFIG_CHECK} ~KEYS_DEBUG_PROC_KEYS"
+ ERROR_KEYS="You must have CONFIG_KEYS to use this package!"
+ ERROR_KEYS_DEBUG_PROC_KEYS="You must have CONFIG_KEYS_DEBUG_PROC_KEYS to run the package testsuite!"
+ linux-info_pkg_setup
+}
+
src_prepare() {
epatch "${FILESDIR}"/${PN}-1.5.5-makefile-fixup.patch
sed -i \
@@ -43,6 +51,7 @@ src_prepare() {
src_configure() {
tc-export CC
+ tc-export AR
}
src_test() {
diff --git a/sys-apps/keyutils/keyutils-1.5.8.ebuild b/sys-apps/keyutils/keyutils-1.5.8.ebuild
new file mode 100644
index 000000000000..f77908eaf6b4
--- /dev/null
+++ b/sys-apps/keyutils/keyutils-1.5.8.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/keyutils/keyutils-1.5.8.ebuild,v 1.1 2014/01/04 23:30:45 robbat2 Exp $
+
+EAPI="5"
+
+inherit multilib eutils toolchain-funcs linux-info
+
+DESCRIPTION="Linux Key Management Utilities"
+HOMEPAGE="http://people.redhat.com/dhowells/keyutils/"
+SRC_URI="http://people.redhat.com/dhowells/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux"
+IUSE="test"
+
+DEPEND="!prefix? ( >=sys-kernel/linux-headers-2.6.11 )"
+
+pkg_setup() {
+ CONFIG_CHECK="~KEYS"
+ use test && CONFIG_CHECK="${CONFIG_CHECK} ~KEYS_DEBUG_PROC_KEYS"
+ ERROR_KEYS="You must have CONFIG_KEYS to use this package!"
+ ERROR_KEYS_DEBUG_PROC_KEYS="You must have CONFIG_KEYS_DEBUG_PROC_KEYS to run the package testsuite!"
+ linux-info_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.5.5-makefile-fixup.patch
+ sed -i \
+ -e '1iRPATH=' \
+ -e '/^C.*FLAGS/s|:=|+=|' \
+ -e 's:-Werror::' \
+ -e '/^BUILDFOR/s:=.*:=:' \
+ -e "/^LIBDIR/s:=.*:=/usr/$(get_libdir):" \
+ -e '/^USRLIBDIR/s:=.*:=$(LIBDIR):' \
+ Makefile || die
+
+ # The lsb check is useless, so avoid spurious command not found messages.
+ sed -i -e 's,lsb_release,:,' tests/prepare.inc.sh || die
+ # All the test files are bash, but try to execute via `sh`.
+ sed -i -r \
+ -e 's:([[:space:]])sh([[:space:]]):\1bash\2:' \
+ tests/{Makefile*,*.sh} || die
+ find tests/ -name '*.sh' -exec sed -i '1s:/sh$:/bash:' {} +
+ # Some tests call the kernel which calls userspace, but that will
+ # run the install keyutils rather than the locally compiled one,
+ # so disable round trip tests.
+ rm -rf tests/keyctl/requesting/{bad-args,piped,valid}
+}
+
+src_configure() {
+ tc-export CC
+ tc-export AR
+}
+
+src_test() {
+ # Execute the locally compiled code rather than the
+ # older versions already installed in the system.
+ LD_LIBRARY_PATH=${S} \
+ PATH="${S}:${PATH}" \
+ emake test || die
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install || die
+ dodoc README
+ gen_usr_ldscript -a keyutils
+}