summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2012-06-19 23:52:51 +0000
committerWilliam Hubbs <williamh@gentoo.org>2012-06-19 23:52:51 +0000
commitb61562e636e643bf3252dc8932898d3121aa5f57 (patch)
tree0998df07e0b82fede33cf53ca245092c94c809a4 /sys-apps/kmod
parentVersion bump. libf2c only needed at run time. (diff)
downloadgentoo-2-b61562e636e643bf3252dc8932898d3121aa5f57.tar.gz
gentoo-2-b61562e636e643bf3252dc8932898d3121aa5f57.tar.bz2
gentoo-2-b61562e636e643bf3252dc8932898d3121aa5f57.zip
version bump
(Portage version: 2.2.0_alpha110/cvs/Linux i686)
Diffstat (limited to 'sys-apps/kmod')
-rw-r--r--sys-apps/kmod/ChangeLog7
-rw-r--r--sys-apps/kmod/kmod-9.ebuild86
2 files changed, 92 insertions, 1 deletions
diff --git a/sys-apps/kmod/ChangeLog b/sys-apps/kmod/ChangeLog
index a441cd5e219c..7ca95e3fe83a 100644
--- a/sys-apps/kmod/ChangeLog
+++ b/sys-apps/kmod/ChangeLog
@@ -1,5 +1,10 @@
# ChangeLog for sys-apps/kmod# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/kmod/ChangeLog,v 1.39 2012/06/13 15:46:09 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/kmod/ChangeLog,v 1.40 2012/06/19 23:52:51 williamh Exp $
+
+*kmod-9 (19 Jun 2012)
+
+ 19 Jun 2012; William Hubbs <williamh@gentoo.org> +kmod-9.ebuild:
+ version bump
13 Jun 2012; Mike Frysinger <vapier@gentoo.org>
+files/kmod-8-gc-sections.patch, kmod-8.ebuild:
diff --git a/sys-apps/kmod/kmod-9.ebuild b/sys-apps/kmod/kmod-9.ebuild
new file mode 100644
index 000000000000..d502d1c60006
--- /dev/null
+++ b/sys-apps/kmod/kmod-9.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/kmod/kmod-9.ebuild,v 1.1 2012/06/19 23:52:51 williamh Exp $
+
+EAPI=4
+
+EGIT_REPO_URI="git://git.kernel.org/pub/scm/utils/kernel/${PN}/${PN}.git"
+
+[[ ${PV} == 9999 ]] && vcs=git-2
+inherit ${vcs} autotools eutils toolchain-funcs libtool
+unset vcs
+
+if [[ ${PV} != 9999 ]] ; then
+ SRC_URI="mirror://kernel/linux/utils/kernel/kmod/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~x86"
+fi
+
+DESCRIPTION="library and tools for managing linux kernel modules"
+HOMEPAGE="http://git.kernel.org/?p=utils/kernel/kmod/kmod.git"
+
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="debug doc lzma static-libs +tools zlib"
+
+RDEPEND="!sys-apps/module-init-tools
+ !sys-apps/modutils
+ lzma? ( app-arch/xz-utils )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ doc? ( dev-util/gtk-doc )
+ lzma? ( virtual/pkgconfig )
+ zlib? ( virtual/pkgconfig )"
+
+# Upstream does not support running the test suite with custom configure flags.
+# I was also told that the test suite is intended for kmod developers.
+# So we have to restrict it.
+# See bug #408915.
+RESTRICT="test"
+
+src_prepare()
+{
+ if [ ! -e configure ]; then
+ if use doc; then
+ gtkdocize --copy --docdir libkmod/docs || die
+ else
+ touch libkmod/docs/gtk-doc.make
+ fi
+ eautoreconf
+ else
+ elibtoolize
+ fi
+}
+
+src_configure()
+{
+ # http://bugs.gentoo.org/410865
+ if has_version '<sys-libs/zlib-1.2.6'; then
+ export zlib_CFLAGS="-I/usr/include"
+ export zlib_LIBS="-lz"
+ fi
+
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable tools) \
+ $(use_enable debug) \
+ $(use_enable doc gtk-doc) \
+ $(use_with lzma xz) \
+ $(use_with zlib)
+}
+
+src_install()
+{
+ default
+
+ find "${D}" -name libkmod.la -exec rm -f {} +
+
+ if use tools; then
+ dodir /bin
+ dosym /usr/bin/kmod /bin/lsmod
+ dodir /sbin
+ local cmd
+ for cmd in depmod insmod modinfo modprobe rmmod; do
+ dosym /usr/bin/kmod /sbin/${cmd}
+ done
+ fi
+}