summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2009-10-13 13:55:43 +0000
committerTony Vroon <chainsaw@gentoo.org>2009-10-13 13:55:43 +0000
commit470082c8d86eb97f7b2e828fb37b1dae2922a5de (patch)
tree215a89d4bea66e67bc4cb76ca8a98d6a6377628a /sys-apps/lcdtest
parentFix quoting (diff)
downloadgentoo-2-470082c8d86eb97f7b2e828fb37b1dae2922a5de.tar.gz
gentoo-2-470082c8d86eb97f7b2e828fb37b1dae2922a5de.tar.bz2
gentoo-2-470082c8d86eb97f7b2e828fb37b1dae2922a5de.zip
The die command was omitted on some tests. Correct this oversight.
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/lcdtest')
-rw-r--r--sys-apps/lcdtest/ChangeLog7
-rw-r--r--sys-apps/lcdtest/lcdtest-1.08-r1.ebuild8
2 files changed, 9 insertions, 6 deletions
diff --git a/sys-apps/lcdtest/ChangeLog b/sys-apps/lcdtest/ChangeLog
index 7ba3bf01decb..969dac2bfd9e 100644
--- a/sys-apps/lcdtest/ChangeLog
+++ b/sys-apps/lcdtest/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-apps/lcdtest
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/lcdtest/ChangeLog,v 1.14 2008/04/22 13:05:46 chainsaw Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lcdtest/ChangeLog,v 1.15 2009/10/13 13:55:43 chainsaw Exp $
+
+ 13 Oct 2009; <chainsaw@gentoo.org> lcdtest-1.08-r1.ebuild:
+ The die command was omitted on some tests. Correct this oversight.
22 Apr 2008; <chainsaw@gentoo.org> -lcdtest-1.01.ebuild,
-lcdtest-1.02.ebuild, -lcdtest-1.03.ebuild, -lcdtest-1.04.ebuild:
diff --git a/sys-apps/lcdtest/lcdtest-1.08-r1.ebuild b/sys-apps/lcdtest/lcdtest-1.08-r1.ebuild
index cbfabbe074f2..6bb0354b1bb6 100644
--- a/sys-apps/lcdtest/lcdtest-1.08-r1.ebuild
+++ b/sys-apps/lcdtest/lcdtest-1.08-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/lcdtest/lcdtest-1.08-r1.ebuild,v 1.6 2008/04/22 13:05:46 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lcdtest/lcdtest-1.08-r1.ebuild,v 1.7 2009/10/13 13:55:43 chainsaw Exp $
inherit eutils toolchain-funcs
@@ -31,9 +31,9 @@ src_compile() {
"${CC}" -o SFont.o -c ${CFLAGS} -DRELEASE=${PV} SFont.c || die SFont compilation failed
eend $?
einfo "Generating font"
- pngtopnm 14P_Arial_Plain_Red.png > help_font.ppm || pngtopnm failed
+ pngtopnm 14P_Arial_Plain_Red.png > help_font.ppm || die pngtopnm failed
ppmtoxpm -name `basename help_font.ppm .ppm`_xpm help_font.ppm |
- sed 's/static //;s/black/#000000/;s/magenta/#FF00FF/;s/#E40808/#009900/' > help_font.c || ppmtoxpm failed
+ sed 's/static //;s/black/#000000/;s/magenta/#FF00FF/;s/#E40808/#009900/' > help_font.c || die ppmtoxpm failed
ebegin "Running final stage compilation"
"${CC}" -o help_font.o -c ${CFLAGS} -DRELEASE=${PV} help_font.c || die help_font compilation failed
"${CC}" -o lcdtest lcdtest.o SFont.o help_font.o -lSDL -lSDL_image || die final link failed