summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaik Schreiber <blizzy@gentoo.org>2002-08-04 00:24:45 +0000
committerMaik Schreiber <blizzy@gentoo.org>2002-08-04 00:24:45 +0000
commit72ddad5750c5e6dacb511f1fe968c6d24693d3a6 (patch)
treee69fab60d151feda08bc82c2dbc869b498f6c513 /sys-apps/lm_sensors
parentAdd patch. (diff)
downloadgentoo-2-72ddad5750c5e6dacb511f1fe968c6d24693d3a6.tar.gz
gentoo-2-72ddad5750c5e6dacb511f1fe968c6d24693d3a6.tar.bz2
gentoo-2-72ddad5750c5e6dacb511f1fe968c6d24693d3a6.zip
added startup script
Diffstat (limited to 'sys-apps/lm_sensors')
-rw-r--r--sys-apps/lm_sensors/ChangeLog32
-rw-r--r--sys-apps/lm_sensors/files/rc_lm_sensors30
-rw-r--r--sys-apps/lm_sensors/lm_sensors-2.6.3-r1.ebuild52
-rw-r--r--sys-apps/lm_sensors/lm_sensors-2.6.4-r1.ebuild52
4 files changed, 154 insertions, 12 deletions
diff --git a/sys-apps/lm_sensors/ChangeLog b/sys-apps/lm_sensors/ChangeLog
index be8a6027a3ff..ef13e2798c25 100644
--- a/sys-apps/lm_sensors/ChangeLog
+++ b/sys-apps/lm_sensors/ChangeLog
@@ -1,16 +1,27 @@
# ChangeLog for sys-apps/lm_sensors
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/lm_sensors/ChangeLog,v 1.5 2002/07/21 09:45:34 naz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lm_sensors/ChangeLog,v 1.6 2002/08/04 00:24:45 blizzy Exp $
- 26 May 2002; Michael Nazaroff <naz@gentoo.org> lm_sensors-2.6.4.ebuild:
+*lm_sensors-2.6.4-r1 (04 Aug 2002)
+
+ 04 Aug 2002; Maik Schreiber <blizzy@gentoo.org> : Added
+ /etc/init.d/lm_sensors script to automatically load lm_sensors
+ modules on startup.
+
+*lm_sensors-2.6.3-r1 (04 Aug 2002)
+
+ 04 Aug 2002; Maik Schreiber <blizzy@gentoo.org> : Added
+ /etc/init.d/lm_sensors script to automatically load lm_sensors
+ modules on startup.
+
+*lm_sensors-2.6.4 (26 May 2002)
+
+ 26 May 2002; Michael Nazaroff <naz@gentoo.org> :
Ebuild bumped to the newest release.
- 26 May 2002; Seemant Kulleen <seemant@gentoo.org> lm_sensors-2.6.3.ebuild:
+ 15 Jul 2002; Mark Guertin <gerk@gentoo.org> : Added ppc to keywords
- 15 Jul 2002; Mark Guertin <gerk@gentoo.org>
- Added ppc to keywords
-
- 14 Jul 2002; phoen][x <phoenix@gentoo.org> lm_sensors-2.6.3.ebuild :
+ 14 Jul 2002; phoen][x <phoenix@gentoo.org> lm_sensors-2.6.3.ebuild:
Added LICENSE, KEYWORDS.
SRC_URI updated thanks to c.vanfleteren@pandora.be (Christophe
@@ -18,8 +29,5 @@
*lm_sensors-2.6.3 (27 Apr 2002)
- 27 Apr 2002; Bruce A. Locke <blocke@shivan.org> lm_sensors-2.6.3.ebuild:
-
- First version added to Portage.
-
-
+ 27 Apr 2002; Bruce A. Locke <blocke@shivan.org> : First version added
+ to Portage.
diff --git a/sys-apps/lm_sensors/files/rc_lm_sensors b/sys-apps/lm_sensors/files/rc_lm_sensors
new file mode 100644
index 000000000000..697b572888a9
--- /dev/null
+++ b/sys-apps/lm_sensors/files/rc_lm_sensors
@@ -0,0 +1,30 @@
+#!/sbin/runscript
+
+start() {
+ if ! [ -f /etc/sysconfig/lm_sensors ] ; then
+ eerror "/etc/sysconfig/lm_sensors does not exist"
+ return 1
+ fi
+
+ . /etc/sysconfig/lm_sensors
+
+ ebegin "Loading lm_sensors modules"
+ eend $?
+ if ! [ -e /proc/sys/dev/sensors ] ; then
+ ebegin " Loading i2c-proc"
+ modprobe i2c-proc &>/dev/null
+ eend $?
+ fi
+ [ -e /proc/sys/dev/sensors ] || return 1
+
+ modules=`grep \^MODULE_ /etc/sysconfig/lm_sensors |wc -l`
+ i=1
+ while [ ${i} -le ${modules} ] ; do
+ module=`eval echo '$'MODULE_${i}`
+ ebegin " Loading ${module}"
+ modprobe ${module} &>/dev/null
+ eend $?
+ i=$((i+1))
+ done
+ return 0
+}
diff --git a/sys-apps/lm_sensors/lm_sensors-2.6.3-r1.ebuild b/sys-apps/lm_sensors/lm_sensors-2.6.3-r1.ebuild
new file mode 100644
index 000000000000..0c60e0ba101c
--- /dev/null
+++ b/sys-apps/lm_sensors/lm_sensors-2.6.3-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lm_sensors/lm_sensors-2.6.3-r1.ebuild,v 1.1 2002/08/04 00:24:45 blizzy Exp $
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Hardware Sensors Monitoring by lm_sensors"
+SRC_URI="http://www2.lm-sensors.nu/~lm78/archive/${P}.tar.gz"
+HOMEPAGE="http://www2.lm-sensors.nu/~lm78"
+KEYWORDS="x86 ppc"
+LICENSE="GPL-2"
+
+SLOT="0"
+
+DEPEND="virtual/linux-sources"
+
+src_compile () {
+
+ emake clean all || die "lm_sensors requires the source of a compatible kernel\nversion installed in /usr/src/linux and i2c support built as a modules"
+
+}
+
+src_install () {
+ emake DESTDIR=${D} PREFIX=/usr MANDIR=/usr/share/man install || die
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/rc_lm_sensors lm_sensors
+}
+
+pkg_postinst() {
+
+ [ -x /usr/sbin/update-modules ] && /usr/sbin/update-modules
+
+ einfo
+ einfo "The lm_sensors hardware sensors package has been installed."
+ einfo
+ einfo "It is recommended that you read the lm_sensors documentation."
+ einfo "To enable lm_sensors you will need to compile i2c support in"
+ einfo "your kernel as a module and run /usr/sbin/sensors-detect to"
+ einfo "detect the hardware in your system."
+ einfo
+ einfo "Be warned, the probing of hardware in your system performed by"
+ einfo "sensors-detect could freeze your system. Also do not use"
+ einfo "lm_sensors on certain laptop models from IBM. See the lm_sensors"
+ einfo "documentation and website for more information."
+ einfo
+ einfo "IMPORTANT: When you merge this package it installs kernel modules"
+ einfo "that can only be used with the specific kernel version whose"
+ einfo "source is located in /usr/src/linux. If you upgrade to a new"
+ einfo "kernel, you will need to remerge the lm_sensors package to build"
+ einfo "new kernel modules."
+ einfo
+
+}
diff --git a/sys-apps/lm_sensors/lm_sensors-2.6.4-r1.ebuild b/sys-apps/lm_sensors/lm_sensors-2.6.4-r1.ebuild
new file mode 100644
index 000000000000..eed9e0def846
--- /dev/null
+++ b/sys-apps/lm_sensors/lm_sensors-2.6.4-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lm_sensors/lm_sensors-2.6.4-r1.ebuild,v 1.1 2002/08/04 00:24:45 blizzy Exp $
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Hardware Sensors Monitoring by lm_sensors"
+SRC_URI="http://www2.lm-sensors.nu/~lm78/archive/${P}.tar.gz"
+HOMEPAGE="http://www2.lm-sensors.nu/~lm78"
+KEYWORDS="x86 ppc"
+LICENSE="GPL-2"
+
+SLOT="0"
+
+DEPEND="virtual/linux-sources"
+
+src_compile () {
+
+ emake clean all || die "lm_sensors requires the source of a compatible kernel\nversion installed in /usr/src/linux and i2c support built as a modules"
+
+}
+
+src_install () {
+ emake DESTDIR=${D} PREFIX=/usr MANDIR=/usr/share/man install || die
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/rc_lm_sensors lm_sensors
+}
+
+pkg_postinst() {
+
+ [ -x /usr/sbin/update-modules ] && /usr/sbin/update-modules
+
+ einfo
+ einfo "The lm_sensors hardware sensors package has been installed."
+ einfo
+ einfo "It is recommended that you read the lm_sensors documentation."
+ einfo "To enable lm_sensors you will need to compile i2c support in"
+ einfo "your kernel as a module and run /usr/sbin/sensors-detect to"
+ einfo "detect the hardware in your system."
+ einfo
+ einfo "Be warned, the probing of hardware in your system performed by"
+ einfo "sensors-detect could freeze your system. Also do not use"
+ einfo "lm_sensors on certain laptop models from IBM. See the lm_sensors"
+ einfo "documentation and website for more information."
+ einfo
+ einfo "IMPORTANT: When you merge this package it installs kernel modules"
+ einfo "that can only be used with the specific kernel version whose"
+ einfo "source is located in /usr/src/linux. If you upgrade to a new"
+ einfo "kernel, you will need to remerge the lm_sensors package to build"
+ einfo "new kernel modules."
+ einfo
+
+}