summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2013-02-09 18:59:10 +0000
committerChris Reffett <creffett@gentoo.org>2013-02-09 18:59:10 +0000
commit5283b11aecb3351c4e4b1c8ccd15148a20f9537a (patch)
tree8c5469736d9a1b3a427ec9ca1b69eb2cd063f096 /sys-apps/lnxhc
parentVersion bump. (diff)
downloadgentoo-2-5283b11aecb3351c4e4b1c8ccd15148a20f9537a.tar.gz
gentoo-2-5283b11aecb3351c4e4b1c8ccd15148a20f9537a.tar.bz2
gentoo-2-5283b11aecb3351c4e4b1c8ccd15148a20f9537a.zip
New package wrt bug 443922. Credit to Fpemud <fpemud@sina.com> for the initial ebuild.
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 42618354)
Diffstat (limited to 'sys-apps/lnxhc')
-rw-r--r--sys-apps/lnxhc/ChangeLog10
-rw-r--r--sys-apps/lnxhc/files/lnxhc-1.2-usrlocal.patch43
-rw-r--r--sys-apps/lnxhc/lnxhc-1.2.ebuild22
-rw-r--r--sys-apps/lnxhc/metadata.xml8
4 files changed, 83 insertions, 0 deletions
diff --git a/sys-apps/lnxhc/ChangeLog b/sys-apps/lnxhc/ChangeLog
new file mode 100644
index 000000000000..efda63535162
--- /dev/null
+++ b/sys-apps/lnxhc/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sys-apps/lnxhc
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lnxhc/ChangeLog,v 1.1 2013/02/09 18:59:10 creffett Exp $
+
+*lnxhc-1.2 (09 Feb 2013)
+
+ 09 Feb 2013; Chris Reffett <creffett@gentoo.org>
+ +files/lnxhc-1.2-usrlocal.patch, +lnxhc-1.2.ebuild, +metadata.xml:
+ New package wrt bug 443922. Credit to Fpemud <fpemud@sina.com> for the initial
+ ebuild.
diff --git a/sys-apps/lnxhc/files/lnxhc-1.2-usrlocal.patch b/sys-apps/lnxhc/files/lnxhc-1.2-usrlocal.patch
new file mode 100644
index 000000000000..fe237502785f
--- /dev/null
+++ b/sys-apps/lnxhc/files/lnxhc-1.2-usrlocal.patch
@@ -0,0 +1,43 @@
+diff -ruN lnxhc-1.2/Makefile lnxhc-1.2-patched/Makefile
+--- lnxhc-1.2/Makefile 2013-02-06 04:14:17.000000000 -0500
++++ lnxhc-1.2-patched/Makefile 2013-02-09 13:39:25.096883794 -0500
+@@ -71,7 +71,6 @@
+ pycheckdir := $(libdir)/python/check
+ exampledir := $(docdir)/examples
+ dbdir1 := $(libdir)
+-dbdir2 := /usr/local/lib/lnxhc
+
+ # Base files
+ binfiles := $(wildcard bin/*)
+@@ -154,7 +153,7 @@
+ $(DESTDIR)$(sysvardir) $(DESTDIR)$(pmdir) \
+ $(DESTDIR)$(checkdir) $(DESTDIR)$(consdir) \
+ $(DESTDIR)$(profiledir) $(DESTDIR)$(dbdir1) \
+- $(DESTDIR)$(dbdir2) $(DESTDIR)$(pmcheckdir) \
++ $(DESTDIR)$(pmcheckdir) \
+ $(DESTDIR)$(pmconsumerdir) $(DESTDIR)$(pydir) \
+ $(DESTDIR)$(pycheckdir) $(DESTDIR)$(exampledir)
+
+@@ -164,7 +163,7 @@
+ $(DESTDIR)$(checkdir) $(DESTDIR)$(consdir) \
+ $(DESTDIR)$(profiledir) $(DESTDIR)$(pycheckdir) \
+ $(DESTDIR)$(pydir) $(DESTDIR)$(libdir) \
+- $(DESTDIR)$(dbdir2) $(DESTDIR)$(exampledir) \
++ $(DESTDIR)$(exampledir) \
+ $(DESTDIR)$(docdir)
+
+ installbase: installdirs
+@@ -184,11 +183,11 @@
+ $(CP) -rp $(examples) $(DESTDIR)$(exampledir)
+ for FILE in $(notdir $(binfiles)) ; do \
+ $(FIXPATH) "$(DESTDIR)/$(bindir)/$${FILE}" "$(libdir)" \
+- "$(dbdir1)" "$(dbdir2)" ; \
++ "$(dbdir1)" ; \
+ done
+ for FILE in $(notdir $(conffiles)) ; do \
+ $(FIXPATH) "$(DESTDIR)/$(confdir)/$${FILE}" "$(libdir)" \
+- "$(dbdir1)" "$(dbdir2)" ; \
++ "$(dbdir1)" ; \
+ done
+
+ uninstallbase:
diff --git a/sys-apps/lnxhc/lnxhc-1.2.ebuild b/sys-apps/lnxhc/lnxhc-1.2.ebuild
new file mode 100644
index 000000000000..ca9fd844b91c
--- /dev/null
+++ b/sys-apps/lnxhc/lnxhc-1.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lnxhc/lnxhc-1.2.ebuild,v 1.1 2013/02/09 18:59:10 creffett Exp $
+
+EAPI=5
+
+inherit eutils
+DESCRIPTION="Linux Health Checker"
+HOMEPAGE="http://lnxhc.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="EPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=">=dev-lang/perl-5.8"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.2-usrlocal.patch"
+}
diff --git a/sys-apps/lnxhc/metadata.xml b/sys-apps/lnxhc/metadata.xml
new file mode 100644
index 000000000000..b8f97c36765b
--- /dev/null
+++ b/sys-apps/lnxhc/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>creffett@gentoo.org</email>
+ <name>Chris Reffett</name>
+ </maintainer>
+</pkgmetadata>