summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJared H.Hudson <jhhudso@gentoo.org>2003-05-02 06:47:50 +0000
committerJared H.Hudson <jhhudso@gentoo.org>2003-05-02 06:47:50 +0000
commit01a984c8d78619536f8646e740ca898a83395878 (patch)
tree8e0ea92b622a96fed53a3965f38e4fdb9f34664c /sys-apps/logwatch
parentupdate to 0.8.3 (diff)
downloadgentoo-2-01a984c8d78619536f8646e740ca898a83395878.tar.gz
gentoo-2-01a984c8d78619536f8646e740ca898a83395878.tar.bz2
gentoo-2-01a984c8d78619536f8646e740ca898a83395878.zip
Remove symbolic links during pkg_postrm() (bug #17746)
Diffstat (limited to 'sys-apps/logwatch')
-rw-r--r--sys-apps/logwatch/ChangeLog7
-rw-r--r--sys-apps/logwatch/files/digest-logwatch-4.2.1-r11
-rw-r--r--sys-apps/logwatch/files/digest-logwatch-4.3.1-r11
-rw-r--r--sys-apps/logwatch/logwatch-4.2.1-r1.ebuild108
-rw-r--r--sys-apps/logwatch/logwatch-4.3.1-r1.ebuild110
5 files changed, 226 insertions, 1 deletions
diff --git a/sys-apps/logwatch/ChangeLog b/sys-apps/logwatch/ChangeLog
index fa76c3969e87..d0f5a6cd9ef5 100644
--- a/sys-apps/logwatch/ChangeLog
+++ b/sys-apps/logwatch/ChangeLog
@@ -1,7 +1,12 @@
# ChangeLog for sys-apps/logwatch
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/logwatch/ChangeLog,v 1.7 2003/04/11 06:23:45 jhhudso Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/logwatch/ChangeLog,v 1.8 2003/05/02 06:47:50 jhhudso Exp $
+ 01 May 2003; Jared Hudson <jhhudso@gentoo.org> logwatch-4.2.1-r1.ebuild,
+ logwatch-4.3.1-r1.ebuild : Changed pkg_postrm() to remove the symbolic
+ links created in pkg_postinst(). In response to bug #17746, credit goes to
+ Gregorio Guidi <g.guidi@sns.it>.
+
11 Apr 2003; Jared Hudson <jhhudso@gentoo.org> logwatch-4.2.1.ebuild,
logwatch-4.3.1.ebuild : Changed pkg_postrm() and pkg_postinst() to fix
crontab bug reported in bug # 16576. Credit goes to:
diff --git a/sys-apps/logwatch/files/digest-logwatch-4.2.1-r1 b/sys-apps/logwatch/files/digest-logwatch-4.2.1-r1
new file mode 100644
index 000000000000..6a3d0abe5962
--- /dev/null
+++ b/sys-apps/logwatch/files/digest-logwatch-4.2.1-r1
@@ -0,0 +1 @@
+MD5 b0ba7785397a29a94715e9710b13340d logwatch-4.2.1.tar.gz 55071
diff --git a/sys-apps/logwatch/files/digest-logwatch-4.3.1-r1 b/sys-apps/logwatch/files/digest-logwatch-4.3.1-r1
new file mode 100644
index 000000000000..f03bb0714db9
--- /dev/null
+++ b/sys-apps/logwatch/files/digest-logwatch-4.3.1-r1
@@ -0,0 +1 @@
+MD5 1976626db0d162bcf95c00e3966a4e66 logwatch-4.3.1.tar.gz 56919
diff --git a/sys-apps/logwatch/logwatch-4.2.1-r1.ebuild b/sys-apps/logwatch/logwatch-4.2.1-r1.ebuild
new file mode 100644
index 000000000000..528b01a2ea8f
--- /dev/null
+++ b/sys-apps/logwatch/logwatch-4.2.1-r1.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/logwatch/logwatch-4.2.1-r1.ebuild,v 1.1 2003/05/02 06:47:50 jhhudso Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="LogWatch, a customizable log analysis system"
+SRC_URI="ftp://ftp.kaybee.org/pub/old/linux/${P}.tar.gz"
+HOMEPAGE="http://www.logwatch.org/"
+
+DEPEND="virtual/glibc
+ virtual/cron
+ virtual/mta
+ dev-lang/perl
+ net-mail/mailx"
+
+SLOT="0"
+KEYWORDS="x86"
+LICENSE="as-is"
+IUSE=""
+RDEPEND=""
+
+src_install() {
+ dodir /usr/share/logwatch
+ dodir /usr/share/logwatch/conf
+ dodir /usr/share/logwatch/conf/logfiles
+ dodir /usr/share/logwatch/conf/services
+ dodir /usr/share/logwatch/scripts
+ dodir /usr/share/logwatch/scripts/services
+ dodir /usr/share/logwatch/scripts/shared
+
+ # correct install directory into script
+ cat ${S}/scripts/logwatch.pl | sed -e "s/my \$BaseDir = \"\/etc\/log.d\";/my \$BaseDir = \"\/usr\/share\/logwatch\";/" > ${S}/scripts/logwatch.tmp_install
+ exeinto /usr/share/logwatch/scripts
+ newexe scripts/logwatch.tmp_install logwatch.pl
+
+ exeinto /usr/share/logwatch/scripts/logfiles
+ for i in scripts/logfiles/* ; do
+ if [ $(ls $i | wc -l) -ne 0 ] ; then
+ file="`echo $i | awk -F/ '{ print $3 }'`"
+ dodir /usr/share/logwatch/scripts/logfiles/$file
+ exeinto /usr/share/logwatch/scripts/logfiles/$file
+ for l in scripts/logfiles/$file/* ; do
+ subfile="`echo $l | awk -F/ '{ print $4 }'`"
+ newexe $l $subfile
+ done
+ fi
+ done
+
+ exeinto /usr/share/logwatch/scripts/services
+ for i in scripts/services/* ; do
+ file="`echo $i | awk -F/ '{ print $3 }'`"
+ newexe $i $file
+ done
+
+ exeinto /usr/share/logwatch/scripts/shared
+ for i in scripts/shared/* ; do
+ file="`echo $i | awk -F/ '{ print $3 }'`"
+ newexe $i $file
+ done
+
+ insinto /usr/share/logwatch/conf
+ doins conf/logwatch.conf
+
+ insinto /usr/share/logwatch/conf/logfiles
+ for i in conf/logfiles/* ; do
+ doins $i
+ done
+
+ insinto /usr/share/logwatch/conf/services
+ for i in conf/services/* ; do
+ doins $i
+ done
+
+ dodoc README License HOWTO-Make-Filter
+ doman logwatch.8
+ }
+
+pkg_postinst() {
+ einfo "creating a symlink for configuration directory..."
+ ln -snf ${ROOT}usr/share/logwatch/conf ${ROOT}etc/logwatch
+
+ einfo "adding executable to path..."
+ ln -sf ${ROOT}usr/share/logwatch/scripts/logwatch.pl ${ROOT}usr/bin/logwatch
+
+ # this will avoid duplicate entries in the crontab
+ if [ "`grep logwatch.pl ${ROOT}var/spool/cron/crontabs/root`" == "" ];
+ then
+ einfo "adding to cron..."
+ echo "0 0 * * * ${ROOT}usr/sbin/logwatch.pl 2>&1 > /dev/null" \
+ >> ${ROOT}var/spool/cron/crontabs/root
+ fi
+}
+
+pkg_postrm() {
+ # this fixes a bug when logwatch package gets updated
+ if [ "`ls -d ${ROOT}var/db/pkg/sys-apps/logwatch* \
+ | wc -l | tail -c 2`" -lt 2 ];
+ then
+ sed "/^0.*\/usr\/sbin\/logwatch.*null$/d" \
+ ${ROOT}var/spool/cron/crontabs/root \
+ > ${ROOT}var/spool/cron/crontabs/root.new
+ mv --force ${ROOT}var/spool/cron/crontabs/root.new \
+ ${ROOT}var/spool/cron/crontabs/root
+ fi
+
+ rm -f ${ROOT}etc/logwatch
+ rm -f ${ROOT}usr/bin/logwatch
+}
diff --git a/sys-apps/logwatch/logwatch-4.3.1-r1.ebuild b/sys-apps/logwatch/logwatch-4.3.1-r1.ebuild
new file mode 100644
index 000000000000..528fc6ba87aa
--- /dev/null
+++ b/sys-apps/logwatch/logwatch-4.3.1-r1.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/logwatch/logwatch-4.3.1-r1.ebuild,v 1.1 2003/05/02 06:47:50 jhhudso Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="LogWatch, a customizable log analysis system"
+SRC_URI="ftp://ftp.kaybee.org/pub/old/linux/${P}.tar.gz"
+HOMEPAGE="http://www.logwatch.org/"
+
+DEPEND="virtual/glibc
+ virtual/cron
+ virtual/mta
+ dev-lang/perl
+ net-mail/mailx"
+
+SLOT="0"
+KEYWORDS="~x86"
+LICENSE="as-is"
+IUSE=""
+RDEPEND=""
+
+src_install() {
+ dodir /usr/share/logwatch
+ dodir /usr/share/logwatch/conf
+ dodir /usr/share/logwatch/conf/logfiles
+ dodir /usr/share/logwatch/conf/services
+ dodir /usr/share/logwatch/scripts
+ dodir /usr/share/logwatch/scripts/services
+ dodir /usr/share/logwatch/scripts/shared
+
+ # correct install directory into script
+ cat ${S}/scripts/logwatch.pl | sed -e "s/my \$BaseDir = \"\/etc\/log.d\";/my \$BaseDir = \"\/usr\/share\/logwatch\";/" > ${S}/scripts/logwatch.tmp_install
+ exeinto /usr/share/logwatch/scripts
+ newexe scripts/logwatch.tmp_install logwatch.pl
+ exeinto /usr/share/logwatch/scripts/logfiles
+ for i in scripts/logfiles/* ; do
+ if [ $(ls $i | wc -l) -ne 0 ] ; then
+ file="`echo $i | awk -F/ '{ print $3 }'`"
+ dodir /usr/share/logwatch/scripts/logfiles/$file
+
+ exeinto /usr/share/logwatch/scripts/logfiles/$file
+ for l in scripts/logfiles/$file/* ; do
+ subfile="`echo $l | awk -F/ '{ print $4 }'`"
+ newexe $l $subfile
+ done
+ fi
+ done
+
+ exeinto /usr/share/logwatch/scripts/services
+ for i in scripts/services/* ; do
+ file="`echo $i | awk -F/ '{ print $3 }'`"
+ newexe $i $file
+ done
+
+ exeinto /usr/share/logwatch/scripts/shared
+ for i in scripts/shared/* ; do
+ file="`echo $i | awk -F/ '{ print $3 }'`"
+ newexe $i $file
+ done
+
+ insinto /usr/share/logwatch/conf
+ doins conf/logwatch.conf
+
+ insinto /usr/share/logwatch/conf/logfiles
+ for i in conf/logfiles/* ; do
+ doins $i
+ done
+
+ insinto /usr/share/logwatch/conf/services
+ for i in conf/services/* ; do
+ doins $i
+ done
+
+ dodoc README License HOWTO-Make-Filter
+ doman logwatch.8
+ }
+
+pkg_postinst() {
+ einfo "creating a symlink for configuration directory..."
+ ln -snf ${ROOT}usr/share/logwatch/conf ${ROOT}etc/logwatch
+
+ einfo "adding executable to path..."
+ ln -sf ${ROOT}usr/share/logwatch/scripts/logwatch.pl ${ROOT}usr/bin/logwatch
+
+ # this will avoid duplicate entries in the crontab
+ if [ "`grep logwatch.pl ${ROOT}var/spool/cron/crontabs/root`" == "" ];
+ then
+ einfo "adding to cron..."
+ echo "0 0 * * * ${ROOT}usr/sbin/logwatch.pl 2>&1 > /dev/null" \
+ >> ${ROOT}var/spool/cron/crontabs/root
+ fi
+}
+
+pkg_postrm() {
+ # this fixes a bug when logwatch package gets updated
+ if [ "`ls -d ${ROOT}var/db/pkg/sys-apps/logwatch* \
+ | wc -l | tail -c 2`" -lt 2 ];
+ then
+ sed "/^0.*\/usr\/sbin\/logwatch.*null$/d" \
+ ${ROOT}var/spool/cron/crontabs/root \
+ > ${ROOT}var/spool/cron/crontabs/root.new
+ mv --force ${ROOT}var/spool/cron/crontabs/root.new \
+ ${ROOT}var/spool/cron/crontabs/root
+ fi
+
+ rm -f ${ROOT}etc/logwatch
+ rm -f ${ROOT}usr/bin/logwatch
+}
+
+