summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-01-24 09:23:18 +0000
committerTim Harder <radhermit@gentoo.org>2014-01-24 09:23:18 +0000
commit344d83422be711fe66102f9187f2c649de3f1b72 (patch)
tree6cdf1b4c0ed9e8ce80ce30b747adf6d8f0982620 /sys-apps/man-db
parentRemove insecure version (bug #484700). (diff)
downloadgentoo-2-344d83422be711fe66102f9187f2c649de3f1b72.tar.gz
gentoo-2-344d83422be711fe66102f9187f2c649de3f1b72.tar.bz2
gentoo-2-344d83422be711fe66102f9187f2c649de3f1b72.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'sys-apps/man-db')
-rw-r--r--sys-apps/man-db/ChangeLog7
-rw-r--r--sys-apps/man-db/man-db-2.6.6.ebuild79
2 files changed, 85 insertions, 1 deletions
diff --git a/sys-apps/man-db/ChangeLog b/sys-apps/man-db/ChangeLog
index 4c3999f663bc..83b0dc02268a 100644
--- a/sys-apps/man-db/ChangeLog
+++ b/sys-apps/man-db/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/man-db
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/man-db/ChangeLog,v 1.62 2014/01/20 15:54:27 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/man-db/ChangeLog,v 1.63 2014/01/24 09:23:18 radhermit Exp $
+
+*man-db-2.6.6 (24 Jan 2014)
+
+ 24 Jan 2014; Tim Harder <radhermit@gentoo.org> +man-db-2.6.6.ebuild:
+ Version bump.
20 Jan 2014; Agostino Sarubbo <ago@gentoo.org> man-db-2.6.5.ebuild:
Stable for ppc, wrt bug #495924
diff --git a/sys-apps/man-db/man-db-2.6.6.ebuild b/sys-apps/man-db/man-db-2.6.6.ebuild
new file mode 100644
index 000000000000..9d9a373743cc
--- /dev/null
+++ b/sys-apps/man-db/man-db-2.6.6.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/man-db/man-db-2.6.6.ebuild,v 1.1 2014/01/24 09:23:18 radhermit Exp $
+
+EAPI="4"
+
+inherit eutils user
+
+DESCRIPTION="a man replacement that utilizes berkdb instead of flat files"
+HOMEPAGE="http://www.nongnu.org/man-db/"
+SRC_URI="mirror://nongnu/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~arm-linux ~x86-linux"
+IUSE="berkdb +gdbm nls selinux static-libs zlib"
+
+RDEPEND="dev-libs/libpipeline
+ berkdb? ( sys-libs/db )
+ gdbm? ( sys-libs/gdbm )
+ !berkdb? ( !gdbm? ( sys-libs/gdbm ) )
+ sys-apps/groff
+ selinux? ( sec-policy/selinux-mandb )
+ zlib? ( sys-libs/zlib )
+ !sys-apps/man"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ virtual/pkgconfig
+ nls? (
+ app-text/po4a
+ sys-devel/gettext
+ )"
+
+pkg_setup() {
+ # Create user now as Makefile in src_install does setuid/chown
+ enewgroup man 15
+ enewuser man 13 -1 /usr/share/man man
+
+ if (use gdbm && use berkdb) || (use !gdbm && use !berkdb) ; then #496150
+ ewarn "Defaulting to USE=gdbm due to ambiguous berkdb/gdbm USE flag settings"
+ fi
+}
+
+src_configure() {
+ export ac_cv_lib_z_gzopen=$(usex zlib)
+ econf \
+ --docdir='$(datarootdir)'/doc/${PF} \
+ --enable-setuid \
+ --with-sections="1 1p 8 2 3 3p 4 5 6 7 9 0p tcl n l p o 1x 2x 3x 4x 5x 6x 7x 8x" \
+ $(use_enable nls) \
+ $(use_enable static-libs static) \
+ --with-db=$(usex gdbm gdbm $(usex berkdb db gdbm))
+}
+
+src_install() {
+ default
+ dodoc docs/{HACKING,TODO}
+ prune_libtool_files
+
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}"/man-db.cron man-db #289884
+
+ keepdir /var/cache/man
+ fowners man:0 /var/cache/man
+ fperms 2755 /var/cache/man
+}
+
+pkg_preinst() {
+ if [[ -f ${EROOT}var/cache/man/whatis ]] ; then
+ einfo "Cleaning ${EROOT}var/cache/man from sys-apps/man"
+ find "${EROOT}"var/cache/man -type f '!' '(' -name index.bt -o -name index.db ')' -delete
+ fi
+ if [[ ! -g ${EROOT}var/cache/man ]] ; then
+ einfo "Resetting permissions on ${EROOT}var/cache/man" #447944
+ mkdir -p "${EROOT}var/cache/man"
+ chown -R man:0 "${EROOT}"var/cache/man
+ find "${EROOT}"var/cache/man -type d '!' -perm /g=s -exec chmod 2755 {} +
+ fi
+}