summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-07-29 14:58:58 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-07-29 14:58:58 +0000
commit449030376dc7d3dc7e762391b29f613e0748bde5 (patch)
tree99159aef139ffed1415570dd719c9fb2580abafc /sys-apps/man
parentfix #5251: make it use the eclasses to determine where to install to. also no... (diff)
downloadgentoo-2-449030376dc7d3dc7e762391b29f613e0748bde5.tar.gz
gentoo-2-449030376dc7d3dc7e762391b29f613e0748bde5.tar.bz2
gentoo-2-449030376dc7d3dc7e762391b29f613e0748bde5.zip
new version
Diffstat (limited to 'sys-apps/man')
-rw-r--r--sys-apps/man/ChangeLog7
-rw-r--r--sys-apps/man/files/digest-man-1.5k1
-rw-r--r--sys-apps/man/man-1.5k.ebuild76
3 files changed, 83 insertions, 1 deletions
diff --git a/sys-apps/man/ChangeLog b/sys-apps/man/ChangeLog
index fe2e1034c418..ab21ea815185 100644
--- a/sys-apps/man/ChangeLog
+++ b/sys-apps/man/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/man
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/ChangeLog,v 1.4 2002/07/14 19:20:18 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/ChangeLog,v 1.5 2002/07/29 14:58:58 azarah Exp $
+
+*man-1.5k (29 Jul 2002)
+
+ 29 Jul 2002; Martin Schlemmer <azarah@gentoo.org> :
+ Update version; cleanups.
24 Apr 2002; t.bangert <bangert@gentoo.org> :
diff --git a/sys-apps/man/files/digest-man-1.5k b/sys-apps/man/files/digest-man-1.5k
new file mode 100644
index 000000000000..e10394767019
--- /dev/null
+++ b/sys-apps/man/files/digest-man-1.5k
@@ -0,0 +1 @@
+MD5 c678a9ba4b0f3df4ce2915e99490aa19 man-1.5k.tar.gz 193480
diff --git a/sys-apps/man/man-1.5k.ebuild b/sys-apps/man/man-1.5k.ebuild
new file mode 100644
index 000000000000..3b8937951581
--- /dev/null
+++ b/sys-apps/man/man-1.5k.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/man-1.5k.ebuild,v 1.1 2002/07/29 14:58:58 azarah Exp $
+
+NV=1.5k
+S=${WORKDIR}/${PN}-${NV}
+DESCRIPTION="Standard commands to read man pages"
+SRC_URI="http://www.kernel.org/pub/linux/utils/man/man-${NV}.tar.gz"
+HOMEPAGE=""
+DEPEND="virtual/glibc"
+
+RDEPEND="virtual/glibc
+ sys-apps/cronbase
+ sys-apps/groff"
+
+SLOT="0"
+KEYWORDS="x86 ppc"
+LICENSE="GPL-2"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ cp configure configure.orig
+ sed -e 's:/usr/lib/locale:$(prefix)/usr/lib/locale:g' \
+ -e 's!/usr/bin:/usr/ucb:!/usr/bin:!' \
+ configure.orig > configure
+ local x
+ for x in / src/ man2html/ msgs/
+ do
+ cd ${S}/${x}
+ cp Makefile.in Makefile.in.orig
+ sed -e '/inst.sh/d' \
+ -e '/^CC =/c\' \
+ -e "CC = gcc" \
+ -e '/^CFLAGS =/c\' \
+ -e "CFLAGS = $CFLAGS" \
+ Makefile.in.orig > Makefile.in
+ done
+}
+
+src_compile() {
+ local myconf=""
+ use nls && myconf="+lang all"
+
+ ./configure -confdir=/etc \
+ +sgid +fhs \
+ ${myconf} || die
+
+ make || die
+}
+
+src_install() {
+ dodir /usr/{bin,sbin}
+ cd ${S}
+ make PREFIX=${D} install || die
+
+ if [ -n "`use nls`" ]
+ then
+ cd ${S}/msgs
+ ./inst.sh ?? ${D}/usr/share/locale/%L/%N
+ fi
+
+ chmod 2555 ${D}/usr/bin/man
+ chown root.man ${D}/usr/bin/man
+
+ insinto /etc
+ cd ${S}
+ doins src/man.conf
+
+ dodoc COPYING LSM README* TODO
+
+ exeinto /etc/cron.daily
+ doexe ${FILESDIR}/makewhatis.cron
+}
+
+