summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-12-12 22:39:57 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-12-12 22:39:57 +0000
commit0475b79fe70d13df0da2b06ef08b1cccd6444382 (patch)
treee80b7bfc61472b14e1515b44701bee9d36dcb6a6 /sys-apps/microcode-data
parentStable for AMD64, wrt security bug #394239 (diff)
downloadgentoo-2-0475b79fe70d13df0da2b06ef08b1cccd6444382.tar.gz
gentoo-2-0475b79fe70d13df0da2b06ef08b1cccd6444382.tar.bz2
gentoo-2-0475b79fe70d13df0da2b06ef08b1cccd6444382.zip
Version bump.
(Portage version: 2.2.0_alpha80/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/microcode-data')
-rw-r--r--sys-apps/microcode-data/ChangeLog8
-rw-r--r--sys-apps/microcode-data/microcode-data-20111110.ebuild42
2 files changed, 49 insertions, 1 deletions
diff --git a/sys-apps/microcode-data/ChangeLog b/sys-apps/microcode-data/ChangeLog
index 14186bec96c9..8790ae1ca344 100644
--- a/sys-apps/microcode-data/ChangeLog
+++ b/sys-apps/microcode-data/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/microcode-data
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/microcode-data/ChangeLog,v 1.16 2011/12/12 21:34:38 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/microcode-data/ChangeLog,v 1.17 2011/12/12 22:39:57 flameeyes Exp $
+
+*microcode-data-20111110 (12 Dec 2011)
+
+ 12 Dec 2011; Diego E. Pettenò <flameeyes@gentoo.org>
+ +microcode-data-20111110.ebuild:
+ Version bump.
*microcode-data-20110915-r1 (12 Dec 2011)
diff --git a/sys-apps/microcode-data/microcode-data-20111110.ebuild b/sys-apps/microcode-data/microcode-data-20111110.ebuild
new file mode 100644
index 000000000000..4b3bcb6b786b
--- /dev/null
+++ b/sys-apps/microcode-data/microcode-data-20111110.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/microcode-data/microcode-data-20111110.ebuild,v 1.1 2011/12/12 22:39:57 flameeyes Exp $
+
+EAPI=4
+
+inherit toolchain-funcs
+
+NUM="20728"
+DESCRIPTION="Intel IA32 microcode update data"
+HOMEPAGE="http://urbanmyth.org/microcode/"
+SRC_URI="http://downloadmirror.intel.com/${NUM}/eng/microcode-${PV}.tgz"
+
+LICENSE="intel-ucode"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="!<sys-apps/microcode-ctl-1.17-r2" #268586
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack ${A}
+ cp "${FILESDIR}"/intel-microcode2ucode.c ./ || die
+}
+
+src_compile() {
+ tc-env_build emake intel-microcode2ucode
+ ./intel-microcode2ucode microcode.dat || die
+}
+
+src_install() {
+ insinto /lib/firmware
+ doins -r microcode.dat intel-ucode
+}
+
+pkg_postinst() {
+ elog "The microcode available for Intel CPUs has been updated. You'll need"
+ elog "to reload the code into your processor. If you're using the init.d:"
+ elog "/etc/init.d/microcode_ctl restart"
+}