summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2014-05-30 20:23:09 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2014-05-30 20:23:09 +0000
commit9647b5e13b35c802ccd9064d6c8caf3f5f95dd11 (patch)
tree6897039f92369fcf7f9890d9bc05b8851f883aa0 /sys-apps/microcode-data
parentStable for amd64 wrt bug #507988 (diff)
downloadgentoo-2-9647b5e13b35c802ccd9064d6c8caf3f5f95dd11.tar.gz
gentoo-2-9647b5e13b35c802ccd9064d6c8caf3f5f95dd11.tar.bz2
gentoo-2-9647b5e13b35c802ccd9064d6c8caf3f5f95dd11.zip
Version bump
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 09BF4F54C2BA7F3C!)
Diffstat (limited to 'sys-apps/microcode-data')
-rw-r--r--sys-apps/microcode-data/ChangeLog8
-rw-r--r--sys-apps/microcode-data/microcode-data-20140430.ebuild45
2 files changed, 52 insertions, 1 deletions
diff --git a/sys-apps/microcode-data/ChangeLog b/sys-apps/microcode-data/ChangeLog
index eeb2af2bf246..b4e1d1433663 100644
--- a/sys-apps/microcode-data/ChangeLog
+++ b/sys-apps/microcode-data/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/microcode-data
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/microcode-data/ChangeLog,v 1.28 2014/03/06 02:08:41 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/microcode-data/ChangeLog,v 1.29 2014/05/30 20:23:09 hwoarang Exp $
+
+*microcode-data-20140430 (30 May 2014)
+
+ 30 May 2014; Markos Chandras <hwoarang@gentoo.org>
+ +microcode-data-20140430.ebuild:
+ Version bump
*microcode-data-20140122 (06 Mar 2014)
diff --git a/sys-apps/microcode-data/microcode-data-20140430.ebuild b/sys-apps/microcode-data/microcode-data-20140430.ebuild
new file mode 100644
index 000000000000..2c5386678a45
--- /dev/null
+++ b/sys-apps/microcode-data/microcode-data-20140430.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/microcode-data/microcode-data-20140430.ebuild,v 1.1 2014/05/30 20:23:09 hwoarang Exp $
+
+EAPI="4"
+
+inherit toolchain-funcs
+
+# Find updates by searching and clicking the first link (hopefully it's the one):
+# http://www.intel.com/content/www/us/en/search.html?keyword=Processor+Microcode+Data+File
+
+NUM="23829"
+DESCRIPTION="Intel IA32 microcode update data"
+HOMEPAGE="http://inertiawar.com/microcode/ https://downloadcenter.intel.com/Detail_Desc.aspx?DwnldID=${NUM}"
+SRC_URI="http://downloadmirror.intel.com/${NUM}/eng/microcode-${PV}.tgz"
+
+LICENSE="intel-ucode"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+RDEPEND="!<sys-apps/microcode-ctl-1.17-r2" #268586
+
+S=${WORKDIR}
+
+src_unpack() {
+ default
+ cp "${FILESDIR}"/intel-microcode2ucode.c ./ || die
+}
+
+src_compile() {
+ tc-env_build emake intel-microcode2ucode
+ ./intel-microcode2ucode microcode.dat || die
+}
+
+src_install() {
+ insinto /lib/firmware
+ doins -r microcode.dat intel-ucode
+}
+
+pkg_postinst() {
+ elog "The microcode available for Intel CPUs has been updated. You'll need"
+ elog "to reload the code into your processor. If you're using the init.d:"
+ elog "/etc/init.d/microcode_ctl restart"
+}