summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2010-03-08 07:29:01 +0000
committerChristian Faulhammer <fauli@gentoo.org>2010-03-08 07:29:01 +0000
commit8138930c9e963de09c14055a8d3bcd3d1542deae (patch)
treee33965abf93d530e3541e57cf399135cf4f513c8 /sys-apps/mlocate
parentUpdated to latest versions, (closes bug 300577) simplified texlive deps. (diff)
downloadgentoo-2-8138930c9e963de09c14055a8d3bcd3d1542deae.tar.gz
gentoo-2-8138930c9e963de09c14055a8d3bcd3d1542deae.tar.bz2
gentoo-2-8138930c9e963de09c14055a8d3bcd3d1542deae.zip
version bump, bug 308403 by ssuominen
(Portage version: 2.1.7.17/cvs/Linux i686)
Diffstat (limited to 'sys-apps/mlocate')
-rw-r--r--sys-apps/mlocate/ChangeLog8
-rw-r--r--sys-apps/mlocate/mlocate-0.22.3.ebuild56
2 files changed, 63 insertions, 1 deletions
diff --git a/sys-apps/mlocate/ChangeLog b/sys-apps/mlocate/ChangeLog
index cf1418c5d29f..c6ee84173fed 100644
--- a/sys-apps/mlocate/ChangeLog
+++ b/sys-apps/mlocate/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/mlocate
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/mlocate/ChangeLog,v 1.55 2010/01/26 23:06:19 tcunha Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/mlocate/ChangeLog,v 1.56 2010/03/08 07:29:00 fauli Exp $
+
+*mlocate-0.22.3 (08 Mar 2010)
+
+ 08 Mar 2010; Christian Faulhammer <fauli@gentoo.org>
+ +mlocate-0.22.3.ebuild:
+ version bump, bug 308403 by ssuominen
26 Jan 2010; Tiago Cunha <tcunha@gentoo.org> mlocate-0.22.2-r1.ebuild:
stable sparc, bug 301400
diff --git a/sys-apps/mlocate/mlocate-0.22.3.ebuild b/sys-apps/mlocate/mlocate-0.22.3.ebuild
new file mode 100644
index 000000000000..de81cf5f49d6
--- /dev/null
+++ b/sys-apps/mlocate/mlocate-0.22.3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/mlocate/mlocate-0.22.3.ebuild,v 1.1 2010/03/08 07:29:01 fauli Exp $
+
+EAPI=3
+
+inherit eutils
+
+DESCRIPTION="Merging locate is an utility to index and quickly search for files"
+HOMEPAGE="https://fedorahosted.org/mlocate/"
+SRC_URI="https://fedorahosted.org/releases/m/l/mlocate/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="!sys-apps/slocate
+ !sys-apps/rlocate"
+
+pkg_setup() {
+ enewgroup locate
+}
+
+src_compile() {
+ emake groupname=locate || die
+}
+
+src_install() {
+ emake groupname=locate DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog README NEWS
+
+ insinto /etc
+ doins "${FILESDIR}/updatedb.conf"
+ fperms 0644 /etc/updatedb.conf
+
+ insinto /etc
+ doins "${FILESDIR}/mlocate-cron.conf"
+ fperms 0644 /etc/mlocate-cron.conf
+
+ insinto /etc/cron.daily
+ newins "${FILESDIR}/mlocate.cron-r2" mlocate
+ fperms 0755 /etc/cron.daily/mlocate
+
+ fowners 0:locate /usr/bin/locate
+ fperms go-r,g+s /usr/bin/locate
+
+ chown -R 0:locate "${D}/var/lib/mlocate"
+ fperms 0750 /var/lib/mlocate
+ keepdir /var/lib/mlocate
+}
+
+pkg_postinst() {
+ elog "Note that the /etc/updatedb.conf file is generic"
+ elog "Please customize it to your system requirements"
+}