summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Callen <abcd@gentoo.org>2011-04-12 22:01:02 +0000
committerJonathan Callen <abcd@gentoo.org>2011-04-12 22:01:02 +0000
commit374520792ba9033e213acca3fa585a8436496e11 (patch)
treed57f6c21b6206cef61288fffa7b3d614e913a03e /sys-apps/most/most-5.0.0a.ebuild
parentVersion bump to new security release. (diff)
downloadgentoo-2-374520792ba9033e213acca3fa585a8436496e11.tar.gz
gentoo-2-374520792ba9033e213acca3fa585a8436496e11.tar.bz2
gentoo-2-374520792ba9033e213acca3fa585a8436496e11.zip
Add prefix support, bump EAPI to 4, add prefix keywords, cleanup
(Portage version: 2.2.0_alpha29_p11/cvs/Linux i686)
Diffstat (limited to 'sys-apps/most/most-5.0.0a.ebuild')
-rw-r--r--sys-apps/most/most-5.0.0a.ebuild19
1 files changed, 9 insertions, 10 deletions
diff --git a/sys-apps/most/most-5.0.0a.ebuild b/sys-apps/most/most-5.0.0a.ebuild
index c94e8cc83a9f..6d733bf344ec 100644
--- a/sys-apps/most/most-5.0.0a.ebuild
+++ b/sys-apps/most/most-5.0.0a.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/most/most-5.0.0a.ebuild,v 1.11 2011/01/06 21:32:23 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/most/most-5.0.0a.ebuild,v 1.12 2011/04/12 22:01:02 abcd Exp $
+
+EAPI=4
DESCRIPTION="Paging program that displays, one windowful at a time, the contents of a file"
HOMEPAGE="ftp://space.mit.edu/pub/davis/most"
@@ -8,25 +10,22 @@ SRC_URI="ftp://space.mit.edu/pub/davis/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="alpha amd64 arm ~mips ppc sparc x86 ~x86-fbsd"
+KEYWORDS="alpha amd64 arm ~mips ppc sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
IUSE=""
RDEPEND=">=sys-libs/slang-2.1.3"
DEPEND="${RDEPEND}"
-src_unpack() {
- unpack ${A}
- sed -i -e 's:$(INSTALL) -s:$(INSTALL):' "${S}"/src/Makefile.in || die
+src_prepare() {
+ sed -i -e 's:$(INSTALL) -s:$(INSTALL):' src/Makefile.in || die
}
-src_compile() {
+src_configure() {
unset ARCH
econf
- emake || die "emake failed."
}
src_install() {
- emake DESTDIR="${D}" DOC_DIR="/usr/share/doc/${PF}" \
- install || die "emake install failed."
- prepalldocs
+ emake DESTDIR="${D}" DOC_DIR="${EPREFIX}/usr/share/doc/${PF}" \
+ install
}