summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Portnoy <avenj@gentoo.org>2003-06-19 20:25:31 +0000
committerJon Portnoy <avenj@gentoo.org>2003-06-19 20:25:31 +0000
commit4ce2cd93c800ebee13850c5068594821f6c97384 (patch)
tree83cf52a237a945f809eb9281a708855467192180 /sys-apps/netkit-base
parentNew revision no longer provides ping. Marked ~x86 - other archs, please add y... (diff)
downloadgentoo-2-4ce2cd93c800ebee13850c5068594821f6c97384.tar.gz
gentoo-2-4ce2cd93c800ebee13850c5068594821f6c97384.tar.bz2
gentoo-2-4ce2cd93c800ebee13850c5068594821f6c97384.zip
New revision no longer provides ping. Marked ~x86 - other archs, please add your arch to KEYWORDS as soon as you have iputils in the default profile.
Diffstat (limited to 'sys-apps/netkit-base')
-rw-r--r--sys-apps/netkit-base/ChangeLog10
-rw-r--r--sys-apps/netkit-base/Manifest4
-rw-r--r--sys-apps/netkit-base/files/digest-netkit-base-0.17-r81
-rw-r--r--sys-apps/netkit-base/netkit-base-0.17-r8.ebuild67
4 files changed, 79 insertions, 3 deletions
diff --git a/sys-apps/netkit-base/ChangeLog b/sys-apps/netkit-base/ChangeLog
index a561a4cc0c15..2018b25e3206 100644
--- a/sys-apps/netkit-base/ChangeLog
+++ b/sys-apps/netkit-base/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-apps/netkit-base
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/netkit-base/ChangeLog,v 1.15 2003/03/27 07:30:39 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/netkit-base/ChangeLog,v 1.16 2003/06/19 20:25:24 avenj Exp $
+
+*netkit-base-0.17-r8 (19 Jun 2003)
+
+ 19 Jun 2003; Jon Portnoy <avenj@gentoo.org> netkit-base-0.17-r8 :
+ This revision no longer provides the 'ping' utility. Ping now
+ comes from iputils instead. NOTE FOR OTHER ARCHs: do _NOT_
+ add KEYWORDS for your arch here unless you have iputils
+ in your default profile!
20 Feb 2003; Zach Welch <zwelch@gentoo.org> :
Added arm to keywords.
diff --git a/sys-apps/netkit-base/Manifest b/sys-apps/netkit-base/Manifest
index fea491409905..7604ccaf00b8 100644
--- a/sys-apps/netkit-base/Manifest
+++ b/sys-apps/netkit-base/Manifest
@@ -1,5 +1,5 @@
-MD5 304fddb28ae529d8ad1d42dd15cd246c ChangeLog 2829
-MD5 40600ca18c0eafae809cead2476eab2e netkit-base-0.17-r8.ebuild 1580
+MD5 d4cf6d29b1b889a2b2362d8dddaf80c4 ChangeLog 3142
+MD5 381ee110068dfa961dbc808cb123b0e8 netkit-base-0.17-r8.ebuild 1763
MD5 57c0c1766b7c2d1bd9538d52f207f431 netkit-base-0.17-r6.ebuild 1555
MD5 f089fd19a8a23ebd17eb63719ec2f8fe netkit-base-0.17-r7.ebuild 1585
MD5 a770366b91d1b0e666ed61ccfff827bc files/digest-netkit-base-0.17-r8 67
diff --git a/sys-apps/netkit-base/files/digest-netkit-base-0.17-r8 b/sys-apps/netkit-base/files/digest-netkit-base-0.17-r8
new file mode 100644
index 000000000000..90e0df4a05c9
--- /dev/null
+++ b/sys-apps/netkit-base/files/digest-netkit-base-0.17-r8
@@ -0,0 +1 @@
+MD5 1f0193358e92559ec0f598b09ccbc0ec netkit-base-0.17.tar.gz 56473
diff --git a/sys-apps/netkit-base/netkit-base-0.17-r8.ebuild b/sys-apps/netkit-base/netkit-base-0.17-r8.ebuild
new file mode 100644
index 000000000000..5ffbe738205b
--- /dev/null
+++ b/sys-apps/netkit-base/netkit-base-0.17-r8.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/netkit-base/netkit-base-0.17-r8.ebuild,v 1.1 2003/06/19 20:25:24 avenj Exp $
+
+inherit eutils
+
+DESCRIPTION="Old-style inetd"
+SRC_URI="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/${P}.tar.gz"
+HOMEPAGE="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/"
+
+# Only keyword for your arch if you have iputils in your default profile!
+KEYWORDS="~x86"
+SLOT="0"
+LICENSE="BSD"
+
+DEPEND="virtual/glibc"
+
+PROVIDE="virtual/inetd"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Note that epatch will intelligently patch architecture specific
+ # patches as well
+ epatch ${FILESDIR}
+}
+
+src_compile() {
+ ./configure || die
+
+ cp MCONFIG MCONFIG.orig
+ #sed -e "s/-O2/${CFLAGS} -Wstrict-prototypes -fomit-frame-pointer/"
+ sed -e "s:^CFLAGS=.*:CFLAGS=${CFLAGS} -Wall -Wbad-function-cast -Wcast-qual -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -Winline:" \
+ MCONFIG.orig > MCONFIG
+
+ emake || die "compile problem"
+}
+
+src_install() {
+ exeopts -m 4755
+
+ # avenj@gentoo.org 19 June 03:
+ # Uncomment for the (obsolete) version of ping.
+ # Most people should merge iputils instead.
+# exeinto /bin
+# doexe ping/ping
+
+ if [ -z "`use build`" ]
+ then
+ cd ${S}/etc.sample
+ sed -e 's:in\.telnetd$:in.telnetd -L /usr/sbin/telnetlogin:' \
+ < inetd.conf > inetd.conf.new
+ mv inetd.conf.new inetd.conf
+ cd ${S}
+
+ exeopts -m 755
+ exeinto /usr/bin
+ dosbin inetd/inetd
+ doman inetd/inetd.8 inetd/daemon.3
+# doman inetd/inetd.8 inetd/daemon.3 ping/ping.8
+
+ dodoc BUGS ChangeLog README
+ docinto samples ; dodoc etc.sample/*
+ exeinto /etc/init.d ; newexe ${FILESDIR}/inetd.rc6 inetd
+ fi
+}