summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2009-11-08 23:15:45 +0000
committerWilliam Hubbs <williamh@gentoo.org>2009-11-08 23:15:45 +0000
commit918de81da08182de7667691c5057adbd7941cf55 (patch)
tree8a4efdc6da4d0c546bb442101e33cefa747d37c6 /sys-apps/openrc/files
parentDrop down menus were not fixed for select tags, so bump again (diff)
downloadgentoo-2-918de81da08182de7667691c5057adbd7941cf55.tar.gz
gentoo-2-918de81da08182de7667691c5057adbd7941cf55.tar.bz2
gentoo-2-918de81da08182de7667691c5057adbd7941cf55.zip
removed old version
(Portage version: 2.2_rc49/cvs/Linux i686)
Diffstat (limited to 'sys-apps/openrc/files')
-rw-r--r--sys-apps/openrc/files/0.4.2/0001-msg-style.patch46
-rw-r--r--sys-apps/openrc/files/0.4.2/0002-useful-functions.patch80
-rw-r--r--sys-apps/openrc/files/0.4.2/0003-KV.patch120
-rw-r--r--sys-apps/openrc/files/0.4.3/0001-fix-is_older_than.patch42
-rw-r--r--sys-apps/openrc/files/0.4.3/0002-support-custom-status.patch204
-rw-r--r--sys-apps/openrc/files/0.4.3/0003-command-line-size-fix.patch94
6 files changed, 0 insertions, 586 deletions
diff --git a/sys-apps/openrc/files/0.4.2/0001-msg-style.patch b/sys-apps/openrc/files/0.4.2/0001-msg-style.patch
deleted file mode 100644
index ab3559e71a70..000000000000
--- a/sys-apps/openrc/files/0.4.2/0001-msg-style.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-From 1eddb56f11b41c4bf4f878c995c5d140b1f9d44d Mon Sep 17 00:00:00 2001
-From: Mike Frysinger <vapier@gentoo.org>
-Date: Mon, 24 Mar 2008 01:48:19 -0400
-Subject: [PATCH] This reverts commit 0e2f160c95b15e95f3885e3f5a3670ec5ae0a709. 2 spaces in 80 cols has never made any sort of realistic difference and we're not going to change this behavior in Gentoo.
-
----
- src/libeinfo/libeinfo.c | 9 +++------
- 1 files changed, 3 insertions(+), 6 deletions(-)
-
-diff --git a/src/libeinfo/libeinfo.c b/src/libeinfo/libeinfo.c
-index f8ddcb5..c46cacb 100644
---- a/src/libeinfo/libeinfo.c
-+++ b/src/libeinfo/libeinfo.c
-@@ -787,7 +787,7 @@ static void _eend(FILE * __EINFO_RESTRICT fp, int col, ECOLOR color,
- if (! msg)
- return;
-
-- cols = get_term_columns(fp) - (strlen(msg) + 3);
-+ cols = get_term_columns(fp) - (strlen(msg) + 5);
-
- /* cons25 is special - we need to remove one char, otherwise things
- * do not align properly at all. */
-@@ -801,18 +801,15 @@ static void _eend(FILE * __EINFO_RESTRICT fp, int col, ECOLOR color,
- if (term_is_cons25)
- cols--;
-
-- /* If extra spacing is required around msg, then please change
-- * via a runtime knob and leave this default as is as it saves 2
-- * valuable columns when running on 80 column screens. */
- if (cols > 0 && colour_terminal(fp)) {
-- fprintf(fp, "%s%s %s[%s%s%s]%s\n", up, tgoto(goto_column, 0, cols),
-+ fprintf(fp, "%s%s %s[%s %s %s]%s\n", up, tgoto(goto_column, 0, cols),
- ecolor(ECOLOR_BRACKET), ecolor(color), msg,
- ecolor(ECOLOR_BRACKET), ecolor(ECOLOR_NORMAL));
- } else {
- if (col > 0)
- for (i = 0; i < cols - col; i++)
- fprintf(fp, " ");
-- fprintf(fp, " [%s]\n", msg);
-+ fprintf(fp, " [ %s ]\n", msg);
- }
- }
-
---
-1.5.4.4
-
diff --git a/sys-apps/openrc/files/0.4.2/0002-useful-functions.patch b/sys-apps/openrc/files/0.4.2/0002-useful-functions.patch
deleted file mode 100644
index a307386f9504..000000000000
--- a/sys-apps/openrc/files/0.4.2/0002-useful-functions.patch
+++ /dev/null
@@ -1,80 +0,0 @@
-From 79e8ce8d2ea0ede99aba18d5f9a625a110aa918f Mon Sep 17 00:00:00 2001
-From: Mike Frysinger <vapier@gentoo.org>
-Date: Mon, 24 Mar 2008 02:03:39 -0400
-Subject: [PATCH] add a softlevel() function to the API so people dont have to worry about inner details and move get_bootparam back to the exported function.sh api
-
----
- sh/functions.sh.in | 22 ++++++++++++++++++++++
- sh/rc-functions.sh.in | 23 -----------------------
- 2 files changed, 22 insertions(+), 23 deletions(-)
-
-diff --git a/sh/functions.sh.in b/sh/functions.sh.in
-index 57917ed..680f534 100644
---- a/sh/functions.sh.in
-+++ b/sh/functions.sh.in
-@@ -42,6 +42,28 @@ rc_runlevel() {
- rc-status --runlevel
- }
-
-+get_bootparam()
-+{
-+ local match="$1"
-+ [ -z "${match}" -o ! -r /proc/cmdline ] && return 1
-+
-+ set -- $(cat /proc/cmdline)
-+ while [ -n "$1" ]; do
-+ case "$1" in
-+ gentoo=*)
-+ local params="${1##*=}"
-+ local IFS=, x=
-+ for x in ${params}; do
-+ [ "${x}" = "${match}" ] && return 0
-+ done
-+ ;;
-+ esac
-+ shift
-+ done
-+
-+ return 1
-+}
-+
- _sanitize_path()
- {
- local IFS=":" p= path=
-diff --git a/sh/rc-functions.sh.in b/sh/rc-functions.sh.in
-index 751d47a..c713def 100644
---- a/sh/rc-functions.sh.in
-+++ b/sh/rc-functions.sh.in
-@@ -51,29 +51,6 @@ is_union_fs()
- unionctl "$1" --list >/dev/null 2>&1
- }
-
--get_bootparam()
--{
-- local match="$1"
-- [ -z "${match}" -o ! -r /proc/cmdline ] && return 1
--
-- set -- $(cat /proc/cmdline)
-- while [ -n "$1" ]; do
-- [ "$1" = "${match}" ] && return 0
-- case "$1" in
-- gentoo=*)
-- local params="${1##*=}"
-- local IFS=, x=
-- for x in ${params}; do
-- [ "${x}" = "${match}" ] && return 0
-- done
-- ;;
-- esac
-- shift
-- done
--
-- return 1
--}
--
- # Add our sbin to $PATH
- case "${PATH}" in
- "${RC_LIBDIR}"/sbin|"${RC_LIBDIR}"/sbin:*);;
---
-1.6.0.2
-
diff --git a/sys-apps/openrc/files/0.4.2/0003-KV.patch b/sys-apps/openrc/files/0.4.2/0003-KV.patch
deleted file mode 100644
index 8ab646f32c0d..000000000000
--- a/sys-apps/openrc/files/0.4.2/0003-KV.patch
+++ /dev/null
@@ -1,120 +0,0 @@
-From dac703b26c71cd8479b71d101c4e1ddb8eadc194 Mon Sep 17 00:00:00 2001
-From: Mike Frysinger <vapier@gentoo.org>
-Date: Mon, 24 Mar 2008 03:14:02 -0400
-Subject: [PATCH] add back KV_* funcs
-
----
- sh/functions.sh.in | 35 +++++++++++++++++++++++++++++++++++
- sh/runtests.sh | 45 +++++++++++++++++++++++++++++++++++++++++++++
- 2 files changed, 80 insertions(+), 0 deletions(-)
-
-diff --git a/sh/functions.sh.in b/sh/functions.sh.in
-index 140f6dc..0522792 100644
---- a/sh/functions.sh.in
-+++ b/sh/functions.sh.in
-@@ -65,6 +65,41 @@ get_bootparam()
- return 1
- }
-
-+KV_major() {
-+ [ -z "$*" ] && return 1
-+ local KV="$*"
-+ echo ${KV%%.*}
-+}
-+
-+KV_minor() {
-+ [ -z "$*" ] && return 1
-+ local KV="$*"
-+ KV=${KV#*.}
-+ echo ${KV%%.*}
-+}
-+
-+KV_micro() {
-+ [ -z "$*" ] && return 1
-+ local KV="$*"
-+ KV=${KV#*.*.}
-+ echo ${KV%%[![:digit:]]*}
-+}
-+
-+KV_to_int() {
-+ [ -z "$*" ] && return 1
-+ local KV_MAJOR="$(KV_major "$*")"
-+ local KV_MINOR="$(KV_minor "$*")"
-+ local KV_MICRO="$(KV_micro "$*")"
-+ local KV_int="$(( KV_MAJOR * 65536 + KV_MINOR * 256 + KV_MICRO ))"
-+ echo "${KV_int}"
-+}
-+
-+_RC_GET_KV_CACHE=""
-+get_KV() {
-+ [ -z ${_RC_GET_KV_CACHE} ] && _RC_GET_KV_CACHE=$(uname -r)
-+ echo $(KV_to_int "${_RC_GET_KV_CACHE}")
-+}
-+
- _sanitize_path()
- {
- local IFS=":" p= path=
-diff --git a/sh/runtests.sh b/sh/runtests.sh
-index d0d6a17..debcf4f 100755
---- a/sh/runtests.sh
-+++ b/sh/runtests.sh
-@@ -3,6 +3,19 @@
- top_srcdir=${top_srcdir:-..}
- . ${top_srcdir}/test/setup_env.sh
-
-+checkit() {
-+ local output=$($1 $3)
-+ local lret=$?
-+ if [ ${lret} -ne 0 ] ; then
-+ ((tret+=lret))
-+ echo "FAIL: exec: $*"
-+ fi
-+ if [ "${output}" != "$2" ] ; then
-+ ((tret+=lret))
-+ echo "FAIL: output: $* : got='${output}' wanted='$2'"
-+ fi
-+}
-+
- ret=0
-
- tret=0
-@@ -22,4 +35,36 @@ done
- eend ${tret}
- ((ret+=tret))
-
-+compare_int() {
-+ local got=$(KV_to_int $1)
-+ local exp=$(KV_to_int $3)
-+ if ! [ ${got} $2 ${exp} ] ; then
-+ ((tret+=1))
-+ echo "FAIL: KV_to_int '${v}'(${got}) $2 '1.2.2'(${exp})"
-+ fi
-+}
-+
-+tret=0
-+ebegin "Testing KV_{major,minor,micro,to_int}"
-+for v in \
-+ 1.2.3 1.2.3-rc0 1.2.3_rc0 "1.2.3 rc0" \
-+ 1.2.3.4 1.2.3.4-rc0 1.2.3.4_rc0 "1.2.3.4 rc0"
-+do
-+ checkit KV_major 1 ${v}
-+ checkit KV_minor 2 ${v}
-+ checkit KV_micro 3 ${v}
-+
-+ compare_int 1.2.2 -lt ${v}
-+ compare_int 1.2.2.10 -lt ${v}
-+ compare_int 1.2.4 -gt ${v}
-+ compare_int 1.2.4-rc0 -gt ${v}
-+ compare_int 1.2.3 -eq ${v}
-+ compare_int 1.2.3-rc0 -eq ${v}
-+ compare_int 1.2.3.2 -eq ${v}
-+ compare_int 1.2.3.3 -eq ${v}
-+ compare_int 1.2.3.4 -eq ${v}
-+done
-+eend ${tret}
-+((ret+=tret))
-+
- exit ${ret}
---
-1.5.4.4
-
diff --git a/sys-apps/openrc/files/0.4.3/0001-fix-is_older_than.patch b/sys-apps/openrc/files/0.4.3/0001-fix-is_older_than.patch
deleted file mode 100644
index 263e06a000c4..000000000000
--- a/sys-apps/openrc/files/0.4.3/0001-fix-is_older_than.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-Index: src/librc/librc-depend.c
-===================================================================
---- src/librc/librc-depend.c (Revision 1497)
-+++ src/librc/librc-depend.c (Revision 1498)
-@@ -565,27 +565,31 @@
- return true;
-
- if (newer) {
-- if (mtime < buf.st_mtime)
-+ if (mtime < buf.st_mtime) {
-+ if (rel == NULL)
-+ return false;
- retval = false;
-+ }
- if (rel != NULL) {
- if (*rel < buf.st_mtime) {
- if (file)
- strlcpy(file, target, PATH_MAX);
- *rel = buf.st_mtime;
- }
-- } else
-- return retval;
-+ }
- } else {
-- if (mtime > buf.st_mtime)
-+ if (mtime > buf.st_mtime) {
-+ if (rel == NULL)
-+ return false;
- retval = false;
-+ }
- if (rel != NULL) {
- if (*rel > buf.st_mtime) {
- if (file)
- strlcpy(file, target, PATH_MAX);
- *rel = buf.st_mtime;
- }
-- } else
-- return retval;
-+ }
- }
-
- /* If not a dir then reset errno */
diff --git a/sys-apps/openrc/files/0.4.3/0002-support-custom-status.patch b/sys-apps/openrc/files/0.4.3/0002-support-custom-status.patch
deleted file mode 100644
index 7459eacdd3db..000000000000
--- a/sys-apps/openrc/files/0.4.3/0002-support-custom-status.patch
+++ /dev/null
@@ -1,204 +0,0 @@
-Index: openrc-0.4.3/sh/runscript.sh.in
-===================================================================
---- openrc-0.4.3.orig/sh/runscript.sh.in
-+++ openrc-0.4.3/sh/runscript.sh.in
-@@ -45,7 +45,32 @@ describe()
- done
- }
-
--# Template start / stop functions
-+# Report status
-+_status()
-+{
-+ if service_stopping; then
-+ ewarn "status: stopping"
-+ return 4
-+ elif service_starting; then
-+ ewarn "status: starting"
-+ return 8
-+ elif service_inactive; then
-+ ewarn "status: inactive"
-+ return 16
-+ elif service_started; then
-+ if service_crashed; then
-+ eerror "status: crashed"
-+ return 32
-+ fi
-+ einfo "status: started"
-+ return 0
-+ else
-+ einfo "status: stopped"
-+ return 1
-+ fi
-+}
-+
-+# Template start / stop / status functions
- start()
- {
- [ -n "${command}" ] || return 0
-@@ -85,6 +110,11 @@ stop()
- eend $? "Failed to stop ${RC_SVCNAME}"
- }
-
-+status()
-+{
-+ _status
-+}
-+
- yesno ${RC_DEBUG} && set -x
-
- _conf_d=${RC_SERVICE%/*}/../conf.d
-@@ -134,7 +164,7 @@ unset _f
-
- while [ -n "$1" ]; do
- # See if we have the required function and run it
-- for _cmd in describe start stop ${extra_commands:-${opts}} \
-+ for _cmd in describe start stop status ${extra_commands:-${opts}} \
- ${extra_started_commands}; do
- if [ "${_cmd}" = "$1" ]; then
- if [ "$(command -v "$1")" = "$1" ]; then
-Index: openrc-0.4.3/src/rc/Makefile
-===================================================================
---- openrc-0.4.3.orig/src/rc/Makefile
-+++ openrc-0.4.3/src/rc/Makefile
-@@ -18,7 +18,7 @@ RC_BINLINKS= einfon einfo ewarnn ewarn e
- service_starting service_started \
- service_stopping service_stopped \
- service_inactive service_wasinactive \
-- service_hotplugged service_started_daemon \
-+ service_hotplugged service_started_daemon service_crashed \
- checkpath fstabinfo mountinfo rc-depend \
- service_get_value service_set_value get_options save_options \
- shell_var is_newer_than is_older_than
-Index: openrc-0.4.3/src/rc/rc-applets.c
-===================================================================
---- openrc-0.4.3.orig/src/rc/rc-applets.c
-+++ openrc-0.4.3/src/rc/rc-applets.c
-@@ -295,6 +295,10 @@ static int do_service(int argc, char **a
- }
- ok = rc_service_started_daemon(service, exec, NULL, idx);
-
-+ } else if (strcmp(applet, "service_crashed") == 0) {
-+ ok = (_rc_can_find_pids() &&
-+ rc_service_daemons_crashed(service) &&
-+ errno != EACCES);
- } else
- eerrorx("%s: unknown applet", applet);
-
-Index: openrc-0.4.3/src/rc/runscript.c
-===================================================================
---- openrc-0.4.3.orig/src/rc/runscript.c
-+++ openrc-0.4.3/src/rc/runscript.c
-@@ -34,6 +34,7 @@
- #include <sys/file.h>
- #include <sys/param.h>
- #include <sys/stat.h>
-+#include <sys/wait.h>
-
- #include <ctype.h>
- #include <dlfcn.h>
-@@ -412,11 +413,10 @@ write_prefix(const char *buffer, size_t
- return ret;
- }
-
--static bool
-+static int
- svc_exec(const char *arg1, const char *arg2)
- {
-- bool execok;
-- int fdout = fileno(stdout);
-+ int ret, fdout = fileno(stdout);
- struct termios tt;
- struct winsize ws;
- int i;
-@@ -527,13 +527,13 @@ svc_exec(const char *arg1, const char *a
- master_tty = -1;
- }
-
-- execok = rc_waitpid(service_pid) == 0 ? true : false;
-- if (!execok && errno == ECHILD)
-+ ret = WEXITSTATUS(rc_waitpid(service_pid));
-+ if (ret != 0 && errno == ECHILD)
- /* killall5 -9 could cause this */
-- execok = true;
-+ ret = 0;
- service_pid = 0;
-
-- return execok;
-+ return ret;
- }
-
- static bool
-@@ -584,39 +584,6 @@ svc_wait(const char *svc)
- return retval;
- }
-
--static RC_SERVICE
--svc_status(void)
--{
-- char status[10];
-- int (*e) (const char *fmt, ...) EINFO_PRINTF(1, 2) = einfo;
-- RC_SERVICE state = rc_service_state(service);
--
-- if (state & RC_SERVICE_STOPPING) {
-- snprintf(status, sizeof(status), "stopping");
-- e = ewarn;
-- } else if (state & RC_SERVICE_STARTING) {
-- snprintf(status, sizeof(status), "starting");
-- e = ewarn;
-- } else if (state & RC_SERVICE_INACTIVE) {
-- snprintf(status, sizeof(status), "inactive");
-- e = ewarn;
-- } else if (state & RC_SERVICE_STARTED) {
-- errno = 0;
-- if (_rc_can_find_pids() &&
-- rc_service_daemons_crashed(service) &&
-- errno != EACCES)
-- {
-- snprintf(status, sizeof(status), "crashed");
-- e = eerror;
-- } else
-- snprintf(status, sizeof(status), "started");
-- } else
-- snprintf(status, sizeof(status), "stopped");
--
-- e("status: %s", status);
-- return state;
--}
--
- static void
- make_exclusive(void)
- {
-@@ -881,7 +848,7 @@ svc_start(bool deps)
- setenv("IN_BACKGROUND", ibsave, 1);
- hook_out = RC_HOOK_SERVICE_START_DONE;
- rc_plugin_run(RC_HOOK_SERVICE_START_NOW, applet);
-- started = svc_exec("start", NULL);
-+ started = (svc_exec("start", NULL) == 0);
- if (ibsave)
- unsetenv("IN_BACKGROUND");
-
-@@ -1058,7 +1025,7 @@ svc_stop(bool deps)
- setenv("IN_BACKGROUND", ibsave, 1);
- hook_out = RC_HOOK_SERVICE_STOP_DONE;
- rc_plugin_run(RC_HOOK_SERVICE_STOP_NOW, applet);
-- stopped = svc_exec("stop", NULL);
-+ stopped = (svc_exec("stop", NULL) == 0);
- if (ibsave)
- unsetenv("IN_BACKGROUND");
-
-@@ -1383,10 +1350,10 @@ runscript(int argc, char **argv)
- rc_stringlist_free(services);
- services = NULL;
- } else if (strcmp (optarg, "status") == 0) {
-- RC_SERVICE r = svc_status();
-- retval = (int) r;
-- if (retval & RC_SERVICE_STARTED)
-- retval = 0;
-+ save = prefix;
-+ eprefix(NULL);
-+ prefix = NULL;
-+ retval = svc_exec("status", NULL);
- } else {
- if (strcmp(optarg, "conditionalrestart") == 0 ||
- strcmp(optarg, "condrestart") == 0)
diff --git a/sys-apps/openrc/files/0.4.3/0003-command-line-size-fix.patch b/sys-apps/openrc/files/0.4.3/0003-command-line-size-fix.patch
deleted file mode 100644
index 85805b9db03c..000000000000
--- a/sys-apps/openrc/files/0.4.3/0003-command-line-size-fix.patch
+++ /dev/null
@@ -1,94 +0,0 @@
-Index: src/librc/librc.h
-===================================================================
---- src/librc/librc.h (revision 7c81f74b60b9d15ed472f1ca63cab0a105a84c08)
-+++ src/librc/librc.h (revision 6abeec74301d8406ebbbd653b9fe9a0e234c09bf)
-@@ -73,6 +73,4 @@
- #define librc_hidden_def(x) hidden_def(x)
-
--ssize_t rc_getline(char **, size_t *, FILE *);
--
- librc_hidden_proto(rc_config_list)
- librc_hidden_proto(rc_config_load)
-Index: src/librc/rc.h.in
-===================================================================
---- src/librc/rc.h.in (revision c0fd1b49e49cec28c1f5a3a76f9db11c62e550dc)
-+++ src/librc/rc.h.in (revision 6abeec74301d8406ebbbd653b9fe9a0e234c09bf)
-@@ -518,4 +518,8 @@
- RC_PIDLIST *rc_find_pids(const char *, const char *const *, uid_t, pid_t);
-
-+/* getline is a handy glibc function that not all libcs have, so
-+ * we have our own */
-+ssize_t rc_getline(char **, size_t *, FILE *);
-+
- __END_DECLS
- #endif
-Index: src/librc/rc.map
-===================================================================
---- src/librc/rc.map (revision 6615eb4b689d7aa1d047bd9ed75eca80beac9767)
-+++ src/librc/rc.map (revision 6abeec74301d8406ebbbd653b9fe9a0e234c09bf)
-@@ -13,4 +13,5 @@
- rc_environ_fd;
- rc_find_pids;
-+ rc_getline;
- rc_newer_than;
- rc_older_than;
-Index: src/rc/rc.c
-===================================================================
---- src/rc/rc.c
-+++ src/rc/rc.c
-@@ -43,10 +43,6 @@
- #include <sys/utsname.h>
- #include <sys/wait.h>
-
--#ifdef __linux__
--# include <asm/setup.h> /* for COMMAND_LINE_SIZE */
--#endif
--
- #include <errno.h>
- #include <dirent.h>
- #include <ctype.h>
-@@ -176,10 +172,8 @@
- proc_getent(const char *ent)
- {
- FILE *fp;
-- char proc[COMMAND_LINE_SIZE];
-- char *p;
-- char *value = NULL;
-- int i;
-+ char *proc, *p, *value = NULL;
-+ size_t i;
-
- if (!exists("/proc/cmdline"))
- return NULL;
-@@ -189,8 +183,10 @@
- return NULL;
- }
-
-- memset(proc, 0, sizeof(proc));
-- fgets(proc, sizeof(proc), fp);
-+ proc = NULL;
-+ i = 0;
-+ if (rc_getline(&proc, &i, fp) == -1 || proc == NULL)
-+ eerror("rc_getline: %s", strerror(errno));
- if (*proc && (p = strstr(proc, ent))) {
- i = p - proc;
- if (i == '\0' || proc[i - 1] == ' ') {
-@@ -202,6 +198,7 @@
- } else
- errno = ENOENT;
- fclose(fp);
-+ free(proc);
-
- return value;
- }
-Index: src/test/rc.funcs.list
-===================================================================
---- src/test/rc.funcs.list (revision 6615eb4b689d7aa1d047bd9ed75eca80beac9767)
-+++ src/test/rc.funcs.list (revision 6abeec74301d8406ebbbd653b9fe9a0e234c09bf)
-@@ -21,4 +21,6 @@
- rc_find_pids
- rc_find_pids@@RC_1.0
-+rc_getline
-+rc_getline@@RC_1.0
- rc_newer_than
- rc_newer_than@@RC_1.0