summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2012-10-17 16:57:56 +0000
committerWilliam Hubbs <williamh@gentoo.org>2012-10-17 16:57:56 +0000
commit3db11bb6bb5646385a63f8ee72cec23601c559ec (patch)
treea753c7bd270e5a4d5a799a641c80f16903c121d5 /sys-apps/openrc/openrc-9999.ebuild
parentInitial commit wrt bug #317197 (diff)
downloadgentoo-2-3db11bb6bb5646385a63f8ee72cec23601c559ec.tar.gz
gentoo-2-3db11bb6bb5646385a63f8ee72cec23601c559ec.tar.bz2
gentoo-2-3db11bb6bb5646385a63f8ee72cec23601c559ec.zip
Add a warning about adding the appropriate network script to the boot runlevel.
(Portage version: 2.2.0_alpha140/cvs/Linux i686, signed Manifest commit with key 0x30C46538)
Diffstat (limited to 'sys-apps/openrc/openrc-9999.ebuild')
-rw-r--r--sys-apps/openrc/openrc-9999.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/sys-apps/openrc/openrc-9999.ebuild b/sys-apps/openrc/openrc-9999.ebuild
index 3c8f51e43b13..eb5ab3d0a5e2 100644
--- a/sys-apps/openrc/openrc-9999.ebuild
+++ b/sys-apps/openrc/openrc-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/openrc/openrc-9999.ebuild,v 1.109 2012/09/29 20:38:12 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/openrc/openrc-9999.ebuild,v 1.110 2012/10/17 16:57:56 williamh Exp $
EAPI=4
@@ -433,6 +433,16 @@ pkg_postinst() {
# update the dependency tree after touching all files #224171
[[ "${EROOT}" = "/" ]] && "${EROOT}/${LIBDIR}"/rc/bin/rc-depend -u
+ if use newnet; then
+ local netscript=network
+ else
+ local netscript=net.lo
+ fi
+
+ ewarn "Please add the $netscript script to your boot runlevel"
+ ewarn "as soon as possible. Not doing so could leave you with a system"
+ ewarn "without networking."
+
elog "You should now update all files in /etc, using etc-update"
elog "or equivalent before restarting any services or this host."
elog