summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFernando J. Pereda <ferdy@gentoo.org>2007-01-06 00:32:19 +0000
committerFernando J. Pereda <ferdy@gentoo.org>2007-01-06 00:32:19 +0000
commit1de968b21eac96051eedf885ecb886eda5af77b6 (patch)
tree01fa00f2cefd5b9c5c51efa36716671867cfb58b /sys-apps/paludis
parentQA: Removed unused versions. (diff)
downloadgentoo-2-1de968b21eac96051eedf885ecb886eda5af77b6.tar.gz
gentoo-2-1de968b21eac96051eedf885ecb886eda5af77b6.tar.bz2
gentoo-2-1de968b21eac96051eedf885ecb886eda5af77b6.zip
Add a last-minute patch to 'Be less sensitive to vdb_path detection failure'
(Portage version: 2.1.1-r2)
Diffstat (limited to 'sys-apps/paludis')
-rw-r--r--sys-apps/paludis/ChangeLog6
-rw-r--r--sys-apps/paludis/files/paludis-0.14.1-vdb-path.patch17
-rw-r--r--sys-apps/paludis/paludis-0.14.1.ebuild8
3 files changed, 29 insertions, 2 deletions
diff --git a/sys-apps/paludis/ChangeLog b/sys-apps/paludis/ChangeLog
index 7c057b388813..a81177d7ddf6 100644
--- a/sys-apps/paludis/ChangeLog
+++ b/sys-apps/paludis/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/paludis
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/paludis/ChangeLog,v 1.34 2007/01/05 20:05:08 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/paludis/ChangeLog,v 1.35 2007/01/06 00:32:18 ferdy Exp $
+
+ 06 Jan 2007; Fernando J. Pereda <ferdy@gentoo.org>
+ +files/paludis-0.14.1-vdb-path.patch, paludis-0.14.1.ebuild:
+ Add a last-minute patch to 'Be less sensitive to vdb_path detection failure'
*paludis-0.14.1 (05 Jan 2007)
diff --git a/sys-apps/paludis/files/paludis-0.14.1-vdb-path.patch b/sys-apps/paludis/files/paludis-0.14.1-vdb-path.patch
new file mode 100644
index 000000000000..14b7e6e8fc4e
--- /dev/null
+++ b/sys-apps/paludis/files/paludis-0.14.1-vdb-path.patch
@@ -0,0 +1,17 @@
+Index: trunk/ebuild/builtin_unmerge.bash
+===================================================================
+--- ebuild/builtin_unmerge.bash (revision 2126)
++++ ebuild/builtin_unmerge.bash (revision 2127)
+@@ -18,10 +18,11 @@
+
+ builtin_unmerge()
+ {
+- local v=$(vdb_path)
++ local v=$(${PALUDIS_COMMAND} --configuration-variable installed location 2>/dev/null )
+ if [[ -z "${v}" ]] ; then
+ v=${ROOT}/var/db/pkg
+ fi
++
+ local dbdir="${v}/${CATEGORY}/${PF}" entry
+ [[ -d "${dbdir}" ]] || die "couldn't find pkg db directory (\"${dbdir}\")"
+
diff --git a/sys-apps/paludis/paludis-0.14.1.ebuild b/sys-apps/paludis/paludis-0.14.1.ebuild
index 796672faf3ec..f929651ccba0 100644
--- a/sys-apps/paludis/paludis-0.14.1.ebuild
+++ b/sys-apps/paludis/paludis-0.14.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/paludis/paludis-0.14.1.ebuild,v 1.1 2007/01/05 20:05:09 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/paludis/paludis-0.14.1.ebuild,v 1.2 2007/01/06 00:32:18 ferdy Exp $
inherit bash-completion eutils flag-o-matic
@@ -47,6 +47,12 @@ pkg_setup() {
filter-ldflags -Wl,--as-needed --as-needed
}
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-vdb-path.patch
+}
+
src_compile() {
local repositories=`echo default $(usev cran) | tr -s \ ,`
local clients=`echo default $(usev contrarius) | tr -s \ ,`