summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2002-12-23 06:30:36 +0000
committerDaniel Robbins <drobbins@gentoo.org>2002-12-23 06:30:36 +0000
commitdd13860c6debb72d7bde4bae6b303df44c727632 (patch)
tree6ad247e09f425db9c7547856f944a6d6597b0588 /sys-apps/partimage
parentMarked stable. (diff)
downloadgentoo-2-dd13860c6debb72d7bde4bae6b303df44c727632.tar.gz
gentoo-2-dd13860c6debb72d7bde4bae6b303df44c727632.tar.bz2
gentoo-2-dd13860c6debb72d7bde4bae6b303df44c727632.zip
new partimage ebuild (~ masked,) closing bug #11804, and allowing me to begin
to address bug #12260.
Diffstat (limited to 'sys-apps/partimage')
-rw-r--r--sys-apps/partimage/ChangeLog15
-rw-r--r--sys-apps/partimage/files/digest-partimage-0.6.21
-rw-r--r--sys-apps/partimage/partimage-0.6.2.ebuild52
3 files changed, 68 insertions, 0 deletions
diff --git a/sys-apps/partimage/ChangeLog b/sys-apps/partimage/ChangeLog
new file mode 100644
index 000000000000..2d73d7762005
--- /dev/null
+++ b/sys-apps/partimage/ChangeLog
@@ -0,0 +1,15 @@
+# ChangeLog for sys-apps/partimage
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/partimage/ChangeLog,v 1.1 2002/12/23 06:30:36 drobbins Exp $
+
+*partimage-0.6.2 (22 Dec 2002)
+
+ 22 Dec 2002; Daniel Robbins <drobbins@gentoo.org>: added initial release. The
+ original version of this ebuild was submitted in bug #11804 by Derek Young
+ (d@young.hostforweb.com.) Thank you Derek for submitting this ebuild. Several
+ fixes were made to this ebuild but the basic approach remains intact. One
+ thing that make not be fully functional is the creation of SSL certificates,
+ which according to Derek requires the "partimag" user (hacked out of the
+ Makefile) to exist. Files originally intended to be owned by "partimag" are
+ owned by root in this ebuild.
+
diff --git a/sys-apps/partimage/files/digest-partimage-0.6.2 b/sys-apps/partimage/files/digest-partimage-0.6.2
new file mode 100644
index 000000000000..6d5fcacac91f
--- /dev/null
+++ b/sys-apps/partimage/files/digest-partimage-0.6.2
@@ -0,0 +1 @@
+MD5 c52ca81f23876cf9baa0dfcaa44d52ac partimage-0.6.2.tar.bz2 668265
diff --git a/sys-apps/partimage/partimage-0.6.2.ebuild b/sys-apps/partimage/partimage-0.6.2.ebuild
new file mode 100644
index 000000000000..8c30f3557f69
--- /dev/null
+++ b/sys-apps/partimage/partimage-0.6.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/partimage/partimage-0.6.2.ebuild,v 1.1 2002/12/23 06:30:36 drobbins Exp $
+
+DESCRIPTION="Console-based application to efficiently save raw partition data to an image file. Optional encryption/compression support."
+HOMEPAGE="http://www.partimage.org/"
+SRC_URI="http://unc.dl.sourceforge.net/sourceforge/partimage/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="ssl"
+
+RDEPEND="virtual/glibc
+ >=sys-libs/zlib-1.1.4
+ >=dev-libs/lzo-1.08
+ >=dev-libs/newt-0.50.35
+ >=sys-libs/slang-1.4.5-r2
+ ssl? ( >=dev-libs/openssl-0.9.6g )"
+
+RDEPEND="${DEPEND} sys-devel/autoconf"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # Patch Makefile.am so we can take over some of is install work
+ #patch -p1 < ${FILESDIR}/${PF}-gentoo.patch || die "patch failed"
+ autoconf
+}
+
+src_compile() {
+ # SSL is optional
+ local sslconf
+ use ssl || sslconf="--disable-ssl"
+ ./configure \
+ ${sslconf} \
+ --prefix=/usr \
+ --infodir=/usr/share/doc/${PF} \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man || die "./configure failed"
+ cp Makefile Makefile.orig
+ sed -e "s/partimag\.root/root.root/g" Makefile.orig > Makefile
+ emake || die
+}
+
+src_install() {
+ make \
+ prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/doc/${PF} \
+ install || die
+}